summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-07-24 07:09:56 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-07-24 07:09:56 +0000
commit90dc6eb9fb702ff01713ba7063c3dbeebc311e03 (patch)
tree7158d0a53ad2998f7a3606e1075d76f1604a6fc7 /app-shells
parentx11-drivers/xf86-video-intel: Bump to 2.99.914 (diff)
downloadgentoo-2-90dc6eb9fb702ff01713ba7063c3dbeebc311e03.tar.gz
gentoo-2-90dc6eb9fb702ff01713ba7063c3dbeebc311e03.tar.bz2
gentoo-2-90dc6eb9fb702ff01713ba7063c3dbeebc311e03.zip
Revbump to fix a bug in array name expansion. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-4.3_p18-r4.ebuild (renamed from app-shells/bash/bash-4.3_p18-r2.ebuild)4
-rw-r--r--app-shells/bash/files/bash-4.3-indirect-array-element.patch21
3 files changed, 31 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 53e498fbc362..869722c75729 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.374 2014/07/08 08:54:50 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.375 2014/07/24 07:09:55 polynomial-c Exp $
+
+*bash-4.3_p18-r4 (24 Jul 2014)
+
+ 24 Jul 2014; Lars Wendler <polynomial-c@gentoo.org> -bash-4.3_p18-r2.ebuild,
+ +bash-4.3_p18-r4.ebuild, +files/bash-4.3-indirect-array-element.patch:
+ Revbump to fix a bug in array name expansion. Removed old.
*bash-4.3_p18-r3 (08 Jul 2014)
diff --git a/app-shells/bash/bash-4.3_p18-r2.ebuild b/app-shells/bash/bash-4.3_p18-r4.ebuild
index 4d65bc3ddb25..49d33d8c0443 100644
--- a/app-shells/bash/bash-4.3_p18-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p18-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p18-r2.ebuild,v 1.1 2014/06/17 03:58:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p18-r4.ebuild,v 1.1 2014/07/24 07:09:55 polynomial-c Exp $
EAPI="4"
@@ -86,6 +86,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.3-here-doc-ps2-comsub.patch
epatch "${FILESDIR}"/${PN}-4.3-compat-lvl.patch
epatch "${FILESDIR}"/${PN}-4.3-parse-time-keyword.patch
+ epatch "${FILESDIR}"/${PN}-4.3-lastpipe-nested-pipe-segfault.patch
+ epatch "${FILESDIR}"/${PN}-4.3-indirect-array-element.patch
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-indirect-array-element.patch b/app-shells/bash/files/bash-4.3-indirect-array-element.patch
new file mode 100644
index 000000000000..547d00cf914b
--- /dev/null
+++ b/app-shells/bash/files/bash-4.3-indirect-array-element.patch
@@ -0,0 +1,21 @@
+*** ../bash-4.3-patched/subst.c 2014-06-03 09:32:44.000000000 -0400
+--- subst.c 2014-07-23 09:58:19.000000000 -0400
+***************
+*** 7369,7373 ****
+
+ if (want_indir)
+! tdesc = parameter_brace_expand_indir (name + 1, var_is_special, quoted, quoted_dollar_atp, contains_dollar_at);
+ else
+ tdesc = parameter_brace_expand_word (name, var_is_special, quoted, PF_IGNUNBOUND|(pflags&(PF_NOSPLIT2|PF_ASSIGNRHS)), &ind);
+--- 7445,7455 ----
+
+ if (want_indir)
+! {
+! tdesc = parameter_brace_expand_indir (name + 1, var_is_special, quoted, quoted_dollar_atp, contains_dollar_at);
+! /* Turn off the W_ARRAYIND flag because there is no way for this function
+! to return the index we're supposed to be using. */
+! if (tdesc && tdesc->flags)
+! tdesc->flags &= ~W_ARRAYIND;
+! }
+ else
+ tdesc = parameter_brace_expand_word (name, var_is_special, quoted, PF_IGNUNBOUND|(pflags&(PF_NOSPLIT2|PF_ASSIGNRHS)), &ind);