summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-04-08 19:14:27 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-04-08 19:14:27 +0000
commit808c382982c45b43ea09096d9676a04f21e7ee0e (patch)
tree240ff95870bef5c747ef8d542e23131e0755bda1 /app-shells
parentAdded ~ppc. bug 122204 (diff)
downloadgentoo-2-808c382982c45b43ea09096d9676a04f21e7ee0e.tar.gz
gentoo-2-808c382982c45b43ea09096d9676a04f21e7ee0e.tar.bz2
gentoo-2-808c382982c45b43ea09096d9676a04f21e7ee0e.zip
This version contains a fix for a build issue on some Power-based systems, as well as a fix for a bug causing fish to sometimes return from a job before all its processes finished.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog9
-rw-r--r--app-shells/fish/files/digest-fish-1.21.43
-rw-r--r--app-shells/fish/fish-1.21.4.ebuild44
3 files changed, 55 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index debf0dd4cad0..5470cfc15bc7 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.17 2006/04/08 19:07:28 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.18 2006/04/08 19:14:27 spyderous Exp $
+
+*fish-1.21.4 (08 Apr 2006)
+
+ 08 Apr 2006; Donnie Berkholz <spyderous@gentoo.org>; +fish-1.21.4.ebuild:
+ This version contains a fix for a build issue on some Power-based systems,
+ as well as a fix for a bug causing fish to sometimes return from a job
+ before all its processes finished.
08 Apr 2006; Donnie Berkholz <spyderous@gentoo.org>; fish-1.18.2.ebuild,
fish-1.19.0.ebuild, fish-1.20.0.ebuild, fish-1.20.1.ebuild,
diff --git a/app-shells/fish/files/digest-fish-1.21.4 b/app-shells/fish/files/digest-fish-1.21.4
new file mode 100644
index 000000000000..86b4d1dc2415
--- /dev/null
+++ b/app-shells/fish/files/digest-fish-1.21.4
@@ -0,0 +1,3 @@
+MD5 baff3cfd7fd256815c5d3dc38cfbc277 fish-1.21.4.tar.bz2 565665
+RMD160 36fb5963abf0de9e0f102ed890cf7188234e6662 fish-1.21.4.tar.bz2 565665
+SHA256 8081c4fa8963d5902d2f7170638fe6157bd7796e14f9f94e5002d5cedb30c87d fish-1.21.4.tar.bz2 565665
diff --git a/app-shells/fish/fish-1.21.4.ebuild b/app-shells/fish/fish-1.21.4.ebuild
new file mode 100644
index 000000000000..560a946293d2
--- /dev/null
+++ b/app-shells/fish/fish-1.21.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.21.4.ebuild,v 1.1 2006/04/08 19:14:27 spyderous Exp $
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://roo.no-ip.org/fish/"
+SRC_URI="http://roo.no-ip.org/fish/files/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="sys-libs/ncurses
+ sys-devel/bc
+ www-client/htmlview
+ || ( (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to use fish as your default shell, you need to add it"
+ einfo "to /etc/shells. This is not recommended because fish doesn't install"
+ einfo "to /bin."
+ einfo
+ ewarn "Many files moved to ${ROOT}usr/share/fish/completions from /etc/fish.d/."
+ ewarn "Delete everything in ${ROOT}etc/fish.d/ except fish_interactive.fish."
+ ewarn "Otherwise, fish won't notice updates to the installed files,"
+ ewarn "because the ones in /etc will override the new ones in /usr."
+ einfo
+}