summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2011-05-16 10:36:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2011-05-16 10:36:26 +0000
commit6bb01b7ad1fbb9bb54c69b2622ccfdb13c2687f2 (patch)
treec458221da4f1262b29b6a32656ed0dc6b0b44c15 /app-shells
parentEnhanced messaging with REPLACING_VERSIONS, correct upgrade link. (diff)
downloadgentoo-2-6bb01b7ad1fbb9bb54c69b2622ccfdb13c2687f2.tar.gz
gentoo-2-6bb01b7ad1fbb9bb54c69b2622ccfdb13c2687f2.tar.bz2
gentoo-2-6bb01b7ad1fbb9bb54c69b2622ccfdb13c2687f2.zip
Rewrite /bin/sh symlink atomically, bug #367241
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-3.2_p51.ebuild6
-rw-r--r--app-shells/bash/bash-4.0_p38.ebuild6
-rw-r--r--app-shells/bash/bash-4.1_p10.ebuild6
-rw-r--r--app-shells/bash/bash-4.1_p11.ebuild6
-rw-r--r--app-shells/bash/bash-4.1_p7.ebuild8
-rw-r--r--app-shells/bash/bash-4.1_p9.ebuild6
-rw-r--r--app-shells/bash/bash-4.2_p10.ebuild6
-rw-r--r--app-shells/bash/bash-4.2_p8-r1.ebuild6
9 files changed, 40 insertions, 18 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 79f5cccc6be0..50bebadc0dd7 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.288 2011/05/09 14:56:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.289 2011/05/16 10:36:26 nyhm Exp $
+
+ 16 May 2011; Tristan Heaven <nyhm@gentoo.org> bash-3.2_p51.ebuild,
+ bash-4.0_p38.ebuild, bash-4.1_p7.ebuild, bash-4.1_p9.ebuild,
+ bash-4.1_p10.ebuild, bash-4.1_p11.ebuild, bash-4.2_p8-r1.ebuild,
+ bash-4.2_p10.ebuild:
+ Rewrite /bin/sh symlink atomically, bug #367241
*bash-4.2_p10 (09 May 2011)
*bash-4.1_p11 (09 May 2011)
diff --git a/app-shells/bash/bash-3.2_p51.ebuild b/app-shells/bash/bash-3.2_p51.ebuild
index 158fe93df44c..7d8afe55afb2 100644
--- a/app-shells/bash/bash-3.2_p51.ebuild
+++ b/app-shells/bash/bash-3.2_p51.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p51.ebuild,v 1.2 2011/02/06 17:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p51.ebuild,v 1.3 2011/05/16 10:36:26 nyhm Exp $
EAPI=1
@@ -173,7 +173,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.0_p38.ebuild b/app-shells/bash/bash-4.0_p38.ebuild
index 75d805434004..2713510b93a8 100644
--- a/app-shells/bash/bash-4.0_p38.ebuild
+++ b/app-shells/bash/bash-4.0_p38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p38.ebuild,v 1.2 2011/02/06 17:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p38.ebuild,v 1.3 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -167,7 +167,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.1_p10.ebuild b/app-shells/bash/bash-4.1_p10.ebuild
index 24127078b5a5..e667be74ecc4 100644
--- a/app-shells/bash/bash-4.1_p10.ebuild
+++ b/app-shells/bash/bash-4.1_p10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p10.ebuild,v 1.1 2011/02/28 18:25:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p10.ebuild,v 1.2 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -176,7 +176,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.1_p11.ebuild b/app-shells/bash/bash-4.1_p11.ebuild
index 067465619009..8baa37e2978c 100644
--- a/app-shells/bash/bash-4.1_p11.ebuild
+++ b/app-shells/bash/bash-4.1_p11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p11.ebuild,v 1.1 2011/05/09 14:56:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p11.ebuild,v 1.2 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -176,7 +176,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.1_p7.ebuild b/app-shells/bash/bash-4.1_p7.ebuild
index 566614fde5a5..9e9d43c6067a 100644
--- a/app-shells/bash/bash-4.1_p7.ebuild
+++ b/app-shells/bash/bash-4.1_p7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p7.ebuild,v 1.8 2010/10/09 19:16:50 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p7.ebuild,v 1.9 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -176,7 +176,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.1_p9.ebuild b/app-shells/bash/bash-4.1_p9.ebuild
index b8e1e96df53a..959a77dd82b2 100644
--- a/app-shells/bash/bash-4.1_p9.ebuild
+++ b/app-shells/bash/bash-4.1_p9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p9.ebuild,v 1.7 2011/02/28 23:54:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1_p9.ebuild,v 1.8 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -176,7 +176,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.2_p10.ebuild b/app-shells/bash/bash-4.2_p10.ebuild
index d27905892af9..0fba62b07a90 100644
--- a/app-shells/bash/bash-4.2_p10.ebuild
+++ b/app-shells/bash/bash-4.2_p10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p10.ebuild,v 1.1 2011/05/09 14:56:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p10.ebuild,v 1.2 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -167,7 +167,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}
diff --git a/app-shells/bash/bash-4.2_p8-r1.ebuild b/app-shells/bash/bash-4.2_p8-r1.ebuild
index eec2374e6d7b..8380bb20b08a 100644
--- a/app-shells/bash/bash-4.2_p8-r1.ebuild
+++ b/app-shells/bash/bash-4.2_p8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p8-r1.ebuild,v 1.1 2011/04/29 22:54:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p8-r1.ebuild,v 1.2 2011/05/16 10:36:26 nyhm Exp $
EAPI="1"
@@ -168,7 +168,9 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
+ local tmp=$(emktemp "${ROOT}"/bin)
+ ln -sf "${target}" "${tmp}"
+ mv -f "${tmp}" "${ROOT}"/bin/sh
fi
}