summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-16 00:13:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-16 00:13:33 +0000
commit447d2a02ce12bd43110156f86367d998d05fb18d (patch)
tree998751900557c0fefddea5031108df9b0796cdea /app-shells
parentSupport pkg-config and the new upstream completions directory structure wrt #... (diff)
downloadgentoo-2-447d2a02ce12bd43110156f86367d998d05fb18d.tar.gz
gentoo-2-447d2a02ce12bd43110156f86367d998d05fb18d.tar.bz2
gentoo-2-447d2a02ce12bd43110156f86367d998d05fb18d.zip
Migrate to upstream build system and directory structure wrt #472938
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 275d053b4c81..afa378585d58 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.251 2013/06/17 13:37:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.252 2013/07/16 00:13:33 ssuominen Exp $
+
+*bash-completion-2.1-r1 (16 Jul 2013)
+
+ 16 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +bash-completion-2.1-r1.ebuild:
+ Migrate to upstream build system and directory structure wrt #472938
17 Jun 2013; Jeroen Roovers <jer@gentoo.org> bash-completion-2.1.ebuild:
Remove nmcli completion (bug #472844).
diff --git a/app-shells/bash-completion/bash-completion-2.1-r1.ebuild b/app-shells/bash-completion/bash-completion-2.1-r1.ebuild
new file mode 100644
index 000000000000..2bf6a2b7e776
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-2.1-r1.ebuild,v 1.1 2013/07/16 00:13:33 ssuominen Exp $
+
+EAPI=5
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="|| ( >=app-shells/bash-4.1 app-shells/zsh )
+ sys-apps/miscfiles
+ !<app-shells/gentoo-bashcomp-20130101" #472938#c1
+
+src_install() {
+ default
+
+ # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
+ # becomes dead symlinks as a result
+ local file
+ for file in cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake; do
+ rm -f "${ED}"/usr/share/bash-completion/completions/${file}
+ done
+
+ # use the copy from app-editors/vim-core:
+ rm -f "${ED}"/usr/share/bash-completion/completions/xxd
+
+ # use the copy from net-misc/networkmanager:
+ rm -f "${ED}"/usr/share/bash-completion/completions/nmcli
+
+ dodoc AUTHORS CHANGES README
+}
+
+pkg_postinst() {
+ if has_version 'app-shells/zsh'; then
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}