summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-26 22:15:00 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-26 22:15:00 +0000
commit31262b97ea1ff17a125e6750305cc717a220f96d (patch)
treef74bce2fc94cbcde45c83862507679cce798d2ad /app-shells
parentAlso fix bug #342801 for old version. (diff)
downloadgentoo-2-31262b97ea1ff17a125e6750305cc717a220f96d.tar.gz
gentoo-2-31262b97ea1ff17a125e6750305cc717a220f96d.tar.bz2
gentoo-2-31262b97ea1ff17a125e6750305cc717a220f96d.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/autojump/ChangeLog11
-rw-r--r--app-shells/autojump/autojump-13.ebuild55
-rw-r--r--app-shells/autojump/metadata.xml10
3 files changed, 76 insertions, 0 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
new file mode 100644
index 000000000000..1988fe2b2dc7
--- /dev/null
+++ b/app-shells/autojump/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-shells/autojump
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.1 2010/10/26 22:15:00 xmw Exp $
+
+*autojump-13 (26 Oct 2010)
+
+ 26 Oct 2010; Michael Weber <xmw@gentoo.org> +autojump-13.ebuild,
+ +metadata.xml:
+ Initial import fixes 335401, thanks to Olivier Mehani
+ <shtrom-gentoo@ssji.net> for the initial ebuild.
+
diff --git a/app-shells/autojump/autojump-13.ebuild b/app-shells/autojump/autojump-13.ebuild
new file mode 100644
index 000000000000..cc4d46dafcbb
--- /dev/null
+++ b/app-shells/autojump/autojump-13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-13.ebuild,v 1.1 2010/10/26 22:15:00 xmw Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+MY_P=${PN}_v${PV}
+SRC_URI="http://github.com/downloads/joelthelion/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion gtk zsh-completion"
+
+RDEPEND="gtk? ( dev-python/pygtk:2 )
+ bash-completion? ( >=app-shells/bash-4 )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ dobin autojump || die
+
+ if use gtk ; then
+ dobin jumpapplet || die
+ insinto /usr/share/${PN}
+ doins icon.png || die
+ fi
+
+ insinto /etc/profile.d
+ doins ${PN}.sh || die
+
+ if use bash-completion ; then
+ doins ${PN}.bash || die
+ fi
+
+ if use zsh-completion ; then
+ doins ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ doins _j || die
+ fi
+
+ doman ${PN}.1 || die
+ dodoc README.rst || die
+}
diff --git a/app-shells/autojump/metadata.xml b/app-shells/autojump/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/app-shells/autojump/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+