summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-30 07:00:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-30 07:00:26 +0000
commit02c1d10274e0dd50853052a114461ad1e01b9ad0 (patch)
tree893c6834099b115cf37337df622483bb2a7e7f01 /app-shells
parentFix typo in french translation #75693 by DELACOUR Guillaume. (diff)
downloadgentoo-2-02c1d10274e0dd50853052a114461ad1e01b9ad0.tar.gz
gentoo-2-02c1d10274e0dd50853052a114461ad1e01b9ad0.tar.bz2
gentoo-2-02c1d10274e0dd50853052a114461ad1e01b9ad0.zip
Add patch to handle trapped signals in scripts better.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-3.0-r11.ebuild4
-rw-r--r--app-shells/bash/files/bash-3.0-trap-fg-signals.patch23
3 files changed, 31 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 4f3fe85285af..c4b917392a66 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.62 2005/04/30 00:08:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.63 2005/04/30 07:00:26 vapier Exp $
+
+ 30 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.0-trap-fg-signals.patch, bash-3.0-r11.ebuild:
+ Add patch to handle trapped signals in scripts better.
30 Apr 2005; Mike Frysinger <vapier@gentoo.org> +files/dot-bash_logout,
+files/dot-bash_profile, +files/dot-bashrc, bash-3.0-r11.ebuild:
diff --git a/app-shells/bash/bash-3.0-r11.ebuild b/app-shells/bash/bash-3.0-r11.ebuild
index 65629541fb3b..d690d25cea2b 100644
--- a/app-shells/bash/bash-3.0-r11.ebuild
+++ b/app-shells/bash/bash-3.0-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.2 2005/04/30 00:08:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.3 2005/04/30 07:00:26 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -56,6 +56,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-{afs,crash,jobs,manpage,pwd,read-e-segfault,ulimit}.patch
# Fix read-builtin and the -u pipe option #87093
epatch "${FILESDIR}"/${P}-read-builtin-pipe.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${P}-trap-fg-signals.patch
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/files/bash-3.0-trap-fg-signals.patch b/app-shells/bash/files/bash-3.0-trap-fg-signals.patch
new file mode 100644
index 000000000000..f28c09af5521
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-trap-fg-signals.patch
@@ -0,0 +1,23 @@
+Don't barf on handled signals inside of scripts. Makes for nicer output.
+
+patch by Martin Schlemmer <azarah@gentoo.org>
+
+--- jobs.c
++++ jobs.c
+@@ -2893,11 +2893,11 @@
+ }
+ else if (IS_FOREGROUND (job))
+ {
+-#if !defined (DONT_REPORT_SIGPIPE)
+- if (termsig && WIFSIGNALED (s) && termsig != SIGINT)
+-#else
+- if (termsig && WIFSIGNALED (s) && termsig != SIGINT && termsig != SIGPIPE)
+-#endif
++ if (termsig && WIFSIGNALED (s) && termsig != SIGINT &&
++#if !defined (DONT_REPORT_SIGPIPE)
++ termsig != SIGPIPE &&
++#endif
++ signal_is_trapped (termsig) == 0)
+ {
+ fprintf (stderr, "%s", j_strsignal (termsig));
+