summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-06-18 21:04:04 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-06-18 21:04:04 +0000
commit19cfbea0eb18554d68944b0debdd6fde0f768b5a (patch)
tree61e45979c22368858d171653e51224c9a0862299 /app-shells/dash
parentNew eselect module for switching BLAS implementations. (diff)
downloadgentoo-2-19cfbea0eb18554d68944b0debdd6fde0f768b5a.tar.gz
gentoo-2-19cfbea0eb18554d68944b0debdd6fde0f768b5a.tar.bz2
gentoo-2-19cfbea0eb18554d68944b0debdd6fde0f768b5a.zip
Version bump.
(Portage version: 2.1)
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/ChangeLog9
-rw-r--r--app-shells/dash/dash-0.5.3.3.ebuild47
-rw-r--r--app-shells/dash/files/digest-dash-0.5.3.36
3 files changed, 60 insertions, 2 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 4c721181cc4b..3e31f036ccd3 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/dash
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.31 2005/10/27 17:10:53 ka0ttic Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.32 2006/06/18 21:04:04 exg Exp $
+
+*dash-0.5.3.3 (18 Jun 2006)
+
+ 18 Jun 2006; Emanuele Giaquinta <exg@gentoo.org> +dash-0.5.3.3.ebuild:
+ Version bump.
*dash-0.5.2.8 (27 Oct 2005)
diff --git a/app-shells/dash/dash-0.5.3.3.ebuild b/app-shells/dash/dash-0.5.3.3.ebuild
new file mode 100644
index 000000000000..be2a00ecf81e
--- /dev/null
+++ b/app-shells/dash/dash-0.5.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.3.ebuild,v 1.1 2006/06/18 21:04:04 exg Exp $
+
+inherit eutils versionator flag-o-matic toolchain-funcs
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P="${MY_P2/_/-}"
+
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="static"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ dev-util/yacc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${DEB_P}.diff
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ export CC="$(tc-getCC)"
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+ newman src/dash.1 dash.1
+ dodoc COPYING ChangeLog
+}
diff --git a/app-shells/dash/files/digest-dash-0.5.3.3 b/app-shells/dash/files/digest-dash-0.5.3.3
new file mode 100644
index 000000000000..3a812e7045c6
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.3.3
@@ -0,0 +1,6 @@
+MD5 d90f816432ab5055f37abf0441018bf6 dash_0.5.3-3.diff.gz 26636
+RMD160 35609c510d0b4bcf0a4c9101ad97d1100711b10d dash_0.5.3-3.diff.gz 26636
+SHA256 8f70dfec8f1f1c72da38cec2f94b2ad6f9af825cd6ff3d945369a98fbd89eb07 dash_0.5.3-3.diff.gz 26636
+MD5 1a3cd6669459be4344ec55ec9d4914f8 dash_0.5.3.orig.tar.gz 207201
+RMD160 fd445535708868fe206852320eece58c3c2bbbaf dash_0.5.3.orig.tar.gz 207201
+SHA256 82aab2ff63e5fac4bff35c91222f735ec67551db86b5c3b3455ecc10e8889e53 dash_0.5.3.orig.tar.gz 207201