summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-27 00:43:38 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-27 00:43:38 +0000
commit4f9306d492ac18bb885e5b73d08fa46f293f5db4 (patch)
tree696e59d4fe42e20c57650ed98b22f95665c10346 /app-shells/bash
parentamd64 stable - 259936 (diff)
downloadgentoo-2-4f9306d492ac18bb885e5b73d08fa46f293f5db4.tar.gz
gentoo-2-4f9306d492ac18bb885e5b73d08fa46f293f5db4.tar.bz2
gentoo-2-4f9306d492ac18bb885e5b73d08fa46f293f5db4.zip
Fix from upstream for regression with subshells/herestrings found via revdep-rebuild script.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-4.0.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.0-comsub-herestring.patch22
3 files changed, 30 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 2dc67133dd79..b4e57eab04dc 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.207 2009/02/26 22:21:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.208 2009/02/27 00:43:38 vapier Exp $
+
+ 27 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-4.0-comsub-herestring.patch, bash-4.0.ebuild:
+ Fix from upstream for regression with subshells/herestrings found via
+ revdep-rebuild script.
26 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+files/bash-4.0-associative-array-subscripts.patch, bash-4.0.ebuild:
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index bb8572fd8d18..84aaf94949b1 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.11 2009/02/26 22:21:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.12 2009/02/27 00:43:38 vapier Exp $
EAPI="1"
@@ -75,6 +75,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-reset-parser-current-token.patch
epatch "${FILESDIR}"/${P}-pipeline-reserved-word.patch
epatch "${FILESDIR}"/${P}-associative-array-subscripts.patch
+ epatch "${FILESDIR}"/${P}-comsub-herestring.patch
epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
# Log bash commands to syslog #91327
if use bashlogger ; then
diff --git a/app-shells/bash/files/bash-4.0-comsub-herestring.patch b/app-shells/bash/files/bash-4.0-comsub-herestring.patch
new file mode 100644
index 000000000000..d30e271c9dee
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-comsub-herestring.patch
@@ -0,0 +1,22 @@
+http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00230.html
+
+*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
+--- parse.y 2009-02-26 17:22:15.000000000 -0500
+***************
+*** 3395,3400 ****
+ else
+ shell_ungetc (peekc);
+! tflags |= LEX_HEREDELIM;
+! lex_firstind = -1;
+ continue;
+ }
+--- 3402,3410 ----
+ else
+ shell_ungetc (peekc);
+! if (peekc != '<')
+! {
+! tflags |= LEX_HEREDELIM;
+! lex_firstind = -1;
+! }
+ continue;
+ }