summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-06 14:15:21 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-06 14:15:21 +0000
commitac907e8389b930b37b05b6417a973ef17a84dd2d (patch)
tree444aed9fb05a2939ebc5d81c56b8e6ad4fa999e9 /app-shells/bash-completion-config
parentVersion bump. (diff)
downloadgentoo-2-ac907e8389b930b37b05b6417a973ef17a84dd2d.tar.gz
gentoo-2-ac907e8389b930b37b05b6417a973ef17a84dd2d.tar.bz2
gentoo-2-ac907e8389b930b37b05b6417a973ef17a84dd2d.zip
Revision bump; updated completion function to ignore *~. Keeping keywords.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-shells/bash-completion-config')
-rw-r--r--app-shells/bash-completion-config/ChangeLog8
-rw-r--r--app-shells/bash-completion-config/Manifest11
-rw-r--r--app-shells/bash-completion-config/bash-completion-config-0.8-r1.ebuild41
-rw-r--r--app-shells/bash-completion-config/files/bashcomp111
-rw-r--r--app-shells/bash-completion-config/files/digest-bash-completion-config-0.8-r11
5 files changed, 167 insertions, 5 deletions
diff --git a/app-shells/bash-completion-config/ChangeLog b/app-shells/bash-completion-config/ChangeLog
index c07d4ab05f09..bcc8cf4139fc 100644
--- a/app-shells/bash-completion-config/ChangeLog
+++ b/app-shells/bash-completion-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion-config
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/ChangeLog,v 1.31 2005/03/30 16:09:23 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/ChangeLog,v 1.32 2005/04/06 14:15:21 ka0ttic Exp $
+
+*bash-completion-config-0.8-r1 (06 Apr 2005)
+
+ 06 Apr 2005; Aaron Walker <ka0ttic@gentoo.org> +files/bashcomp,
+ +bash-completion-config-0.8-r1.ebuild:
+ Revision bump; updated completion function to ignore *~. Keeping keywords.
30 Mar 2005; Michael Hanselmann <hansmi@gentoo.org>
bash-completion-config-0.8.ebuild:
diff --git a/app-shells/bash-completion-config/Manifest b/app-shells/bash-completion-config/Manifest
index 0622cbb47945..c8bf06b052c7 100644
--- a/app-shells/bash-completion-config/Manifest
+++ b/app-shells/bash-completion-config/Manifest
@@ -1,6 +1,9 @@
-MD5 99ce5509db4b50f28a1f6675f8c09b2b metadata.xml 258
-MD5 4dda558384ab4e4307bfdf04de7478f1 ChangeLog 4988
-MD5 11db45bbec40f85c7e6bc6e8e92f8a1d bash-completion-config-0.7.ebuild 1197
+MD5 65a6c0533045f034a789888e559172d2 bash-completion-config-0.8-r1.ebuild 1301
MD5 ee2ff44da98eaf47bfa809c4c45d1aed bash-completion-config-0.8.ebuild 1197
-MD5 4867900c2f58751082d053b8519e359f files/digest-bash-completion-config-0.8 72
+MD5 11db45bbec40f85c7e6bc6e8e92f8a1d bash-completion-config-0.7.ebuild 1197
+MD5 d3fef64f55a5036839f86370ff237657 ChangeLog 5219
+MD5 99ce5509db4b50f28a1f6675f8c09b2b metadata.xml 258
MD5 7350eb647c4ed74167513478041f538f files/digest-bash-completion-config-0.7 72
+MD5 4867900c2f58751082d053b8519e359f files/digest-bash-completion-config-0.8 72
+MD5 4867900c2f58751082d053b8519e359f files/digest-bash-completion-config-0.8-r1 72
+MD5 89fcdca3033fc8367e34122240a20cae files/bashcomp 3182
diff --git a/app-shells/bash-completion-config/bash-completion-config-0.8-r1.ebuild b/app-shells/bash-completion-config/bash-completion-config-0.8-r1.ebuild
new file mode 100644
index 000000000000..8913318d7b79
--- /dev/null
+++ b/app-shells/bash-completion-config/bash-completion-config-0.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/bash-completion-config-0.8-r1.ebuild,v 1.1 2005/04/06 14:15:21 ka0ttic Exp $
+
+MY_PN="bashcomp-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Utility to easily add/remove bash-completions to your environment"
+HOMEPAGE="http://developer.berlios.de/projects/bashcomp-config/"
+SRC_URI="http://download.berlios.de/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc64 ~ppc-macos s390 sparc x86"
+IUSE=""
+
+DEPEND=">=app-shells/bash-2.05"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO ChangeLog README
+
+ insinto /usr/share/bash-completion
+ newins ${FILESDIR}/bashcomp ${PN} || die "failed to install bashcomp"
+}
+
+# remove files that bashcomp-config provides for non-Gentoo platforms
+pkg_preinst() {
+ [[ -e ${ROOT}/etc/profile.d/bash-completion ]] && rm -fr ${D}/etc
+ rm -fr ${D}/usr/share/${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable command-line completion for bash-completion-config,"
+ einfo "run the following as root:"
+ einfo
+ einfo " bash-completion-config --global --install bash-completion-config"
+ echo
+}
diff --git a/app-shells/bash-completion-config/files/bashcomp b/app-shells/bash-completion-config/files/bashcomp
new file mode 100644
index 000000000000..64cf7df8abc3
--- /dev/null
+++ b/app-shells/bash-completion-config/files/bashcomp
@@ -0,0 +1,111 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: bashcomp,v 1.1 2005/04/06 14:15:21 ka0ttic Exp $
+#
+# Author: Aaron Walker <ka0ttic%gentoo.org>
+#
+# completion for bash-completion-config
+
+# echo all completions in BASHCOMP_DIR
+complete_avail()
+{
+ local bashcomp BASHCOMP_DIR="/usr/share/bash-completion"
+ for bashcomp in $BASHCOMP_DIR/* ; do
+ echo -n "${bashcomp##*/} "
+ done
+}
+
+# echo all installed completions in $1
+complete_installed()
+{
+ local bashcomp
+ for bashcomp in $1/* ; do
+ echo -n "${bashcomp##*/} "
+ done
+}
+
+# show completions for $1
+complete_on()
+{
+ local cur="$1"
+
+ case "$2" in
+ install)
+ COMPREPLY=($(compgen -f -X '*~' -W "$(complete_avail)" -- "${cur}"))
+ ;;
+ uninstall)
+ if [ -z "$3" ] ; then
+ COMPREPLY=($(compgen -X '*~' -W "$(complete_installed \
+ ${HOME}/.bash_completion.d)" -- "${cur}"))
+ else
+ COMPREPLY=($(compgen -X '*~' -W "$(complete_installed \
+ /etc/bash_completion.d)" -- "${cur}"))
+ fi
+ ;;
+ esac
+}
+
+_bash_completion_config()
+{
+ local cur prev opts i a=0
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-g --global -l --list -i --install -u --uninstall -h --help -d --debug -V --version -nc --nocolor"
+
+ if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=($(compgen -W "${opts}" -- "${cur}"))
+ return 0
+ fi
+
+ case "${prev}" in
+ -nc|--nocolor|--nocolour)
+ COMPREPLY=($(compgen -W "${opts/-nc --nocolor/}" -- "${cur}"))
+ ;;
+ -d|--debug)
+ COMPREPLY=($(compgen -W "${opts/-d --debug/}" -- "${cur}"))
+ ;;
+ -g|--global)
+ for i in ${COMP_WORDS[@]} ; do
+ [[ "${i}" == "-i" || "${i}" == "--install" ||
+ "${i}" == "-u" || "${i}" == "--uninstall" ]] && a=1
+ [[ "${i}" == "-nc" || "${i}" == "--nocolor" ||
+ "${i}" == "--nocolour" ]] && a=1
+ done
+
+ if [ ${a} -gt 0 ] ; then
+ action=install
+ complete_on "${cur}" "${action}"
+ else
+ COMPREPLY=($(compgen -W "-i --install -u --uninstall" -- "${cur}"))
+ fi
+ ;;
+ -i|--install)
+ action=install
+ complete_on "${cur}" "${action}"
+ ;;
+ -u|--uninstall)
+ action=uninstall
+
+ for i in ${COMP_WORDS[@]} ; do
+ if [[ "${i}" == "-g" || "${i}" == "--global" ]] ; then
+ global=1
+ fi
+ done
+
+ if [ -z "${global}" ] ; then
+ complete_on "${cur}" "${action}"
+ else
+ complete_on "${cur}" "${action}" glob
+ fi
+ ;;
+ *)
+ [ -n "${action}" ] && complete_on "${cur}" "${action}"
+ ;;
+ esac
+
+ unset global
+}
+complete -F _bash_completion_config bash-completion-config
+
+# vim: set ft=sh tw=80 sw=4 et :
diff --git a/app-shells/bash-completion-config/files/digest-bash-completion-config-0.8-r1 b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.8-r1
new file mode 100644
index 000000000000..d094e4018e48
--- /dev/null
+++ b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.8-r1
@@ -0,0 +1 @@
+MD5 b9b9dddc10b01d0679559a78a7d04f7f bashcomp-config-0.8.tar.bz2 108587