summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-11-01 00:45:17 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-11-01 00:45:17 +0000
commited0a91663c1022e859e0cce20a504f581a3dc066 (patch)
tree60289730f96940d63aef511feaead0b1889ca9f1 /app-sci
parent~alpha keyword. (Manifest recommit) (diff)
downloadgentoo-2-ed0a91663c1022e859e0cce20a504f581a3dc066.tar.gz
gentoo-2-ed0a91663c1022e859e0cce20a504f581a3dc066.tar.bz2
gentoo-2-ed0a91663c1022e859e0cce20a504f581a3dc066.zip
Replaced ${GCC} with tc-getCC.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/blas-atlas/ChangeLog5
-rw-r--r--app-sci/blas-atlas/blas-atlas-3.6.0.ebuild10
2 files changed, 8 insertions, 7 deletions
diff --git a/app-sci/blas-atlas/ChangeLog b/app-sci/blas-atlas/ChangeLog
index 635e46a5c1af..a9da0c116a87 100644
--- a/app-sci/blas-atlas/ChangeLog
+++ b/app-sci/blas-atlas/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/blas-atlas
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.16 2004/10/10 18:43:08 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.17 2004/11/01 00:45:17 ribosome Exp $
+
+ 31 Oct 2004; Olivier Fisette <ribosome@gentoo.org> blas-atlas-3.6.0.ebuild:
+ Replaced ${GCC} by tc-getCC from toolchain-funcs.
10 Oct 2004; Danny van Dyk <kugelfang@gentoo.org> blas-atlas-3.6.0.ebuild:
Marked stable on x86 and ppc.
diff --git a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
index 06012f37b706..295e3660ee77 100644
--- a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
+++ b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.15 2004/10/10 18:43:08 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.16 2004/11/01 00:45:17 ribosome Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
HOMEPAGE="http://math-atlas.sourceforge.net/"
@@ -79,15 +79,13 @@ src_compile() {
# Libraries will be installed in ${RPATH}/atlas and ${RPATH}/threaded-atlas:
RPATH="${DESTTREE}/lib/blas"
- GCC="gcc"
-
if [ -n "${interactive}" ]
then
echo "${interactive}"
- make config CC="${GCC} -DUSE_LIBTOOL -DINTERACTIVE" || die
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
else
# Use ATLAS defaults for all questions:
- (echo | make config CC="${GCC} -DUSE_LIBTOOL") || atlas_fail
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
fi
if [ "${ARCH}" == "sparc" ]; then