summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-08-20 21:57:07 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-08-20 21:57:07 +0000
commit265ea6695d377d0aefa7fadb0fa6d3cda5e1a698 (patch)
tree2f8e582684f63b681a3c3e9a85d27e8895f3e0fb /app-sci
parentstable on ppc64, bug #58505 (Manifest recommit) (diff)
downloadgentoo-2-265ea6695d377d0aefa7fadb0fa6d3cda5e1a698.tar.gz
gentoo-2-265ea6695d377d0aefa7fadb0fa6d3cda5e1a698.tar.bz2
gentoo-2-265ea6695d377d0aefa7fadb0fa6d3cda5e1a698.zip
Minor Compile fixes. ~amd64
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/labplot/ChangeLog6
-rw-r--r--app-sci/labplot/files/labplot-1.3.0-amd64.patch22
-rw-r--r--app-sci/labplot/labplot-1.3.0.ebuild18
3 files changed, 36 insertions, 10 deletions
diff --git a/app-sci/labplot/ChangeLog b/app-sci/labplot/ChangeLog
index bae3f8cebc55..f46516078e7a 100644
--- a/app-sci/labplot/ChangeLog
+++ b/app-sci/labplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/labplot
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/labplot/ChangeLog,v 1.6 2004/07/27 02:58:00 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/labplot/ChangeLog,v 1.7 2004/08/20 21:57:07 kugelfang Exp $
+
+ 20 Aug 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/labplot-1.3.0-amd64.patch, labplot-1.3.0.ebuild:
+ Marked ~amd64. Some compile fixes for amd64/gcc-3.4*.
26 Jul 2004; Olivier Fisette <ribosome@gentoo.org>
labplot-1.3.0.ebuild, labplot-1.2.3.ebuild:
diff --git a/app-sci/labplot/files/labplot-1.3.0-amd64.patch b/app-sci/labplot/files/labplot-1.3.0-amd64.patch
new file mode 100644
index 000000000000..5bbadac00eeb
--- /dev/null
+++ b/app-sci/labplot/files/labplot-1.3.0-amd64.patch
@@ -0,0 +1,22 @@
+--- libjasper/include/jasper/jas_types.h.old 2004-08-20 22:27:33.831853344 +0200
++++ libjasper/include/jasper/jas_types.h 2004-08-20 22:27:56.952338496 +0200
+@@ -178,7 +178,7 @@
+
+ #endif
+
+-#if defined(HAVE_STDINT_H)
++#if defined(HAVE_STDINT_H) || defined (_STDINT_H)
+ /*
+ * The C language implementation does correctly provide the standard header
+ * file "stdint.h".
+--- src/Plot2DSurface.cc.old 2004-08-20 22:28:48.961431912 +0200
++++ src/Plot2DSurface.cc 2004-08-20 22:57:09.291942384 +0200
+@@ -195,7 +195,7 @@
+ // kdDebug()<<"a = "<<a[j-1+NX*(i-1)]<<endl;
+ // kdDebug()<<" color value ("<<i<<"/"<<j<<") = "<<value<<endl;
+
+- QBrush brush(getColor(value,palette),(Qt::BrushStyle)brush);
++ QBrush brush(getColor(value,palette)/*,(Qt::BrushStyle)brush*/);
+ p->setBrush(brush);
+ if(mesh)
+ p->setPen( Qt::black );
diff --git a/app-sci/labplot/labplot-1.3.0.ebuild b/app-sci/labplot/labplot-1.3.0.ebuild
index c84c7c9a513e..146dfd39fcc6 100644
--- a/app-sci/labplot/labplot-1.3.0.ebuild
+++ b/app-sci/labplot/labplot-1.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/labplot/labplot-1.3.0.ebuild,v 1.1 2004/07/27 02:58:00 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/labplot/labplot-1.3.0.ebuild,v 1.2 2004/08/20 21:57:07 kugelfang Exp $
-inherit kde
+inherit eutils gnuconfig kde
MPN="LabPlot"
@@ -29,17 +29,17 @@ need-kde 3.1
S="${WORKDIR}/${MPN}-${PV}"
src_compile() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
+src_compile() {
local myconf="\
$(use_enable fftw) \
$(use_enable fftw fftw3) \
$(use_enable imagemagick ImageMagick) \
$(use_enable tiff)"
- # Uncomment the following for use on amd64.
- # if [ ${ARCH} = "amd64" ]; then
- # myconf="${myconf} \
- # --host=x86-linux-gnu \
- # --build=x86-linux-gnu \
- # --disable-pstoedit"
- # fi
+ gnuconfig_update
kde_src_compile
}