summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-07-16 22:31:16 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-07-16 22:31:16 +0000
commit416931ceb2a6a4856e4ce4b915a3ba9418f9246d (patch)
treec9f44b0ce11a5f1d4de7c08b992380165c2d546b /app-sci/scilab
parentFixed small DEPEND line error (diff)
downloadgentoo-2-416931ceb2a6a4856e4ce4b915a3ba9418f9246d.tar.gz
gentoo-2-416931ceb2a6a4856e4ce4b915a3ba9418f9246d.tar.bz2
gentoo-2-416931ceb2a6a4856e4ce4b915a3ba9418f9246d.zip
New version
Diffstat (limited to 'app-sci/scilab')
-rw-r--r--app-sci/scilab/ChangeLog7
-rw-r--r--app-sci/scilab/Manifest2
-rw-r--r--app-sci/scilab/files/digest-scilab-2.71
-rw-r--r--app-sci/scilab/scilab-2.7.ebuild122
4 files changed, 131 insertions, 1 deletions
diff --git a/app-sci/scilab/ChangeLog b/app-sci/scilab/ChangeLog
index 74880afe8830..377936cdaf87 100644
--- a/app-sci/scilab/ChangeLog
+++ b/app-sci/scilab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/scilab
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.3 2003/05/01 10:57:37 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/ChangeLog,v 1.4 2003/07/16 22:31:16 rphillips Exp $
+
+*scilab-2.6 (16 Jul 2003)
+
+ 16 Jul 2003; Ryan Phillips <rphillips@gentoo.org> scilab-2.7.ebuild :
+ Fixes #16737.
*scilab-2.6 (28 Apr 2002)
diff --git a/app-sci/scilab/Manifest b/app-sci/scilab/Manifest
index 1f3f4aedf9de..8b62038ca5be 100644
--- a/app-sci/scilab/Manifest
+++ b/app-sci/scilab/Manifest
@@ -1,4 +1,6 @@
MD5 7569fd52bdaa067a058790f571eca548 scilab-2.6.ebuild 2840
MD5 0ef404ab9a495f3c4a9f941b661f3cd5 ChangeLog 777
+MD5 7569fd52bdaa067a058790f571eca548 scilab-2.7.ebuild 2840
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 1d6cf95b60df9aed59392d68189bb25d files/digest-scilab-2.6 67
+MD5 08e3affe50b12d19408b7e389b08a964 files/digest-scilab-2.7 67
diff --git a/app-sci/scilab/files/digest-scilab-2.7 b/app-sci/scilab/files/digest-scilab-2.7
new file mode 100644
index 000000000000..6f12c076f4a7
--- /dev/null
+++ b/app-sci/scilab/files/digest-scilab-2.7
@@ -0,0 +1 @@
+MD5 e8aa1ede5efa20eeced284963d08bebb scilab-2.7.src.tar.gz 9510676
diff --git a/app-sci/scilab/scilab-2.7.ebuild b/app-sci/scilab/scilab-2.7.ebuild
new file mode 100644
index 000000000000..6e2f94ad6c24
--- /dev/null
+++ b/app-sci/scilab/scilab-2.7.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scilab/scilab-2.7.ebuild,v 1.1 2003/07/16 22:31:16 rphillips Exp $
+
+DESCRIPTION="scientific software package for numerical computations"
+SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/Meta2/Scilab/distributions/${P}.src.tar.gz"
+HOMEPAGE="http://www-rocq.inria.fr/scilab/"
+
+LICENSE="scilab"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcltk"
+
+DEPEND="virtual/x11
+ x11-libs/Xaw3d
+ tcltk? ( dev-lang/tk )"
+
+src_compile() {
+ local myopts
+
+ use tcltk || myopts="--without-tk"
+ if [ !"`use tcltk`" ] ; then
+ mv ${S}/tcl/Makefile ${S}/tcl/Makefile.orig
+ sed -e 's,all:: browsehelpexe,all::,' ${S}/tcl/Makefile.orig > ${S}/tcl/Makefile
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ ${myopts} || die "./configure failed"
+ env HOME=${S} make all || die
+}
+
+src_install() {
+ BINDISTFILES="\
+ ${P}/.binary \
+ ${P}/.pvmd.conf \
+ ${P}/ACKNOWLEDGEMENTS \
+ ${P}/CHANGES \
+ ${P}/Makefile \
+ ${P}/Makefile.OBJ \
+ ${P}/Makefile.incl \
+ ${P}/Makemex \
+ ${P}/Path.incl \
+ ${P}/README \
+ ${P}/Version.incl \
+ ${P}/configure \
+ ${P}/libtool \
+ ${P}/license.txt \
+ ${P}/licence.txt \
+ ${P}/scilab.quit \
+ ${P}/scilab.star \
+ ${P}/X11_defaults \
+ ${P}/bin \
+ ${P}/config \
+ ${P}/contrib \
+ ${P}/demos \
+ ${P}/examples \
+ ${P}/imp/NperiPos.ps \
+ ${P}/imp/giffonts \
+ ${P}/macros \
+ ${P}/man \
+ ${P}/maple \
+ ${P}/pvm3/lib/pvm \
+ ${P}/pvm3/lib/pvmd \
+ ${P}/pvm3/lib/pvmtmparch \
+ ${P}/pvm3/lib/pvmgetarch \
+ ${P}/pvm3/lib/LINUX/pvmd3 \
+ ${P}/pvm3/lib/LINUX/pvmgs \
+ ${P}/routines/*.h \
+ ${P}/routines/Make.lib \
+ ${P}/routines/default/FCreate \
+ ${P}/routines/default/Flist \
+ ${P}/routines/default/README \
+ ${P}/routines/default/fundef \
+ ${P}/routines/default/*.c \
+ ${P}/routines/default/*.f \
+ ${P}/routines/graphics/Math.h \
+ ${P}/routines/graphics/Graphics.h \
+ ${P}/routines/interf/*.h \
+ ${P}/routines/intersci/sparse.h \
+ ${P}/routines/menusX/*.h \
+ ${P}/routines/scicos/scicos.h \
+ ${P}/routines/sun/*.h \
+ ${P}/routines/xsci/*.h \
+ ${P}/scripts \
+ ${P}/tcl \
+ ${P}/tests \
+ ${P}/util"
+
+ touch .binary
+ strip bin/scilex
+ cd ${S}/tests && make distclean
+ cd ${S}/examples && make distclean
+ dodir /usr/lib
+ (cd ${S}/..; tar cf - ${BINDISTFILES} ${PVMBINDISTFILES} | (cd ${D}/usr/lib; tar xf -))
+ rm .binary
+
+ dodir /usr/bin
+ dosym /usr/lib/${P}/bin/scilab /usr/bin/scilab
+ dosym /usr/lib/${P}/bin/intersci /usr/bin/intersci
+ dosym /usr/lib/${P}/bin/intersci-n /usr/bin/intersci-n
+}
+
+# the following is needed in order to create the startup scripts with
+# the right paths
+pkg_postinst() {
+ (cd /usr/lib/${P}; make)
+}
+
+# but of course then, unmerge won't remove everything without the following
+pkg_postrm() {
+ rm /usr/lib/${P}/Path.incl
+ rm -r /usr/lib/${P}/bin
+ rm -r /usr/lib/${P}/util
+ rm -r /usr/lib/${P}/examples
+ rmdir /usr/lib/${P}
+}