summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-09-26 01:26:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-09-26 01:26:42 +0000
commite0617434fe4133a88d17d500e8cc079117615957 (patch)
tree9b56fe8cde78ffb95da60ea0281d78be78d5bca1 /app-portage
parentadd patch for year checking from bug #17992 (diff)
downloadgentoo-2-e0617434fe4133a88d17d500e8cc079117615957.tar.gz
gentoo-2-e0617434fe4133a88d17d500e8cc079117615957.tar.bz2
gentoo-2-e0617434fe4133a88d17d500e8cc079117615957.zip
add patch for year checking from bug #17992
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/lintool/ChangeLog8
-rw-r--r--app-portage/lintool/Manifest6
-rw-r--r--app-portage/lintool/files/digest-lintool-0.2.4-r11
-rw-r--r--app-portage/lintool/files/lintool-0.2.4-fixyear.diff28
-rw-r--r--app-portage/lintool/lintool-0.2.4-r1.ebuild30
5 files changed, 69 insertions, 4 deletions
diff --git a/app-portage/lintool/ChangeLog b/app-portage/lintool/ChangeLog
index bc9a4474cccd..32120853aa52 100644
--- a/app-portage/lintool/ChangeLog
+++ b/app-portage/lintool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/lintool
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/lintool/ChangeLog,v 1.2 2003/08/16 05:37:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/lintool/ChangeLog,v 1.3 2003/09/26 01:26:37 robbat2 Exp $
+
+*lintool-0.2.4-r1 (25 Sep 2003)
+
+ 25 Sep 2003; Robin H. Johnson <robbat2@gentoo.org> lintool-0.2.4-r1.ebuild,
+ files/lintool-0.2.4-fixyear.diff:
+ add patch for year checking from bug #17992
*lintool-0.2.4 (15 Aug 2003)
diff --git a/app-portage/lintool/Manifest b/app-portage/lintool/Manifest
index f4a6c9ae9668..ed8a7d8db036 100644
--- a/app-portage/lintool/Manifest
+++ b/app-portage/lintool/Manifest
@@ -1,9 +1,9 @@
-MD5 925442965e4de9fb4f3290ff8cba0436 lintool-0.2.4-r1.ebuild 685
+MD5 3172ffa3136991ddbfc32e13df7cba11 lintool-0.2.4-r1.ebuild 688
MD5 77ae944cb0d686f03cdadc1c3858633c lintool-0.2.4.ebuild 606
MD5 2a34e71938843c9b85176a7c60c78a47 lintool-0.2.3-r1.ebuild 763
-MD5 1dfe4b61135762fe199c3a6ebaa84281 ChangeLog 1891
+MD5 f3d2d1636aa2c3f011f49ba1b2daeb3c ChangeLog 2086
MD5 13e5eb0a0cf6391bc4eaabacf800b9fc metadata.xml 615
MD5 0e24f68c021ae2a1a5c97c15895d4d95 files/digest-lintool-0.2.4 128
MD5 904facf4355aba6e98b567e01d281b7b files/digest-lintool-0.2.3-r1 202
MD5 c7ea1e4a90f1cead953a48dea2b2b3e7 files/digest-lintool-0.2.4-r1 65
-MD5 17e1607189dddef07f6ee92e85ac087f files/lintool-0.2.4-fixyear.diff 1073
+MD5 020ce0397482bd0468b70ad38f5020b0 files/lintool-0.2.4-fixyear.diff 1357
diff --git a/app-portage/lintool/files/digest-lintool-0.2.4-r1 b/app-portage/lintool/files/digest-lintool-0.2.4-r1
new file mode 100644
index 000000000000..8a5cec737038
--- /dev/null
+++ b/app-portage/lintool/files/digest-lintool-0.2.4-r1
@@ -0,0 +1 @@
+MD5 ab4ca882e1c95e635934b453a0962498 lintool-0.2.4.tar.bz2 21779
diff --git a/app-portage/lintool/files/lintool-0.2.4-fixyear.diff b/app-portage/lintool/files/lintool-0.2.4-fixyear.diff
new file mode 100644
index 000000000000..371912242034
--- /dev/null
+++ b/app-portage/lintool/files/lintool-0.2.4-fixyear.diff
@@ -0,0 +1,28 @@
+diff -ur lintool-0.2.4.orig/src/lintool/ebuild.py lintool-0.2.4/src/lintool/ebuild.py
+--- lintool-0.2.4.orig/src/lintool/ebuild.py 2002-10-30 13:35:31.000000000 -0800
++++ lintool-0.2.4/src/lintool/ebuild.py 2003-09-25 18:22:30.000000000 -0700
+@@ -7,6 +7,7 @@
+ import os
+ import os.path
+ import string
++from time import gmtime, time, strftime
+
+ class TestSpaces(Test):
+
+@@ -56,12 +57,14 @@
+
+ def __init__(self, formatter, options):
+ Test.__init__(self,formatter, options)
++ # get current year
++ currentyear = strftime("%Y",gmtime(time()))
+ self.desc = "Testing for malformed headers"
+ self.want = [ [ 0, # count
+- re.compile("^(# Copyright .*2002.*)"),
++ re.compile("^(# Copyright .*"+currentyear+".*)"),
+ "Copyright statement" ],
+ [ 0, # count
+- re.compile("^(# \$Header:.*\$)"),
++ re.compile("^(# \$Header.*\$)"),
+ "\$Header: \$" ],
+ [ 0, # count
+ re.compile("^(# Distributed under the terms of the GNU General Public License.*)"),
diff --git a/app-portage/lintool/lintool-0.2.4-r1.ebuild b/app-portage/lintool/lintool-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..bd97fdf91660
--- /dev/null
+++ b/app-portage/lintool/lintool-0.2.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/lintool/lintool-0.2.4-r1.ebuild,v 1.1 2003/09/26 01:26:37 robbat2 Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gentoo Linux \"lint\" utility"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha"
+
+DEPEND=">=dev-lang/python-2.2"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/lintool-0.2.4-fixyear.diff
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README NEWS ChangeLog COPYING AUTHORS
+}