summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-24 16:16:21 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-24 16:16:21 +0000
commit630efae7021c6daf02d247cd942349d40cad612b (patch)
tree0aff0fe6b6a0b3c2c1f944ce045bc554b6fc1a4e /app-portage
parentchange jpeg USE flag to exif (#93652) (diff)
downloadgentoo-2-630efae7021c6daf02d247cd942349d40cad612b.tar.gz
gentoo-2-630efae7021c6daf02d247cd942349d40cad612b.tar.bz2
gentoo-2-630efae7021c6daf02d247cd942349d40cad612b.zip
fowners root:portage in src_install doesn't work. Use chgrp in pkg_postinst
instead. Clean up pkg_setup and spacing in DEPEND (Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/porthole/ChangeLog6
-rw-r--r--app-portage/porthole/porthole-0.4.1.ebuild33
2 files changed, 20 insertions, 19 deletions
diff --git a/app-portage/porthole/ChangeLog b/app-portage/porthole/ChangeLog
index 57ee42ec5bba..a4ade14a2d32 100644
--- a/app-portage/porthole/ChangeLog
+++ b/app-portage/porthole/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/porthole
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.18 2005/01/01 15:55:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.19 2005/06/24 16:16:21 agriffis Exp $
+
+ 24 Jun 2005; Aron Griffis <agriffis@gentoo.org> porthole-0.4.1.ebuild:
+ fowners root:portage in src_install doesn't work. Use chgrp in pkg_postinst
+ instead. Clean up pkg_setup and spacing in DEPEND
08 Dec 2004; Marius Mauch <genone@gentoo.org> -porthole-0.3.1.ebuild:
removing 0.3.1 as it's reported to break with portage-2.0.51
diff --git a/app-portage/porthole/porthole-0.4.1.ebuild b/app-portage/porthole/porthole-0.4.1.ebuild
index f264210cc43c..d887f67a69a8 100644
--- a/app-portage/porthole/porthole-0.4.1.ebuild
+++ b/app-portage/porthole/porthole-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.4.1.ebuild,v 1.4 2005/01/01 15:55:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.4.1.ebuild,v 1.5 2005/06/24 16:16:21 agriffis Exp $
inherit distutils
@@ -12,27 +12,24 @@ SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="debug"
DEPEND=">=dev-lang/python-2.3
- >=sys-apps/portage-2.0.51-r3
- >=dev-python/pygtk-2.0.0
- >=dev-python/pyxml-0.8.3"
+ >=sys-apps/portage-2.0.51-r3
+ >=dev-python/pygtk-2.0.0
+ >=dev-python/pyxml-0.8.3"
RDEPEND="${DEPEND} debug? ( >=dev-python/pycrash-0.4_pre3 )"
pkg_setup() {
-
- local gnome_flag=""
+ local gnome_flag=false
for pygtk_install in /var/db/pkg/dev-python/pygtk*; do
- if grep 2 ${pygtk_install}/SLOT > /dev/null; then
- for flag in `cat ${pygtk_install}/USE`; do
- if [ ${flag} == gnome ]; then
- gnome_flag="found"
- fi
- done
+ cd ${pygtk_install} || die
+ if [[ $(<SLOT) == 2 && " $(<USE) " == *" gnome "* ]]; then
+ gnome_flag=true
+ break
fi
done
- if [ -z "${gnome_flag}" ]; then
+ if ! ${gnome_flag}; then
echo
eerror "pygtk was not merged with the gnome"
eerror "USE flag. Porthole requires pygtk be"
@@ -43,12 +40,12 @@ pkg_setup() {
src_install() {
distutils_src_install
- chmod -R a+r ${D}/usr/share/porthole
+ chmod -R a+rX ${D}/usr/share/porthole
dodoc TODO README NEWS AUTHORS
-}
-
-pkg_preinst() {
keepdir /var/log/porthole
- fowners root:portage /var/log/porthole
fperms g+w /var/log/porthole
}
+
+pkg_postinst() {
+ chgrp portage ${ROOT}/var/log/porthole
+}