summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-02-06 08:30:46 +0000
committerMichael Weber <xmw@gentoo.org>2014-02-06 08:30:46 +0000
commit4dca52ed52fa53c82b9eda465295f1d2a9aab664 (patch)
treecc767425dc33ac8756d47dd96dd5d4485d4fd743 /app-portage
parentMake sure to pull in media-video/ffmpeg from SLOT="0" instead of eg. SLOT="0.10" (diff)
downloadgentoo-2-4dca52ed52fa53c82b9eda465295f1d2a9aab664.tar.gz
gentoo-2-4dca52ed52fa53c82b9eda465295f1d2a9aab664.tar.bz2
gentoo-2-4dca52ed52fa53c82b9eda465295f1d2a9aab664.zip
Add portage 2.2.8 patch by pinkybyte
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/porticron/ChangeLog9
-rw-r--r--app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch26
-rw-r--r--app-portage/porticron/porticron-0.7_p20140126.ebuild29
3 files changed, 63 insertions, 1 deletions
diff --git a/app-portage/porticron/ChangeLog b/app-portage/porticron/ChangeLog
index a4d9b57e3488..098b2c1c0aed 100644
--- a/app-portage/porticron/ChangeLog
+++ b/app-portage/porticron/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/porticron
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porticron/ChangeLog,v 1.33 2014/01/11 11:21:47 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porticron/ChangeLog,v 1.34 2014/02/06 08:30:46 xmw Exp $
+
+*porticron-0.7_p20140126 (06 Feb 2014)
+
+ 06 Feb 2014; Michael Weber <xmw@gentoo.org>
+ +files/porticron-0.7_p20140126-portage-2.2.8.patch,
+ +porticron-0.7_p20140126.ebuild:
+ Add portage 2.2.8 patch by pinkybyte
*porticron-0.7_p20131113 (11 Jan 2014)
diff --git a/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch b/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch
new file mode 100644
index 000000000000..4531ab638fd8
--- /dev/null
+++ b/app-portage/porticron/files/porticron-0.7_p20140126-portage-2.2.8.patch
@@ -0,0 +1,26 @@
+From 7a7002d5af62d0a4791a386cdc3560330f27f1c0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rainer=20M=C3=BCller?= <raimue@codingfarm.de>
+Date: Sun, 26 Jan 2014 23:23:03 +0100
+Subject: [PATCH] Avoid the deprecated `portageq portdir'
+
+This implements the fix proposed in hollow/porticron#6.
+---
+ bin/porticron | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/porticron b/bin/porticron
+index d168b27..86a1f70 100755
+--- a/bin/porticron
++++ b/bin/porticron
+@@ -117,7 +117,7 @@ FQDN=$(hostname --fqdn)
+ HOST=$(hostname -s)
+ IP=$(dig +short ${FQDN} | tr '\n' ' ')
+ DATE=$(date -R)
+-PORTDIR=$(portageq portdir)
++PORTDIR=$(portageq get_repo_path $(portageq envvar EROOT) gentoo)
+
+ # replace variables
+ for var in FQDN HOST IP DATE; do
+--
+1.8.5.1
+
diff --git a/app-portage/porticron/porticron-0.7_p20140126.ebuild b/app-portage/porticron/porticron-0.7_p20140126.ebuild
new file mode 100644
index 000000000000..43f076407f56
--- /dev/null
+++ b/app-portage/porticron/porticron-0.7_p20140126.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porticron/porticron-0.7_p20140126.ebuild,v 1.1 2014/02/06 08:30:46 xmw Exp $
+
+EAPI="5"
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="cron script to sync portage and send update mails to root"
+HOMEPAGE="http://github.com/hollow/porticron"
+SRC_URI="https://github.com/hollow/${PN}/tarball/df727fe -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="net-dns/bind-tools"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-portage-2.2.8.patch
+}
+
+src_install() {
+ dosbin bin/porticron
+ insinto /etc
+ doins etc/porticron.conf
+}