summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-10-11 15:06:39 +0000
committerThilo Bangert <bangert@gentoo.org>2008-10-11 15:06:39 +0000
commit296d30216b8658c6ef51e4a37902b7cd04fe48bf (patch)
tree7ec6a6c15b55cee11a0752c0e767ce9e991d7111 /app-portage
parentIncludes linux 2.6.26.3, 2.6.26.4, 2.6.26.5, 2.6.26.6 and a missing capabilit... (diff)
downloadgentoo-2-296d30216b8658c6ef51e4a37902b7cd04fe48bf.tar.gz
gentoo-2-296d30216b8658c6ef51e4a37902b7cd04fe48bf.tar.bz2
gentoo-2-296d30216b8658c6ef51e4a37902b7cd04fe48bf.zip
bump eix on behalf of Martin Väth as per bug #241336
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.14.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 47183e9639a8..b857368d3061 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.249 2008/10/01 14:44:58 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.250 2008/10/11 15:06:39 bangert Exp $
+
+*eix-0.14.1 (11 Oct 2008)
+
+ 11 Oct 2008; Thilo Bangert <bangert@gentoo.org> +eix-0.14.1.ebuild:
+ bump eix on behalf of Martin Väth as per bug #241336
01 Oct 2008; Brent Baude <ranger@gentoo.org> eix-0.13.3-r1.ebuild:
stable ppc64, bug 238282
diff --git a/app-portage/eix/eix-0.14.1.ebuild b/app-portage/eix/eix-0.14.1.ebuild
new file mode 100644
index 000000000000..013f6457d008
--- /dev/null
+++ b/app-portage/eix/eix-0.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.14.1.ebuild,v 1.1 2008/10/11 15:06:39 bangert Exp $
+
+DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc sqlite"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if test -d /var/log && ! test -x /var/log || test -e /var/log/eix-sync.log
+ then
+ einfo
+ einfo "eix-sync no longer supports redirection to /var/log/eix-sync.log"
+ einfo "You can remove that file."
+ fi
+}