summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-11-11 14:26:55 +0000
committerTroy Dack <tad@gentoo.org>2003-11-11 14:26:55 +0000
commitd53a426dcc98c401a27b159da6aa72ea25980d48 (patch)
treea7af0b70f834951ae5b8f5629228585d436cd6e9 /app-pda
parentInitial import into portage. Closes Bug #29396. (diff)
downloadgentoo-2-d53a426dcc98c401a27b159da6aa72ea25980d48.tar.gz
gentoo-2-d53a426dcc98c401a27b159da6aa72ea25980d48.tar.bz2
gentoo-2-d53a426dcc98c401a27b159da6aa72ea25980d48.zip
Initial import into portage. Closes Bug #29396.
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/synce-kde/ChangeLog9
-rw-r--r--app-pda/synce-kde/Manifest3
-rw-r--r--app-pda/synce-kde/files/digest-synce-kde-0.6.12
-rw-r--r--app-pda/synce-kde/synce-kde-0.6.1.ebuild45
4 files changed, 58 insertions, 1 deletions
diff --git a/app-pda/synce-kde/ChangeLog b/app-pda/synce-kde/ChangeLog
new file mode 100644
index 000000000000..ba17bd7e5d49
--- /dev/null
+++ b/app-pda/synce-kde/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-pda/synce-kde
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kde/ChangeLog,v 1.1 2003/11/11 14:26:48 tad Exp $
+
+*synce-kde-0.6.1 (12 Nov 2003)
+
+ 12 Nov 2003; Troy Dack <tad@gentoo.org> synce-kde-0.6.1.ebuild:
+ Initial ebuild. Bug #29396.
+
diff --git a/app-pda/synce-kde/Manifest b/app-pda/synce-kde/Manifest
index 98672ba21432..0d5e731ac3f2 100644
--- a/app-pda/synce-kde/Manifest
+++ b/app-pda/synce-kde/Manifest
@@ -1,2 +1,3 @@
-MD5 d55adf373761f8b4804cb739d9c626f4 synce-kde-0.6.1.ebuild 1130
+MD5 be48e079e775fb20d2a5d37cb9eec58d ChangeLog 342
+MD5 c435970c611ea701e69d6777d9dbbaae synce-kde-0.6.1.ebuild 1179
MD5 79536d5a6c86b20bb2307cc315815423 files/digest-synce-kde-0.6.1 129
diff --git a/app-pda/synce-kde/files/digest-synce-kde-0.6.1 b/app-pda/synce-kde/files/digest-synce-kde-0.6.1
new file mode 100644
index 000000000000..63f9ce35a641
--- /dev/null
+++ b/app-pda/synce-kde/files/digest-synce-kde-0.6.1
@@ -0,0 +1,2 @@
+MD5 d003401d8c652b0f32551203a66f98e7 synce-kde-0.6.1.tar.gz 836252
+MD5 74de1b1452a718c85364fab5ce3c0c2a agsync-0.2-pre.tgz 93716
diff --git a/app-pda/synce-kde/synce-kde-0.6.1.ebuild b/app-pda/synce-kde/synce-kde-0.6.1.ebuild
new file mode 100644
index 000000000000..9a27230a172d
--- /dev/null
+++ b/app-pda/synce-kde/synce-kde-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Kevin Koltzau <kevin@plop.org>
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kde/synce-kde-0.6.1.ebuild,v 1.1 2003/11/11 14:26:48 tad Exp $
+
+inherit kde-base
+
+need-kde 3.1
+
+AGVER="agsync-0.2-pre"
+
+IUSE="avantgo"
+DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync. - KDE System Tray utility (formerly app-pda/rapip)"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz
+ avantgo? (http://www.mechlord.ca/%7Elownewulf/${AGVER}.tgz)"
+HOMEPAGE="http://synce.sourceforge.net"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+newdepend ">=app-pda/synce-0.8
+ >=app-pda/synce-rra-0.8
+ !app-pda/rapip"
+
+src_unpack() {
+ kde_src_unpack
+
+ # the default install location of iptables is /sbin/iptables
+ cd ${S}/raki
+ cp configdialogimpl.cpp configdialogimpl.cpp.orig
+ sed "s:/usr/sbin/iptables:/sbin/iptables:" \
+ configdialogimpl.cpp.orig > configdialogimpl.cpp
+}
+
+src_compile() {
+ if [ `use avantgo` ]; then
+ cd ${S}/../agsync-0.2-pre
+ emake
+ cd ${S}
+ myconf="$myconf --with-agsync=${S}/../${AGVER}"
+ fi
+ kde_src_compile
+}