summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-10-01 23:39:32 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-10-01 23:39:32 +0000
commit6ec61bff3fe42de0e62e70255ccde7b85f792262 (patch)
tree3697a45e4c93ed88ff36d645cf95e05e9f804aad /app-pda
parentRemoved =net-news/inn-2.4.1 (diff)
downloadgentoo-2-6ec61bff3fe42de0e62e70255ccde7b85f792262.tar.gz
gentoo-2-6ec61bff3fe42de0e62e70255ccde7b85f792262.tar.bz2
gentoo-2-6ec61bff3fe42de0e62e70255ccde7b85f792262.zip
fixing -lsdp bug
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/ChangeLog6
-rw-r--r--app-pda/multisync/files/multisync-0.82-bluetooth-sdp-2.patch11
-rw-r--r--app-pda/multisync/multisync-0.82.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/app-pda/multisync/ChangeLog b/app-pda/multisync/ChangeLog
index d640ddc80b78..54ef44f16465 100644
--- a/app-pda/multisync/ChangeLog
+++ b/app-pda/multisync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/multisync
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.14 2004/08/17 13:35:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.15 2004/10/01 23:39:32 humpback Exp $
+
+ 02 Oct 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/multisync-0.82-bluetooth-sdp-2.patch, multisync-0.82.ebuild:
+ Adding missing patch for -lsdp bug #63743
17 Aug 2004; Aron Griffis <agriffis@gentoo.org> multisync-0.81.ebuild:
Fix USE test in DEPEND. Should be !gtk2? instead of plain !gtk2
diff --git a/app-pda/multisync/files/multisync-0.82-bluetooth-sdp-2.patch b/app-pda/multisync/files/multisync-0.82-bluetooth-sdp-2.patch
new file mode 100644
index 000000000000..af0fe2cd1492
--- /dev/null
+++ b/app-pda/multisync/files/multisync-0.82-bluetooth-sdp-2.patch
@@ -0,0 +1,11 @@
+--- plugins/irmc_sync/src/Makefile.in.org 2004-08-21 23:57:13.647919824 +0200
++++ plugins/irmc_sync/src/Makefile.in 2004-08-21 23:57:31.073270768 +0200
+@@ -109,7 +109,7 @@
+ irmc_bluetooth.c irmc_bluetooth.h
+
+
+-libirmc_bluetooth_la_LIBADD = -lbluetooth -lsdp -lpthread
++libirmc_bluetooth_la_LIBADD = -lbluetooth -lpthread
+
+ libirmc_sync_la_SOURCES = \
+ interface.c interface.h \
diff --git a/app-pda/multisync/multisync-0.82.ebuild b/app-pda/multisync/multisync-0.82.ebuild
index e42dc7a5f28a..6dd9085f7880 100644
--- a/app-pda/multisync/multisync-0.82.ebuild
+++ b/app-pda/multisync/multisync-0.82.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.82.ebuild,v 1.6 2004/09/21 23:35:06 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.82.ebuild,v 1.7 2004/10/01 23:39:32 humpback Exp $
inherit eutils
@@ -49,7 +49,9 @@ src_unpack() {
# Fix the opie Makefile
cd ${S}
epatch ${FILESDIR}/${PN}-0.81-gentoo.patch
+ # Fix for sdp lib bug #63743
epatch ${FILESDIR}/${PN}-0.82-bluetooth-sdp.patch
+ epatch ${FILESDIR}/${PN}-0.82-bluetooth-sdp-2.patch
}
src_compile() {