summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-26 05:32:34 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-26 05:32:34 +0000
commit1b42efe76e7edfe9c83c647fe4442c481d7fe56e (patch)
treee129bcae0acec6375833699ab40ccfff42fd74e0 /app-pda
parentVersion bump (diff)
downloadgentoo-2-1b42efe76e7edfe9c83c647fe4442c481d7fe56e.tar.gz
gentoo-2-1b42efe76e7edfe9c83c647fe4442c481d7fe56e.tar.bz2
gentoo-2-1b42efe76e7edfe9c83c647fe4442c481d7fe56e.zip
EAPI 3, dependencies, docs, etc.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/msynctool/ChangeLog8
-rw-r--r--app-pda/msynctool/metadata.xml4
-rw-r--r--app-pda/msynctool/msynctool-0.22.ebuild23
-rw-r--r--app-pda/msynctool/msynctool-0.36.ebuild14
4 files changed, 35 insertions, 14 deletions
diff --git a/app-pda/msynctool/ChangeLog b/app-pda/msynctool/ChangeLog
index 65fa200a302c..d7a855b3fab3 100644
--- a/app-pda/msynctool/ChangeLog
+++ b/app-pda/msynctool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/msynctool
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/ChangeLog,v 1.9 2010/05/26 12:28:34 bangert Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/ChangeLog,v 1.10 2011/02/26 05:32:34 dirtyepic Exp $
+
+ 26 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> msynctool-0.22.ebuild,
+ msynctool-0.36.ebuild, metadata.xml:
+ EAPI 3, dependencies, docs, etc.
26 May 2010; Thilo Bangert <bangert@gentoo.org> -msynctool-9999.ebuild:
remove svn ebuild - repository disappeared
diff --git a/app-pda/msynctool/metadata.xml b/app-pda/msynctool/metadata.xml
index 0d934d06b5d0..2025e2b89d0d 100644
--- a/app-pda/msynctool/metadata.xml
+++ b/app-pda/msynctool/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>pda</herd>
<maintainer>
- <email>peper@gentoo.org</email>
- <name>Piotr Jaroszyński</name>
+ <email>dirtyepic@gentoo.org</email>
+ <name>Ryan Hill</name>
</maintainer>
<longdescription lang="en">
</longdescription>
diff --git a/app-pda/msynctool/msynctool-0.22.ebuild b/app-pda/msynctool/msynctool-0.22.ebuild
index 2f9801a5e34e..d4c36c8d3608 100644
--- a/app-pda/msynctool/msynctool-0.22.ebuild
+++ b/app-pda/msynctool/msynctool-0.22.ebuild
@@ -1,20 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.22.ebuild,v 1.2 2007/09/08 04:09:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.22.ebuild,v 1.3 2011/02/26 05:32:34 dirtyepic Exp $
+
+EAPI="3"
DESCRIPTION="OpenSync msync tool"
HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+SRC_URI="http://www.opensync.org/downloads/releases/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+src_prepare() {
+ sed -i -e 's: -Werror::g' \
+ -e 's: -R $(libdir)::g' \
+ tools/Makefile.in
+}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ dodoc AUTHORS README
}
diff --git a/app-pda/msynctool/msynctool-0.36.ebuild b/app-pda/msynctool/msynctool-0.36.ebuild
index 2baf3a6229e4..b6a171762e70 100644
--- a/app-pda/msynctool/msynctool-0.36.ebuild
+++ b/app-pda/msynctool/msynctool-0.36.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.36.ebuild,v 1.1 2008/01/27 17:41:00 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/msynctool/msynctool-0.36.ebuild,v 1.2 2011/02/26 05:32:34 dirtyepic Exp $
+
+EAPI="3"
inherit cmake-utils
@@ -13,5 +15,9 @@ SLOT="0"
LICENSE="GPL-2"
IUSE=""
-DEPEND="=app-pda/libopensync-${PV}*"
-RDEPEND="${DEPEND}"
+RDEPEND="~app-pda/libopensync-${PV}
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+DOCS="AUTHORS CODING"