summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-01-26 12:05:58 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-01-26 12:05:58 +0000
commit4cefdb4e944969681d58960d58e2e90cf738b239 (patch)
tree5cdab9f0c027b3d181ce7d9db0a23015c7cb1e56 /app-pda/pilot-mailsync
parentversion bump. major ebuild cleanup. (#37551) (diff)
downloadgentoo-2-4cefdb4e944969681d58960d58e2e90cf738b239.tar.gz
gentoo-2-4cefdb4e944969681d58960d58e2e90cf738b239.tar.bz2
gentoo-2-4cefdb4e944969681d58960d58e2e90cf738b239.zip
version bump. added -fPIC for amd64 systems (bug #45755). enabled gpilot plugin via USE=gnome
(Portage version: 2.0.51-r14)
Diffstat (limited to 'app-pda/pilot-mailsync')
-rw-r--r--app-pda/pilot-mailsync/ChangeLog9
-rw-r--r--app-pda/pilot-mailsync/Manifest3
-rw-r--r--app-pda/pilot-mailsync/files/digest-pilot-mailsync-0.8.31
-rw-r--r--app-pda/pilot-mailsync/pilot-mailsync-0.8.3.ebuild64
4 files changed, 75 insertions, 2 deletions
diff --git a/app-pda/pilot-mailsync/ChangeLog b/app-pda/pilot-mailsync/ChangeLog
index fdeca7a0a38f..5417fce2643f 100644
--- a/app-pda/pilot-mailsync/ChangeLog
+++ b/app-pda/pilot-mailsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/pilot-mailsync
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-mailsync/ChangeLog,v 1.3 2005/01/01 15:46:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-mailsync/ChangeLog,v 1.4 2005/01/26 12:05:58 liquidx Exp $
+
+*pilot-mailsync-0.8.3 (26 Jan 2005)
+
+ 26 Jan 2005; Alastair Tse <liquidx@gentoo.org>
+ +pilot-mailsync-0.8.3.ebuild:
+ version bump. added -fPIC for amd64 systems (bug #45755). enabled gpilot
+ plugin via USE=gnome
*pilot-mailsync-0.8.0.2 (12 Oct 2003)
diff --git a/app-pda/pilot-mailsync/Manifest b/app-pda/pilot-mailsync/Manifest
index ee4d07e6869a..4c428fa7c30c 100644
--- a/app-pda/pilot-mailsync/Manifest
+++ b/app-pda/pilot-mailsync/Manifest
@@ -1,6 +1,7 @@
MD5 818ce6599b0a658a4cbb53c276791690 ChangeLog 430
MD5 075fea99b82d61028585dc3e42f00466 metadata.xml 156
MD5 c8cc33559ef60b592ec67bc3dd48cdd4 pilot-mailsync-0.8.0.2.ebuild 761
-MD5 6a51c29662580634d473ffe20de05ccd pilot-mailsync-0.8.1.ebuild 760
+MD5 01c3597bf14dcd2c12ce7d2065e3b0fa pilot-mailsync-0.8.3.ebuild 885
MD5 6f4db2e33b85320840d9490d4408773a files/digest-pilot-mailsync-0.8.0.2 75
MD5 c40b06dccab65e88a6d81d42dcea483b files/digest-pilot-mailsync-0.8.1 73
+MD5 35a746c8fc6fc591cff6b6d3744c76c1 files/digest-pilot-mailsync-0.8.3 73
diff --git a/app-pda/pilot-mailsync/files/digest-pilot-mailsync-0.8.3 b/app-pda/pilot-mailsync/files/digest-pilot-mailsync-0.8.3
new file mode 100644
index 000000000000..ee3e3d88f53a
--- /dev/null
+++ b/app-pda/pilot-mailsync/files/digest-pilot-mailsync-0.8.3
@@ -0,0 +1 @@
+MD5 3b2b1f781ad396b687470ad6891e5d09 pilot-mailsync-0.8.3.tar.gz 2037489
diff --git a/app-pda/pilot-mailsync/pilot-mailsync-0.8.3.ebuild b/app-pda/pilot-mailsync/pilot-mailsync-0.8.3.ebuild
new file mode 100644
index 000000000000..2ba2920fb5b3
--- /dev/null
+++ b/app-pda/pilot-mailsync/pilot-mailsync-0.8.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-mailsync/pilot-mailsync-0.8.3.ebuild,v 1.1 2005/01/26 12:05:58 liquidx Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="An application to transfer outgoing mail from and deliver incoming mail to a Palm OS device."
+HOMEPAGE="http://wissrech.iam.uni-bonn.de/people/garcke/pms/"
+SRC_URI="http://wissrech.iam.uni-bonn.de/people/garcke/pms/${P}.tar.gz"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl gnome"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ gnome? ( >=app-pda/gnome-pilot-2 )
+ >=app-pda/pilot-link-0.11.7-r1"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ if use gnome; then
+ mv ${P} ${P}-gpilot
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ # bug #45755
+ append-flags -fPIC
+
+ cd ${S}
+ econf $(use_enable ssl)
+ if use gnome; then
+ cd ${S}-gpilot
+ econf $(use_enable ssl) --enable-gpilot
+ fi
+
+ cd ${S}
+ emake || die "make failed"
+ if use gnome; then
+ cd ${S}-gpilot
+ emake || die "gpilot plugin make failed"
+ fi
+
+}
+
+src_install() {
+ cd ${S}
+ make RPM_BUILD_ROOT=${D} install || die "install failed"
+ dodoc README INSTALL docs/*
+
+ if use gnome; then
+ cd ${S}-gpilot
+ insinto /usr/share/gnome-pilot/conduits/
+ doins mailsync.conduit
+ insinto /usr/lib/gnome-pilot/conduits/
+ doins .libs/libgnome_mailsync_conduit.so
+ fi
+
+} \ No newline at end of file