summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-19 09:56:37 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-19 09:56:37 +0000
commitf2f30691818be7b43667a3a616e49f45ace34eb0 (patch)
tree0b9932be4e075b5cd7799e1d5b369e40c2222776 /app-office
parentBump, only a year and a half since the last non-release-candidate release. To... (diff)
downloadgentoo-2-f2f30691818be7b43667a3a616e49f45ace34eb0.tar.gz
gentoo-2-f2f30691818be7b43667a3a616e49f45ace34eb0.tar.bz2
gentoo-2-f2f30691818be7b43667a3a616e49f45ace34eb0.zip
Version bump, bug 207968, reported by Craig Bradney <cbradney AT zip.com.au> and DrChandra the Gentoo Person <gentooperson AT yahoo.com>.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/ChangeLog10
-rw-r--r--app-office/scribus/scribus-1.3.3.11.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index 5ce65cbdddb8..6edfbaa9431c 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/scribus
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.101 2007/07/08 00:45:00 hanno Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.102 2008/02/19 09:56:37 pva Exp $
+
+*scribus-1.3.3.11 (19 Feb 2008)
+
+ 19 Feb 2008; <pva@gentoo.org> +scribus-1.3.3.11.ebuild:
+ Version bump, bug 207968, reported by Craig Bradney <cbradney AT zip.com.au>
+ and DrChandra the Gentoo Person <gentooperson AT yahoo.com>.
08 Jul 2007; Hanno Boeck <hanno@gentoo.org> scribus-1.3.4-r1.ebuild:
Requires cairo with svg-support.
diff --git a/app-office/scribus/scribus-1.3.3.11.ebuild b/app-office/scribus/scribus-1.3.3.11.ebuild
new file mode 100644
index 000000000000..7ddeb28e184a
--- /dev/null
+++ b/app-office/scribus/scribus-1.3.3.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.3.3.11.ebuild,v 1.1 2008/02/19 09:56:37 pva Exp $
+
+inherit qt3 eutils
+
+DESCRIPTION="Desktop Publishing (DTP) and Layout program for Linux."
+HOMEPAGE="http://www.scribus.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo"
+
+DEPEND="$(qt_min_version 3.3.4)
+ >=media-libs/freetype-2.1
+ >=media-libs/lcms-1.09
+ media-libs/tiff
+ >=media-libs/libart_lgpl-2.3.8
+ >=sys-devel/gcc-3.0.0
+ >=dev-libs/libxml2-2.6.0
+ cairo? ( >=x11-libs/cairo-1.0 )"
+
+RDEPEND="${DEPEND}
+ virtual/ghostscript"
+
+pkg_setup() {
+ if use cairo && ! built_with_use 'x11-libs/cairo' 'X' ; then
+ eerror "You must build cairo with X support"
+ die "x11-libs/cairo built without X"
+ fi
+}
+
+src_compile() {
+ econf `use_enable cairo` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ domenu scribus.desktop
+ doicon scribus/icons/scribusicon.png
+}