summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-09-25 06:13:52 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-09-25 06:13:52 +0000
commitd8b9609cda5f773e67c9df26c438a72518041f0a (patch)
tree3a26ebe3c74868546634c1d37b5ca1ee6914ce54 /app-office
parentversion bump (diff)
downloadgentoo-2-d8b9609cda5f773e67c9df26c438a72518041f0a.tar.gz
gentoo-2-d8b9609cda5f773e67c9df26c438a72518041f0a.tar.bz2
gentoo-2-d8b9609cda5f773e67c9df26c438a72518041f0a.zip
exchanging make with emake -j1, as this is equivalent. Thanks to vapier for talking it through; adjusting die messages
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/magicpoint/ChangeLog7
-rw-r--r--app-office/magicpoint/magicpoint-1.12a.ebuild18
2 files changed, 15 insertions, 10 deletions
diff --git a/app-office/magicpoint/ChangeLog b/app-office/magicpoint/ChangeLog
index bb34da235d2d..2e962fa47091 100644
--- a/app-office/magicpoint/ChangeLog
+++ b/app-office/magicpoint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/magicpoint
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.27 2007/09/24 20:14:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.28 2007/09/25 06:13:52 opfer Exp $
+
+ 25 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
+ magicpoint-1.12a.ebuild:
+ exchanging make with emake -j1, as this is equivalent. Thanks to vapier for
+ talking it through; adjusting die messages
24 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
magicpoint-1.12a.ebuild:
diff --git a/app-office/magicpoint/magicpoint-1.12a.ebuild b/app-office/magicpoint/magicpoint-1.12a.ebuild
index 64e4c690f78f..ae55a18c077d 100644
--- a/app-office/magicpoint/magicpoint-1.12a.ebuild
+++ b/app-office/magicpoint/magicpoint-1.12a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.12a.ebuild,v 1.4 2007/09/25 01:36:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.12a.ebuild,v 1.5 2007/09/25 06:13:51 opfer Exp $
inherit autotools elisp-common eutils fixheadtails
@@ -60,27 +60,27 @@ src_compile() {
--x-includes=/usr/X11R6/include || die "econf failed"
xmkmf || die "xmkmf failed"
- # emake fails miserably at all that
- make Makefiles || die "make failed"
- make clean || die "make clean failed"
- make BINDIR=/usr/bin LIBDIR=/etc/X11 || die "make failed"
+ # no parallel build possibly, anywhere
+ emake -j1 Makefiles || die "emake Makefiles failed"
+ emake -j1 clean || die "emake clean failed"
+ emake -j1 BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
use emacs && cp contrib/*.el "${S}" && \
elisp-compile *.el || die "elisp-compile failed"
}
src_install() {
- make \
+ emake -j1 \
DESTDIR="${D}" \
BINDIR=/usr/bin \
LIBDIR=/etc/X11 \
- install || die "make install failed"
+ install || die "emake install failed"
- make \
+ emake -j1 \
DESTDIR="${D}" \
DOCHTMLDIR=/usr/share/doc/${PF} \
MANPATH=/usr/share/man \
MANSUFFIX=1 \
- install.man || die "make install.man failed"
+ install.man || die "emake install.man failed"
exeinto /usr/bin
doexe contrib/{mgp2html.pl,mgp2latex.pl}