summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-05 14:31:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-05 14:31:15 +0000
commitb401f5df19e53672743cc7ec85551391d1346a79 (patch)
treece8b81bbe3c745870cfc4786f4660e7142f14a6d /app-office
parentremove old (diff)
downloadgentoo-2-b401f5df19e53672743cc7ec85551391d1346a79.tar.gz
gentoo-2-b401f5df19e53672743cc7ec85551391d1346a79.tar.bz2
gentoo-2-b401f5df19e53672743cc7ec85551391d1346a79.zip
Distribute help images wrt offlinehelp. Thanks to geki and his work on this.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/libreoffice-3.5.9999.ebuild34
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild23
3 files changed, 50 insertions, 13 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 918a7a10cea1..a54f16e54eb0 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.302 2012/05/05 10:30:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.303 2012/05/05 14:31:15 scarabeus Exp $
+
+ 05 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-3.5.9999.ebuild,
+ libreoffice-9999-r2.ebuild:
+ Distribute help images wrt offlinehelp. Thanks to geki and his work on this.
05 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Require beanshel/rhino only when building the specified extensions.
diff --git a/app-office/libreoffice/libreoffice-3.5.9999.ebuild b/app-office/libreoffice/libreoffice-3.5.9999.ebuild
index 628064675a83..272215bc7895 100644
--- a/app-office/libreoffice/libreoffice-3.5.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-3.5.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.9999.ebuild,v 1.40 2012/05/03 20:00:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.9999.ebuild,v 1.41 2012/05/05 14:31:15 scarabeus Exp $
EAPI=4
@@ -37,7 +37,7 @@ SRC_URI="branding? ( http://dev.gentooexperimental.org/~scarabeus/${BRANDING} )"
# Split modules following git/tarballs
# Core MUST be first!
-MODULES="core binfilter"
+MODULES="core binfilter help"
# Only release has the tarballs
if [[ ${PV} != *9999* ]]; then
for i in ${DEV_URI}; do
@@ -156,8 +156,8 @@ PDEPEND="
"
# FIXME: cppunit should be moved to test conditional
-# after everything upstream is under gbuild
-# as dmake execute tests right away
+# after everything upstream is under gbuild
+# as dmake execute tests right away
DEPEND="${COMMON_DEPEND}
>=dev-libs/boost-1.46
>=dev-libs/libxml2-2.7.8
@@ -323,10 +323,10 @@ src_configure() {
[[ -z ${jbs} ]] && jbs="1"
# sane: just sane.h header that is used for scan in writer, not
- # linked or anything else, worthless to depend on
+ # linked or anything else, worthless to depend on
# vigra: just uses templates from there
- # it is serious pain in the ass for packaging
- # should be replaced by boost::gil if someone interested
+ # it is serious pain in the ass for packaging
+ # should be replaced by boost::gil if someone interested
internal_libs+="
--without-system-sane
--without-system-vigra
@@ -468,7 +468,23 @@ src_configure() {
}
src_compile() {
- # this is not a proper make script and the jobs are passed during configure
+ # hack for offlinehelp, this needs fixing upstream at some point
+ # it is broken because we send --without-help
+ # https://bugs.freedesktop.org/show_bug.cgi?id=46506
+ (
+ source "${S}/Env.host.sh" 2&> /dev/null
+
+ local path="${SOLARVER}/${INPATH}/res/img"
+ mkdir -p "${path}" || die
+
+ echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=default_images/res/helpimg > \"${path}/helpimg.ilst\""
+ perl "${S}/helpcontent2/helpers/create_ilst.pl" \
+ -dir=default_images/res/helpimg \
+ > "${path}/helpimg.ilst"
+ [[ -s "${path}/helpimg.ilst" ]] || ewarn "The help images list is empty, something is fishy, report a bug."
+ )
+
+ # not a proper make script
make build || die
}
@@ -498,7 +514,7 @@ src_install() {
# It is broken because we send --without-help
# https://bugs.freedesktop.org/show_bug.cgi?id=46506
insinto /usr/$(get_libdir)/libreoffice/help
- doins xmlhelp/util/main_transform.xsl
+ doins xmlhelp/util/*.xsl
}
pkg_preinst() {
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 2680e42332e3..a9c4627c3c8c 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.63 2012/05/05 10:30:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.64 2012/05/05 14:31:15 scarabeus Exp $
EAPI=4
@@ -37,7 +37,8 @@ SRC_URI="branding? ( http://dev.gentooexperimental.org/~scarabeus/${BRANDING} )"
# Split modules following git/tarballs
# Core MUST be first!
-MODULES="core binfilter"
+# Help is used for the image generator
+MODULES="core binfilter help"
# Only release has the tarballs
if [[ ${PV} != *9999* ]]; then
for i in ${DEV_URI}; do
@@ -486,6 +487,22 @@ src_configure() {
}
src_compile() {
+ # hack for offlinehelp, this needs fixing upstream at some point
+ # it is broken because we send --without-help
+ # https://bugs.freedesktop.org/show_bug.cgi?id=46506
+ (
+ source "${S}/config_host.mk" 2&> /dev/null
+
+ local path="${SOLARVER}/${INPATH}/res/img"
+ mkdir -p "${path}" || die
+
+ echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=icon-themes/galaxy/res/helpimg > \"${path}/helpimg.ilst\""
+ perl "${S}/helpcontent2/helpers/create_ilst.pl" \
+ -dir=icon-themes/galaxy/res/helpimg \
+ > "${path}/helpimg.ilst"
+ [[ -s "${path}/helpimg.ilst" ]] || ewarn "The help images list is empty, something is fishy, report a bug."
+ )
+
# this is not a proper make script
make build || die
}
@@ -517,7 +534,7 @@ src_install() {
# It is broken because we send --without-help
# https://bugs.freedesktop.org/show_bug.cgi?id=46506
insinto /usr/$(get_libdir)/libreoffice/help
- doins xmlhelp/util/main_transform.xsl
+ doins xmlhelp/util/*.xsl
}
pkg_preinst() {