summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-03 12:34:21 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-03 12:34:21 +0000
commita8465930ffbd39197b3c7534e6b0d7618591721a (patch)
tree731e1e1dc65c25cede99376998c5d17aeeef71c8 /app-office
parentversion bump (diff)
downloadgentoo-2-a8465930ffbd39197b3c7534e6b0d7618591721a.tar.gz
gentoo-2-a8465930ffbd39197b3c7534e6b0d7618591721a.tar.bz2
gentoo-2-a8465930ffbd39197b3c7534e6b0d7618591721a.zip
Pass headless to test runs. This should solve various dbus/assert crashes and bug#410317.
(Portage version: 2.2.0_alpha98/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-3.5.2-tests-headless.patch37
-rw-r--r--app-office/libreoffice/libreoffice-3.5.2.2.ebuild3
3 files changed, 45 insertions, 2 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 3b96e23904a0..2d79d56c349b 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.274 2012/04/03 07:28:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.275 2012/04/03 12:34:21 scarabeus Exp $
+
+ 03 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libreoffice-3.5.2-tests-headless.patch, libreoffice-3.5.2.2.ebuild:
+ Pass headless to test runs. This should solve various dbus/assert crashes and
+ bug#410317.
03 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+files/libreoffice-3.5.2-icu-49-part2.patch, libreoffice-3.5.2.2.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-3.5.2-tests-headless.patch b/app-office/libreoffice/files/libreoffice-3.5.2-tests-headless.patch
new file mode 100644
index 000000000000..e654c9b384c0
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-3.5.2-tests-headless.patch
@@ -0,0 +1,37 @@
+From b8ec5464300a0c909166197a09a80c837b90fef5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Chv=C3=A1tal?= <tchvatal@suse.cz>
+Date: Tue, 3 Apr 2012 14:21:23 +0200
+Subject: [PATCH] always pass --headless to cppunits
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+They should not need any actual UI anyway, and most of them already
+pass the option manually.
+http://lists.freedesktop.org/archives/libreoffice/2012-March/029109.html
+
+This is partial code grab as cherry-pick had the test-mk files collisions
+all over the place. I pick only the additional define which results in some
+tests adding --headless twice, which does no harm.
+
+Author: Luboš Luňák <l.lunak@suse.cz>
+Signed-off-by: Tomáš Chvátal <tchvatal@suse.cz>
+---
+ solenv/gbuild/CppunitTest.mk | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/solenv/gbuild/CppunitTest.mk b/solenv/gbuild/CppunitTest.mk
+index 0d8959e..826d3f5 100644
+--- a/solenv/gbuild/CppunitTest.mk
++++ b/solenv/gbuild/CppunitTest.mk
+@@ -61,6 +61,7 @@ gb_CppunitTarget__make_url = file://$(if $(filter WNT,$(OS_FOR_BUILD)),/)$(1)
+ gb_CppunitTest__get_uno_type_target = $(OUTDIR)/bin/$(1).rdb
+ define gb_CppunitTest__make_args
+ $(ARGS) \
++--headless \
+ $(if $(strip $(UNO_TYPES)),\
+ "-env:UNO_TYPES=$(foreach rdb,udkapi $(UNO_TYPES),\
+ $(call gb_CppunitTarget__make_url,$(call gb_CppunitTest__get_uno_type_target,$(rdb))))") \
+--
+1.7.7
+
diff --git a/app-office/libreoffice/libreoffice-3.5.2.2.ebuild b/app-office/libreoffice/libreoffice-3.5.2.2.ebuild
index 6953b6d7cde4..54f74cf97bd1 100644
--- a/app-office/libreoffice/libreoffice-3.5.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.5.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.2.2.ebuild,v 1.6 2012/04/03 07:28:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.5.2.2.ebuild,v 1.7 2012/04/03 12:34:21 scarabeus Exp $
EAPI=4
@@ -196,6 +196,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.5-propagate-gb_FULLDEPS.patch"
"${FILESDIR}/${PN}-3.5.2-icu-49.patch"
"${FILESDIR}/${PN}-3.5.2-icu-49-part2.patch"
+ "${FILESDIR}/${PN}-3.5.2-tests-headless.patch"
)
REQUIRED_USE="