summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-06-08 00:41:01 +0000
committerMarinus Schraal <foser@gentoo.org>2003-06-08 00:41:01 +0000
commit675881039d1a266ef4a9d36ec0a8b05f7ea53ac3 (patch)
treeb9efd08e1f3807b39d24cc61fd4bcfcc14217283 /app-office
parentreenabled gnome support (diff)
downloadgentoo-2-675881039d1a266ef4a9d36ec0a8b05f7ea53ac3.tar.gz
gentoo-2-675881039d1a266ef4a9d36ec0a8b05f7ea53ac3.tar.bz2
gentoo-2-675881039d1a266ef4a9d36ec0a8b05f7ea53ac3.zip
reenabled gnome support
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/Manifest4
-rw-r--r--app-office/abiword/abiword-1.0.6-r1.ebuild81
-rw-r--r--app-office/abiword/files/digest-abiword-1.0.6-r11
4 files changed, 90 insertions, 3 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 2a096402c92b..0d0e5f695304 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.36 2003/06/01 06:34:06 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.37 2003/06/08 00:40:52 foser Exp $
+
+*abiword-1.0.6-r1 (07 Jun 2003)
+
+ 07 Jun 2003; foser <foser@gentoo.org> abiword-1.0.6-r1.ebuild :
+ reenabled gnome USE
*abiword-1.0.6 (01 Jun 2003)
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 319c041dd47a..af49794ae7b7 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,9 +1,9 @@
-MD5 7367b4953a0720f1d654d783539158f7 abiword-1.0.6-r1.ebuild 1931
+MD5 45ef3c97f810939b519b426c06cb5309 abiword-1.0.6-r1.ebuild 1932
MD5 abc2e2533728780d556f1b3b4f76208b abiword-1.0.2-r1.ebuild 4692
MD5 c5ae3337735d638b699db192edaf03b0 abiword-1.0.6.ebuild 2017
MD5 621e5db238b3aea21cf8dbb65aa6f5fb abiword-1.0.3.ebuild 4648
MD5 2b025fa06432cfef4ab76f015d7af6af abiword-1.9.1.ebuild 2385
-MD5 84ae01c6ff5a9ac56d79130ff30a2014 ChangeLog 5985
+MD5 6ac38d8943763af06e5dacd39aeba919 ChangeLog 6103
MD5 24e5e79582e10e3a1bde1472b096c790 abiword-1.0.5.ebuild 2012
MD5 4ab387fa04b0102a395a4b654f0714df files/abiword-1.1.4-wv_configure_fooling.patch 1575
MD5 ec999635047cabecdcece23cd40d4bd9 files/digest-abiword-1.0.3 67
diff --git a/app-office/abiword/abiword-1.0.6-r1.ebuild b/app-office/abiword/abiword-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..5a46419fcec3
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.6-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.6-r1.ebuild,v 1.1 2003/06/08 00:40:52 foser Exp $
+
+inherit flag-o-matic
+
+replace-flags "-O?" "-O1"
+IUSE="nls spell jpeg xml2 gnome"
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Word processor"
+SRC_URI="mirror://sourceforge/abiword/${P}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="1"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50.2-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-extra/gal-1.99
+ >=gnome-base/bonobo-1.0.9-r1 )"
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --with-gnome --enable-gnome"; \
+ export ABI_OPT_BONOBO=1
+
+ use spell \
+ && myconf="${myconf} --with-pspell --disable-static"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+ einfo "Ignore above errors if it does not cause the build to fail"
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ # we got enough of the perl problems for now
+ econf ${myconf} --disable-scripting
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}
diff --git a/app-office/abiword/files/digest-abiword-1.0.6-r1 b/app-office/abiword/files/digest-abiword-1.0.6-r1
new file mode 100644
index 000000000000..d0a527459fa3
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.0.6-r1
@@ -0,0 +1 @@
+MD5 b35ea76f8d3eb70a94c3432a44e4a9d9 abiword-1.0.6.tar.gz 18598390