summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-04-18 23:40:55 +0000
committerVlastimil Babka <caster@gentoo.org>2009-04-18 23:40:55 +0000
commitb0d4d2f8caa21028d7607fcf2223d49bb4a78c40 (patch)
tree691e461b5091b87e33cae32d7e52a6dcd2ac0b78 /app-office/taskcoach
parentStable on amd64, bug #266707 (diff)
downloadgentoo-2-b0d4d2f8caa21028d7607fcf2223d49bb4a78c40.tar.gz
gentoo-2-b0d4d2f8caa21028d7607fcf2223d49bb4a78c40.tar.bz2
gentoo-2-b0d4d2f8caa21028d7607fcf2223d49bb4a78c40.zip
Version bump. Fixes lockfile.py problems with python 2.6.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-0.72.6.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index ce24189cb5e3..c039cbbc7aa1 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.22 2009/04/05 18:46:14 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.23 2009/04/18 23:40:55 caster Exp $
+
+*taskcoach-0.72.6 (18 Apr 2009)
+
+ 18 Apr 2009; Vlastimil Babka <caster@gentoo.org> +taskcoach-0.72.6.ebuild:
+ Version bump. Fixes lockfile.py problems with python 2.6.
*taskcoach-0.72.5 (05 Apr 2009)
diff --git a/app-office/taskcoach/taskcoach-0.72.6.ebuild b/app-office/taskcoach/taskcoach-0.72.6.ebuild
new file mode 100644
index 000000000000..9e1470526bf7
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-0.72.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.72.6.ebuild,v 1.1 2009/04/18 23:40:55 caster Exp $
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.4
+ =dev-python/wxpython-2.8*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ if ! use x86; then
+ elog "Removing Funambol support, works only on x86."
+ rm -fv taskcoachlib/bin.in/linux/*.so || die
+ fi
+}
+
+src_compile() {
+ # upstream now sets executable to /usr/bin/python2.5
+ distutils_src_compile --executable=/usr/bin/python
+}
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ rm "${D}/usr/bin/taskcoach.pyw" || die
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}