summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-12-01 17:57:06 +0000
committerMart Raudsepp <leio@gentoo.org>2011-12-01 17:57:06 +0000
commita70765b64b41ba86f9d359d7064b657c360cca97 (patch)
tree367df79c6ece7a3711372afcfd3dd428bb9f077a /app-office/pinpoint
parentadd some prefix keywords (diff)
downloadgentoo-2-a70765b64b41ba86f9d359d7064b657c360cca97.tar.gz
gentoo-2-a70765b64b41ba86f9d359d7064b657c360cca97.tar.bz2
gentoo-2-a70765b64b41ba86f9d359d7064b657c360cca97.zip
Version bump. Start of speaker screen support, camera based background support, screensaver inhibiting when fullscreen, etc
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/ChangeLog8
-rw-r--r--app-office/pinpoint/pinpoint-0.1.4.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/app-office/pinpoint/ChangeLog b/app-office/pinpoint/ChangeLog
index bc00dda5e389..e26823c3f4fd 100644
--- a/app-office/pinpoint/ChangeLog
+++ b/app-office/pinpoint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/pinpoint
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/ChangeLog,v 1.1 2011/08/24 06:27:38 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/ChangeLog,v 1.2 2011/12/01 17:57:06 leio Exp $
+
+*pinpoint-0.1.4 (01 Dec 2011)
+
+ 01 Dec 2011; Mart Raudsepp <leio@gentoo.org> +pinpoint-0.1.4.ebuild:
+ Version bump. Start of speaker screen support, camera based background
+ support, screensaver inhibiting when fullscreen, etc
*pinpoint-0.1.2 (24 Aug 2011)
diff --git a/app-office/pinpoint/pinpoint-0.1.4.ebuild b/app-office/pinpoint/pinpoint-0.1.4.ebuild
new file mode 100644
index 000000000000..903f5c5b4ec8
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/pinpoint-0.1.4.ebuild,v 1.1 2011/12/01 17:57:06 leio Exp $
+
+EAPI=4
+
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome.org
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://live.gnome.org/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND=">=media-libs/clutter-1.4:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( >=media-libs/clutter-gst-1.3:1.0 )
+ pdf? ( gnome-base/librsvg:2 )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ econf --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+ fi
+}