summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-09-24 05:41:22 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-09-24 05:41:22 +0000
commite99c24e4b42aec70a6726fcec2eb5a070cf99dd5 (patch)
tree04ebadbb2315ed3796593003e120d02fcb288d0a /app-office/openoffice-ximian
parentstable on x86 (diff)
downloadgentoo-2-e99c24e4b42aec70a6726fcec2eb5a070cf99dd5.tar.gz
gentoo-2-e99c24e4b42aec70a6726fcec2eb5a070cf99dd5.tar.bz2
gentoo-2-e99c24e4b42aec70a6726fcec2eb5a070cf99dd5.zip
Fix building without java and libxslt >=1.1.5, closes bug #106174
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-office/openoffice-ximian')
-rw-r--r--app-office/openoffice-ximian/ChangeLog6
-rw-r--r--app-office/openoffice-ximian/files/1.1.5/build-new-xslt.diff20
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild11
3 files changed, 33 insertions, 4 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index e7e9081079ee..8f5c9cd6fd17 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.139 2005/09/17 14:16:30 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.140 2005/09/24 05:36:47 suka Exp $
+
+ 24 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/1.1.5/build-new-xslt.diff, openoffice-ximian-1.3.16.ebuild:
+ Fix building without java and libxslt >=1.1.5, closes bug #106174
17 Sep 2005; Andreas Proschofsky <suka@gentoo.org>
files/1.1.5/gentoo-1.3.16.patch:
diff --git a/app-office/openoffice-ximian/files/1.1.5/build-new-xslt.diff b/app-office/openoffice-ximian/files/1.1.5/build-new-xslt.diff
new file mode 100644
index 000000000000..972ac902af21
--- /dev/null
+++ b/app-office/openoffice-ximian/files/1.1.5/build-new-xslt.diff
@@ -0,0 +1,20 @@
+--- officecfg/util/resource.xsl.orig 2005-09-23 14:00:56.000000000 +0200
++++ officecfg/util/resource.xsl 2005-09-23 14:02:14.000000000 +0200
+@@ -84,7 +84,8 @@
+ </xsl:template>
+
+ <!-- match all elements that could possibly contain info elements -->
+- <xsl:template match="info/desc[@xml:lang=$locale]|info/label[@xml:lang=$locale]">
++ <xsl:template match="info/desc|info/label">
++ <xsl:if test="@xml:lang=$locale">
+
+ <!-- print TPF's path to current node -->
+ <xsl:for-each select="ancestor-or-self::*">
+@@ -108,6 +109,7 @@
+
+ <xsl:apply-templates/>
+
++ </xsl:if>
+ </xsl:template>
+
+ </xsl:transform>
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild
index f5af159f7404..d06da44ecde4 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild,v 1.1 2005/09/17 07:33:36 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.16.ebuild,v 1.2 2005/09/24 05:36:47 suka Exp $
# Notes:
#
@@ -131,7 +131,7 @@ pkg_setup() {
set_languages () {
- strip-linguas en pt ru el nl fr es fi hu ca it cs sk da sv nb no pl de sl pt_BR th et ja ko zh_CN zh_TW tr hi_IN ar he
+ strip-linguas en pt ru el nl fr es fi hu ca it cs sk da sv nb nn pl de sl pt_BR th et ja ko zh_CN zh_TW tr hi_IN ar he
if [ -n "${LINGUAS}" ] ; then
# use the leftmost value
temp_lang=( ${LINGUAS} )
@@ -171,7 +171,9 @@ set_languages () {
;;
sv ) OOLANGNO=46; OOLANGNAME=SWED; OOLFULLNAME=Swedish
;;
- no ) OOLANGNO=47; OOLANGNAME=NORBOK; OOLFULLNAME="Norwegian"
+ nn ) OOLANGNO=79; OOLANGNAME=NORNYN; OOLFULLNAME="Norwegian"
+ ;;
+ nb ) OOLANGNO=47; OOLANGNAME=NORBOK; OOLFULLNAME="Norwegian"
;;
pl ) OOLANGNO=48; OOLANGNAME=POL; OOLFULLNAME=Polish
;;
@@ -268,6 +270,9 @@ src_unpack() {
#fix for bug #82385
epatch ${FILESDIR}/${OO_VER}/getcompver.awk.patch
+ #Allow building with libxslt >= 1.1.15
+ use java || epatch ${FILESDIR}/${OO_VER}/build-new-xslt.diff
+
#Workaround for bug #73940, may break debug use flag on ppc
if use ppc; then
epatch ${FILESDIR}/${OO_VER}/STLport-vector.patch