summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-12-13 00:22:36 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-12-13 00:22:36 +0000
commit8356192150e63e1239cd5697d0cd9da3a100b103 (patch)
treee64f2c0fe04af3e7749b2a82a9dd3647f1f034a8 /app-office/libreoffice-bin-debug
parentVersion bump because of bug 445032 (diff)
downloadgentoo-2-8356192150e63e1239cd5697d0cd9da3a100b103.tar.gz
gentoo-2-8356192150e63e1239cd5697d0cd9da3a100b103.tar.bz2
gentoo-2-8356192150e63e1239cd5697d0cd9da3a100b103.zip
Version bump because of bug 445032
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key B6C5F7DE)
Diffstat (limited to 'app-office/libreoffice-bin-debug')
-rw-r--r--app-office/libreoffice-bin-debug/ChangeLog8
-rw-r--r--app-office/libreoffice-bin-debug/libreoffice-bin-debug-3.6.4.3.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/app-office/libreoffice-bin-debug/ChangeLog b/app-office/libreoffice-bin-debug/ChangeLog
index 1a7f14978f46..3b169f8d5f86 100644
--- a/app-office/libreoffice-bin-debug/ChangeLog
+++ b/app-office/libreoffice-bin-debug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-bin-debug
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.22 2012/11/24 21:47:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.23 2012/12/13 00:22:36 dilfridge Exp $
+
+*libreoffice-bin-debug-3.6.4.3 (13 Dec 2012)
+
+ 13 Dec 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libreoffice-bin-debug-3.6.4.3.ebuild:
+ Version bump because of bug 445032
24 Nov 2012; Agostino Sarubbo <ago@gentoo.org>
libreoffice-bin-debug-3.6.3.2.ebuild:
diff --git a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-3.6.4.3.ebuild b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-3.6.4.3.ebuild
new file mode 100644
index 000000000000..e62f4447731f
--- /dev/null
+++ b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-3.6.4.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/libreoffice-bin-debug-3.6.4.3.ebuild,v 1.1 2012/12/13 00:22:36 dilfridge Exp $
+
+EAPI=5
+
+BASE_AMD64_URI="mirror://gentoo/amd64-debug-"
+BASE_X86_URI="mirror://gentoo/x86-debug-"
+
+DESCRIPTION="LibreOffice, a full office productivity suite. Binary package, debug info."
+HOMEPAGE="http://www.libreoffice.org"
+SRC_URI_AMD64="
+ kde? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-kde-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-kde-java-${PVR}.tar.xz )
+ )
+ gnome? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-gnome-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-gnome-java-${PVR}.tar.xz )
+ )
+ !kde? ( !gnome? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-base-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-base-java-${PVR}.tar.xz )
+ ) )
+"
+SRC_URI_X86="
+ kde? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-kde-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-kde-java-${PVR}.tar.xz )
+ )
+ gnome? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-gnome-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-gnome-java-${PVR}.tar.xz )
+ )
+ !kde? ( !gnome? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-base-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-base-java-${PVR}.tar.xz )
+ ) )
+"
+
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
+IUSE="gnome java kde"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=app-office/${PN/-debug}-${PVR}[gnome=,java=,kde=]"
+
+RESTRICT="test strip"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr
+ cp -aR "${S}"/usr/* "${ED}"/usr/ || die
+}