summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-06-21 08:43:02 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-06-21 08:43:02 +0000
commitf46440261fd8dae13483fbad49bbb152a34e2514 (patch)
tree80454981630b8709d049c2202e8f0c7325b39156 /app-office/kexi
parentFinal release of KOffice 1.4. (diff)
downloadgentoo-2-f46440261fd8dae13483fbad49bbb152a34e2514.tar.gz
gentoo-2-f46440261fd8dae13483fbad49bbb152a34e2514.tar.bz2
gentoo-2-f46440261fd8dae13483fbad49bbb152a34e2514.zip
Final release of KOffice 1.4.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/ChangeLog7
-rw-r--r--app-office/kexi/files/digest-kexi-1.4.01
-rw-r--r--app-office/kexi/kexi-1.4.0.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 68451c8b510b..d128d019a0c0 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.3 2005/06/11 09:44:51 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.4 2005/06/21 08:38:18 greg_g Exp $
+
+*kexi-1.4.0 (21 Jun 2005)
+
+ 21 Jun 2005; Gregorio Guidi <greg_g@gentoo.org> +kexi-1.4.0.ebuild:
+ Final release of KOffice 1.4.
11 Jun 2005; Markus Rothe <corsair@gentoo.org> kexi-1.4.0_rc1.ebuild:
Added ~ppc64; bug #95128
diff --git a/app-office/kexi/files/digest-kexi-1.4.0 b/app-office/kexi/files/digest-kexi-1.4.0
new file mode 100644
index 000000000000..aada0edc41ee
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.4.0
@@ -0,0 +1 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
diff --git a/app-office/kexi/kexi-1.4.0.ebuild b/app-office/kexi/kexi-1.4.0.ebuild
new file mode 100644
index 000000000000..280d88e83716
--- /dev/null
+++ b/app-office/kexi/kexi-1.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.4.0.ebuild,v 1.1 2005/06/21 08:38:18 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python
+ !dev-db/kexi"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoscript lib/koscript
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.3
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+
+ kde-meta_src_compile
+}