summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-28 14:32:14 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-28 14:32:14 +0000
commit4ef26189e5554792790a1deb052bd095fef4041a (patch)
tree14c835ea3bfc13af087efe8d93ddfff9a77794f8 /app-office/gnucash
parentMarking stable. (diff)
downloadgentoo-2-4ef26189e5554792790a1deb052bd095fef4041a.tar.gz
gentoo-2-4ef26189e5554792790a1deb052bd095fef4041a.tar.bz2
gentoo-2-4ef26189e5554792790a1deb052bd095fef4041a.zip
add docs support
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/ChangeLog5
-rw-r--r--app-office/gnucash/Manifest4
-rw-r--r--app-office/gnucash/gnucash-1.8.2-r1.ebuild46
3 files changed, 44 insertions, 11 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index b935756ab620..2cdc114089ea 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.19 2003/04/28 11:11:46 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.20 2003/04/28 14:32:06 liquidx Exp $
*gnucash-1.8.2-r1 (28 Apr 2003)
28 Apr 2003; Alastair Tse <liquidx@gentoo.org> gnucash-1.8.2-r1.ebuild:
- ./configure doesn't accept --disable-*
+ added docs support
+ workaround ./configure doesn't accept --disable-*
28 Apr 2003; Alastair Tse <liquidx@gentoo.org> gnucash-1.8.2-r1.ebuild:
new gnucash that has ofx and hbci support.
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
index 9047ebf1d9e5..583f0bd6a2da 100644
--- a/app-office/gnucash/Manifest
+++ b/app-office/gnucash/Manifest
@@ -1,8 +1,8 @@
-MD5 10476c7a2d81452304029683b6c2f1f8 ChangeLog 3508
+MD5 4c8c770e989d9143f86c37b1b6c02cfc ChangeLog 3540
MD5 b8e0eec1a6bcd963f2ce26db9abf9b9f gnucash-1.8.1.ebuild 1455
MD5 54902cd500c04f0659cd9a7d3438f1cd gnucash-1.8.2.ebuild 1546
MD5 4800e560c499c667d2c95a7e3b01c42b gnucash-1.6.8.ebuild 1882
-MD5 dfe89fd88679a797025a645ef2a9355e gnucash-1.8.2-r1.ebuild 1772
+MD5 a4a179f3cba1d6f4856a2fa353f35776 gnucash-1.8.2-r1.ebuild 2654
MD5 e298b9154a60df27ab519e6b88dd4c47 files/digest-gnucash-1.8.1 66
MD5 cdaa1f2adfbd3112916a8c2076fa04bd files/digest-gnucash-1.8.2 66
MD5 cdaa1f2adfbd3112916a8c2076fa04bd files/digest-gnucash-1.8.2-r1 66
diff --git a/app-office/gnucash/gnucash-1.8.2-r1.ebuild b/app-office/gnucash/gnucash-1.8.2-r1.ebuild
index 775aeb3edd78..ed0e280d0b53 100644
--- a/app-office/gnucash/gnucash-1.8.2-r1.ebuild
+++ b/app-office/gnucash/gnucash-1.8.2-r1.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.2-r1.ebuild,v 1.2 2003/04/28 11:11:46 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.2-r1.ebuild,v 1.3 2003/04/28 14:32:06 liquidx Exp $
inherit flag-o-matic libtool
# won't configure with this
filter-flags -fomit-frame-pointer
+DOC_VER="1.8.0"
+IUSE="nls postgres ofx hbci doc"
+
DESCRIPTION="A personal finance manager"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-docs-${DOC_VER}.tar.gz )"
HOMEPAGE="http://www.gnucash.org/"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86"
SLOT="0"
LICENSE="GPL-2"
-IUSE="nls postgres ofx hbci"
RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
>=dev-util/guile-1.6
@@ -42,7 +45,9 @@ DEPEND="${RDEPEND}
>=dev-lang/swig-1.3_alpha4
<gnome-base/libglade-2
gnome-base/libghttp
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ doc? ( >=app-text/scrollkeeper-0.3.1
+ app-text/docbook-xsl-stylesheets )"
MAKEOPTS="${MAKEOPTS} -j1"
@@ -60,12 +65,39 @@ src_compile() {
econf \
`use_enable nls` \
- ${myconf} || die
+ ${myconf} || die "configure failed"
- emake || die
+ emake || die "make failed"
+
+ if [ -n "`use doc`" ]; then
+ cd ${WORKDIR}/${PN}-docs-${DOC_VER}
+ econf --localstatedir=/var/lib || die "doc configure failed"
+ emake || die "doc make failed"
+ fi
}
src_install() {
einstall pkgdatadir=${D}/usr/share/gnucash || die "install failed"
dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+ dodoc docs/README*
+
+ if [ -n "`use doc`" ]; then
+ cd ${WORKDIR}/${PN}-docs-${DOC_VER}
+ make DESTDIR=${D} install || die "doc install failed"
+ rm -rf ${D}/var/lib/scrollkeeper
+ fi
+}
+
+pkg_postinst() {
+ if [ -x ${ROOT}/usr/bin/scrollkeeper-update ]; then
+ echo ">>> Updating Scrollkeeper"
+ scrollkeeper-update -q -p ${ROOT}/var/lib/scrollkeeper
+ fi
+}
+
+pkg_postrm() {
+ if [ -x ${ROOT}/usr/bin/scrollkeeper-update ]; then
+ echo ">>> Updating Scrollkeeper"
+ scrollkeeper-update -q -p ${ROOT}/var/lib/scrollkeeper
+ fi
}