summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-17 21:06:35 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-17 21:06:35 +0000
commitd754c8661d56456d08e2fdd6d748d558eed342ff (patch)
treed8413df126f2d7e3be5b278d7e667a4c01c3e2cb /app-mobilephone
parentAdd explicit dep on python-exec:0 since the package wraps the script manually. (diff)
downloadgentoo-2-d754c8661d56456d08e2fdd6d748d558eed342ff.tar.gz
gentoo-2-d754c8661d56456d08e2fdd6d748d558eed342ff.tar.bz2
gentoo-2-d754c8661d56456d08e2fdd6d748d558eed342ff.zip
Add patch to fix bash-completion file install location wrt bug 483234
(Portage version: 2.2.3/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog12
-rw-r--r--app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch12
-rw-r--r--app-mobilephone/gammu/gammu-1.29.0.ebuild103
-rw-r--r--app-mobilephone/gammu/gammu-1.30.0.ebuild106
-rw-r--r--app-mobilephone/gammu/gammu-1.32.0-r1.ebuild (renamed from app-mobilephone/gammu/gammu-1.32.0.ebuild)9
5 files changed, 26 insertions, 216 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index caee5555af41..3de56129f9d9 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/gammu
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.93 2012/11/08 09:38:52 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.94 2013/09/17 21:06:35 creffett Exp $
+
+*gammu-1.32.0-r1 (17 Sep 2013)
+
+ 17 Sep 2013; Chris Reffett <creffett@gentoo.org>
+ +files/gammu-1.32.0-bashcompdir.patch, +gammu-1.32.0-r1.ebuild,
+ -gammu-1.29.0.ebuild, -gammu-1.30.0.ebuild, -gammu-1.32.0.ebuild:
+ Add patch to fix bash-completion file install location wrt bug 483234
*gammu-1.32.0 (08 Nov 2012)
@@ -519,4 +526,3 @@
13 Mar 2004; Lim Swee Tat <st_lim@gentoo.org> :
First release
-
diff --git a/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch b/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch
new file mode 100644
index 000000000000..d7ae0a5b8b10
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch
@@ -0,0 +1,12 @@
+diff -ruN gammu-1.32.0/contrib/CMakeLists.txt gammu-1.32.0-patched/contrib/CMakeLists.txt
+--- gammu-1.32.0/contrib/CMakeLists.txt 2012-06-27 04:02:27.000000000 -0400
++++ gammu-1.32.0-patched/contrib/CMakeLists.txt 2013-09-17 16:46:22.852164906 -0400
+@@ -85,7 +85,7 @@
+ if (INSTALL_BASH_COMPLETION)
+ install (
+ FILES bash-completion/gammu
+- DESTINATION "/etc/bash_completion.d"
++ DESTINATION "/usr/share/bash-completion/"
+ COMPONENT "bash"
+ )
+ endif (INSTALL_BASH_COMPLETION)
diff --git a/app-mobilephone/gammu/gammu-1.29.0.ebuild b/app-mobilephone/gammu/gammu-1.29.0.ebuild
deleted file mode 100644
index 0aa744124ad0..000000000000
--- a/app-mobilephone/gammu/gammu-1.29.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.29.0.ebuild,v 1.3 2012/05/22 16:06:13 ssuominen Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-
-inherit eutils cmake-utils python
-
-DESCRIPTION="A tool to handle your cellular phone"
-HOMEPAGE="http://www.wammu.eu/"
-SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
-
-RDEPEND="bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- usb? ( virtual/libusb:1 )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- dbi? ( >=dev-db/libdbi-0.8.3 )
- dev-util/dialog
- !dev-python/python-gammu" # needs to be removed from the tree
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- dev-util/cmake"
-
-# sys-devel/gettext is needed for creating .mo files
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-skip-locktest.patch
-
- local lang support_linguas=no
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
- fi
- done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
-}
-
-src_configure() {
- # debug flag is used inside cmake-utils.eclass
- local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
- $(cmake-utils_use_with irda IRDA) \
- $(cmake-utils_use_with curl CURL) \
- $(cmake-utils_use_with usb USB) \
- $(cmake-utils_use_with python PYTHON) \
- $(cmake-utils_use_with mysql MySQL) \
- $(cmake-utils_use_with postgres Postgres) \
- $(cmake-utils_use_with dbi LibDBI) \
- $(cmake-utils_use_with nls GettextLibs) \
- $(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
- if use python; then
- mycmakeargs="${mycmakeargs} -DBUILD_PYTHON=$(PYTHON -a)"
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
-}
-
-pkg_postinst() {
- use python && python_mod_optimize gammu
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup gammu
-}
diff --git a/app-mobilephone/gammu/gammu-1.30.0.ebuild b/app-mobilephone/gammu/gammu-1.30.0.ebuild
deleted file mode 100644
index adc786312f63..000000000000
--- a/app-mobilephone/gammu/gammu-1.30.0.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.30.0.ebuild,v 1.3 2012/05/22 16:06:13 ssuominen Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="python? 2"
-
-inherit eutils cmake-utils python
-
-DESCRIPTION="A tool to handle your cellular phone"
-HOMEPAGE="http://www.wammu.eu/"
-SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion curl debug bluetooth irda mysql postgres dbi nls python usb"
-
-RDEPEND="bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- usb? ( virtual/libusb:1 )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-server )
- dbi? ( >=dev-db/libdbi-0.8.3 )
- dev-util/dialog
- !dev-python/python-gammu" # needs to be removed from the tree
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- dev-util/cmake"
-
-# sys-devel/gettext is needed for creating .mo files
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-skip-locktest.patch
-
- local lang support_linguas=no
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
- fi
- done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -rf locale/${lang} || die
- fi
- done
- fi
-}
-
-src_configure() {
- # debug flag is used inside cmake-utils.eclass
- local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
- $(cmake-utils_use_with irda IRDA) \
- $(cmake-utils_use_with curl CURL) \
- $(cmake-utils_use_with usb USB) \
- $(cmake-utils_use_with python PYTHON) \
- $(cmake-utils_use_with mysql MySQL) \
- $(cmake-utils_use_with postgres Postgres) \
- $(cmake-utils_use_with dbi LibDBI) \
- $(cmake-utils_use_with nls GettextLibs) \
- $(cmake-utils_use_with nls Iconv) \
- -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
- if ! use bash-completion; then
- mycmakeargs="${mycmakeargs} -DINSTALL_BASH_COMPLETION=OFF"
- fi
- if use python; then
- mycmakeargs="${mycmakeargs} -DBUILD_PYTHON=$(PYTHON -a)"
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
-}
-
-pkg_postinst() {
- use python && python_mod_optimize gammu
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup gammu
-}
diff --git a/app-mobilephone/gammu/gammu-1.32.0.ebuild b/app-mobilephone/gammu/gammu-1.32.0-r1.ebuild
index 0d7e380ef57d..03173f65de26 100644
--- a/app-mobilephone/gammu/gammu-1.32.0.ebuild
+++ b/app-mobilephone/gammu/gammu-1.32.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.32.0.ebuild,v 1.1 2012/11/08 09:38:52 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.32.0-r1.ebuild,v 1.1 2013/09/17 21:06:35 creffett Exp $
-EAPI="4"
+EAPI=5
PYTHON_DEPEND="python? 2"
@@ -42,7 +42,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-skip-locktest.patch
+ epatch "${FILESDIR}/${PN}-skip-locktest.patch"
+ epatch "${FILESDIR}/${PN}-1.32.0-bashcompdir.patch"
local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do