summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-08-19 19:24:47 +0000
committerAlin Năstac <mrness@gentoo.org>2008-08-19 19:24:47 +0000
commit7331c074847c2c37fee689b9cc5363994dd2d8bf (patch)
treeaf33c958a0d7e043708c730528b3f9896420da77 /app-mobilephone
parentUpdate HOMEPAGE (#235046). (diff)
downloadgentoo-2-7331c074847c2c37fee689b9cc5363994dd2d8bf.tar.gz
gentoo-2-7331c074847c2c37fee689b9cc5363994dd2d8bf.tar.bz2
gentoo-2-7331c074847c2c37fee689b9cc5363994dd2d8bf.zip
Version bump. Change wxpython dependency atom (#225593).
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/wammu-0.28.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index dc87b4d41f74..bc75e4dd372e 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.31 2008/06/07 12:54:56 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.32 2008/08/19 19:24:47 mrness Exp $
+
+*wammu-0.28 (19 Aug 2008)
+
+ 19 Aug 2008; Alin Năstac <mrness@gentoo.org> +wammu-0.28.ebuild:
+ Version bump. Change wxpython dependency atom (#225593).
*wammu-0.27 (07 Jun 2008)
diff --git a/app-mobilephone/wammu/wammu-0.28.ebuild b/app-mobilephone/wammu/wammu-0.28.ebuild
new file mode 100644
index 000000000000..8e0b64e4c50f
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.28.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.28.ebuild,v 1.1 2008/08/19 19:24:47 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=dev-python/wxpython-2.8
+ >=dev-python/python-gammu-0.24
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ca cs de es et fi fr gl he hu it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ pushd "${S}"/locale || die "locale directory not found"
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r ${lang}
+ fi
+ done
+ fi
+ popd
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}