summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-01-16 20:31:33 +0000
committerAlin Năstac <mrness@gentoo.org>2007-01-16 20:31:33 +0000
commit4101f14be906027e9f692857f5a57f93940c3f23 (patch)
treea13caee043211e1cca0ac7823b0f1d2324bcd44d /app-mobilephone
parentBump to 3.5.6 (prerelease). (diff)
downloadgentoo-2-4101f14be906027e9f692857f5a57f93940c3f23.tar.gz
gentoo-2-4101f14be906027e9f692857f5a57f93940c3f23.tar.bz2
gentoo-2-4101f14be906027e9f692857f5a57f93940c3f23.zip
Add -fno-strict-aliasing. Stable on x86.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnokii/ChangeLog10
-rw-r--r--app-mobilephone/gnokii/files/digest-gnokii-0.6.14-r23
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.14-r2.ebuild137
3 files changed, 148 insertions, 2 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index 43fcb4468360..ab3a80150c43 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gnokii
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.48 2006/12/27 10:27:18 mrness Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.49 2007/01/16 20:31:33 mrness Exp $
+
+*gnokii-0.6.14-r2 (16 Jan 2007)
+
+ 16 Jan 2007; Alin Năstac <mrness@gentoo.org> -gnokii-0.6.14-r1.ebuild,
+ +gnokii-0.6.14-r2.ebuild:
+ Add -fno-strict-aliasing. Stable on x86.
*gnokii-0.6.14-r1 (27 Dec 2006)
diff --git a/app-mobilephone/gnokii/files/digest-gnokii-0.6.14-r2 b/app-mobilephone/gnokii/files/digest-gnokii-0.6.14-r2
new file mode 100644
index 000000000000..2f801c789991
--- /dev/null
+++ b/app-mobilephone/gnokii/files/digest-gnokii-0.6.14-r2
@@ -0,0 +1,3 @@
+MD5 89449d613c7a7e765a0d8da57ef1bb88 gnokii-0.6.14.tar.bz2 1546845
+RMD160 471689e6ccbb2a81c0eb27a073e27f88ed71e3df gnokii-0.6.14.tar.bz2 1546845
+SHA256 cea63cddf79864d306198c7a84091af0b4685816b352ae253a3e2bfac5e67cb7 gnokii-0.6.14.tar.bz2 1546845
diff --git a/app-mobilephone/gnokii/gnokii-0.6.14-r2.ebuild b/app-mobilephone/gnokii/gnokii-0.6.14-r2.ebuild
new file mode 100644
index 000000000000..5d7c7407c59f
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.14-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.14-r2.ebuild,v 1.1 2007/01/16 20:31:33 mrness Exp $
+
+inherit eutils flag-o-matic linux-info
+
+DESCRIPTION="user space driver and tools for use with mobile phones"
+HOMEPAGE="http://www.gnokii.org/"
+SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="nls bluetooth ical irda sms postgres mysql usb X"
+
+RESTRICT="test" #test fails; maybe it will work in the future, but till then...
+
+RDEPEND="X? ( >=x11-libs/gtk+-2.8.19 )
+ bluetooth? ( >=net-wireless/bluez-libs-2.25 )
+ sms? ( >=dev-libs/glib-2.10.3
+ postgres? ( >=dev-db/postgresql-8.0.8 )
+ mysql? ( >=virtual/mysql-4.1 )
+ )
+ ical? ( >=dev-libs/libical-0.26.6 )
+ usb? ( >=dev-libs/libusb-0.1.11 )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( >=sys-devel/gettext-0.14.5 )
+ >=sys-devel/autoconf-2.59-r7
+ >=app-text/recode-3.6-r2"
+
+CONFIG_CHECK="UNIX98_PTYS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Add proper conditional support for ical and usb USE flags
+ epatch "${FILESDIR}"/${P}-configure.in.patch
+
+ if use sms ; then
+ local MY_SMSD_DB_OBJS="file.lo"
+ local MY_SMSD_DB_LIBS="libfile.la"
+ if use postgres; then
+ MY_SMSD_DB_OBJS="${MY_SMSD_DB_OBJS} pq.lo"
+ MY_SMSD_DB_LIBS="${MY_SMSD_DB_LIBS} libpq.la"
+ fi
+ if use mysql; then
+ MY_SMSD_DB_OBJS="${MY_SMSD_DB_OBJS} mysql.lo"
+ MY_SMSD_DB_LIBS="${MY_SMSD_DB_LIBS} libmysql.la"
+ fi
+
+ sed -i \
+ -e "s/^DB_OBJS.*=.*file[.]lo/DB_OBJS = ${MY_SMSD_DB_OBJS}/" \
+ -e "s/^DB_LIBS.*=.*libfile[.]la/DB_LIBS = ${MY_SMSD_DB_LIBS}/" \
+ -e 's/\(^.*LIBTOOL.*--mode=finish.*$\)/#\1/' \
+ smsd/Makefile
+
+ #Change default database module if pq not supported
+ if ! use postgres ; then
+ local MY_DEFAULT_DB_MODULE="file"
+ if use mysql ; then
+ MY_DEFAULT_DB_MODULE="mysql"
+ fi
+ sed -i -e "s/\"pq\"/\"${MY_DEFAULT_DB_MODULE}\"/" smsd/smsd.c
+ fi
+ fi
+}
+
+src_compile() {
+ find po/ -name '*.po' -exec recode latin1..u8 {} \;
+ append-flags -fno-strict-aliasing
+ append-ldflags $(bindnow-flags) #avoid QA notices
+
+ autoconf && econf \
+ $(use_enable nls) \
+ $(use_enable usb) \
+ $(use_enable ical) \
+ $(use_with X x) \
+ --disable-debug \
+ --disable-xdebug \
+ --disable-rlpdebug \
+ --enable-security \
+ --disable-unix98test \
+ || die "configure failed"
+
+
+ emake -j1 || die "make failed"
+
+ if use sms; then
+ cd "${S}/smsd"
+
+ emake || die "smsd make install failed"
+
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
+
+ doman Docs/man/*
+ dodir "/usr/share/doc/${PF}"
+ cp -r Docs/sample "${D}/usr/share/doc/${PF}/sample"
+ cp -r Docs/protocol "${D}/usr/share/doc/${PF}/protocol"
+ rm -rf Docs/man Docs/sample Docs/protocol
+ dodoc Docs/*
+
+ # only one file needs suid root to make a pseudo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use sms; then
+ cd "${S}/smsd"
+
+ einstall || die "smsd make install failed"
+
+ cd "${S}"
+ fi
+}
+
+pkg_postinst() {
+ einfo "gnokii does not need it's own group anymore."
+ einfo "Make sure the user that runs gnokii has read/write access to the device"
+ einfo "which your phone is connected to. eg. chown <user> /dev/ttyS0"
+ echo
+ ewarn "We received at least one report of gnokii with usb connection breaking the phone,"
+ ewarn "which was in need to be serviced afterwards. Be careful if you decide to try that..."
+}