summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 16:20:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 16:20:39 +0000
commit76625443c8e8aa684edd0a51c974f757b6f85995 (patch)
tree3103b50ecfdd6d0dd31e29047294d9c5dc428a9d /app-mobilephone/gammu/files
parentppc stable #281427 (diff)
downloadgentoo-2-76625443c8e8aa684edd0a51c974f757b6f85995.tar.gz
gentoo-2-76625443c8e8aa684edd0a51c974f757b6f85995.tar.bz2
gentoo-2-76625443c8e8aa684edd0a51c974f757b6f85995.zip
Delete older ebuild.
Diffstat (limited to 'app-mobilephone/gammu/files')
-rw-r--r--app-mobilephone/gammu/files/gammu-1.22.1-assert.patch277
-rw-r--r--app-mobilephone/gammu/files/gammu-1.22.1-skip-locktest.patch12
2 files changed, 0 insertions, 289 deletions
diff --git a/app-mobilephone/gammu/files/gammu-1.22.1-assert.patch b/app-mobilephone/gammu/files/gammu-1.22.1-assert.patch
deleted file mode 100644
index ceb6626428bd..000000000000
--- a/app-mobilephone/gammu/files/gammu-1.22.1-assert.patch
+++ /dev/null
@@ -1,277 +0,0 @@
-diff -Nru gammu-1.22.1.orig/tests/at-parser.c gammu-1.22.1/tests/at-parser.c
---- gammu-1.22.1.orig/tests/at-parser.c 2008-12-10 09:07:19.000000000 +0000
-+++ gammu-1.22.1/tests/at-parser.c 2009-01-17 11:58:44.000000000 +0000
-@@ -4,12 +4,19 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
--#include <assert.h>
- #include "../common/phone/at/atgen.h"
- #include "../common/protocol/protocol.h" /* Needed for GSM_Protocol_Message */
- #include "../common/gsmstate.h" /* Needed for state machine internals */
- #include "../common/gsmphones.h" /* Phone data */
-
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-+
- #define BUFFER_SIZE ((size_t)16384)
-
- int main(int argc UNUSED, char **argv UNUSED)
-diff -Nru gammu-1.22.1.orig/tests/cal-read.c gammu-1.22.1/tests/cal-read.c
---- gammu-1.22.1.orig/tests/cal-read.c 2008-12-10 09:07:19.000000000 +0000
-+++ gammu-1.22.1/tests/cal-read.c 2009-01-17 11:58:56.000000000 +0000
-@@ -11,7 +11,14 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
--#include <assert.h>
-+
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-
- int main(int argc, char **argv)
- {
-diff -Nru gammu-1.22.1.orig/tests/debug.c gammu-1.22.1/tests/debug.c
---- gammu-1.22.1.orig/tests/debug.c 2009-01-17 11:59:46.000000000 +0000
-+++ gammu-1.22.1/tests/debug.c 2009-01-17 11:54:34.000000000 +0000
-@@ -1,17 +1,24 @@
- #include <gammu.h>
- #include <stdlib.h>
- #include <stdio.h>
--#include <assert.h>
-
- GSM_StateMachine *s;
-
- #ifdef WIN32
- # define NUL "NUL"
-+char debug_filename[] = ".\\gammu-debug-test.log";
- #else
- # define NUL "/dev/null"
-+char debug_filename[] = "./gammu-debug-test.log";
- #endif
-
--char debug_filename[] = "gammu-debug-test-XXXXXX";
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-
- NORETURN void fail(int errcode)
- {
-@@ -57,9 +64,6 @@
- int main(int argc UNUSED, char **argv UNUSED)
- {
- FILE *debug_file;
--#ifndef WIN32
-- int debug_fd;
--#endif
- GSM_Debug_Info *di_sm, *di_global;
-
- /* Allocates state machine */
-@@ -69,16 +73,6 @@
- fail(1);
- }
-
--#ifndef WIN32
-- /* Create file for logs */
-- debug_fd = mkstemp(debug_filename);
-- if (debug_fd == -1) {
-- printf("Could not create temporary file!\n");
-- fail(2);
-- }
-- close(debug_fd);
--#endif
--
- /* Get debug handles */
- di_sm = GSM_GetDebug(s);
- di_global = GSM_GetGlobalDebug();
-@@ -95,6 +89,7 @@
- * Test 2 - global /dev/null, local tempfile, do not use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(false, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_global) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_sm) == ERR_NONE);
-@@ -107,6 +102,7 @@
- * Test 3 - global /dev/null, local tempfile, use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(true, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_global) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_sm) == ERR_NONE);
-@@ -119,6 +115,7 @@
- * Test 4 - global tempfile, local /dev/null, use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(true, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_sm) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_global) == ERR_NONE);
-@@ -131,6 +128,7 @@
- * Test 5 - global tempfile, local /dev/null, do not use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(false, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_sm) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_global) == ERR_NONE);
-@@ -142,6 +140,7 @@
- * Test 6 - global /dev/null, local tempfile, do not use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(true, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_global) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_sm) == ERR_NONE);
-@@ -155,6 +154,7 @@
- * Test 7 - global /dev/null, local tempfile, use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(false, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_global) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_sm) == ERR_NONE);
-@@ -168,6 +168,7 @@
- * Test 8 - global tempfile, local /dev/null, use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(false, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_sm) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_global) == ERR_NONE);
-@@ -181,6 +182,7 @@
- * Test 9 - global tempfile, local /dev/null, do not use global
- */
- debug_file = fopen(debug_filename, "w+");
-+ assert(debug_file != NULL);
- assert(GSM_SetDebugGlobal(true, di_sm) == true);
- assert(GSM_SetDebugFile(NUL, di_sm) == ERR_NONE);
- assert(GSM_SetDebugFileDescriptor(debug_file, true, di_global) == ERR_NONE);
-diff -Nru gammu-1.22.1.orig/tests/get-smsc-at.c gammu-1.22.1/tests/get-smsc-at.c
---- gammu-1.22.1.orig/tests/get-smsc-at.c 2008-12-10 09:07:19.000000000 +0000
-+++ gammu-1.22.1/tests/get-smsc-at.c 2009-01-17 11:59:08.000000000 +0000
-@@ -4,13 +4,20 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
--#include <assert.h>
- #include "../common/protocol/protocol.h" /* Needed for GSM_Protocol_Message */
- #include "../common/gsmstate.h" /* Needed for state machine internals */
- #include "../common/gsmphones.h" /* Phone data */
-
- #define BUFFER_SIZE 16384
-
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-+
- extern GSM_Error ATGEN_ReplyGetSMSC(GSM_Protocol_Message msg, GSM_StateMachine *s);
-
- int main(int argc, char **argv)
-diff -Nru gammu-1.22.1.orig/tests/locking.c gammu-1.22.1/tests/locking.c
---- gammu-1.22.1.orig/tests/locking.c 2008-11-13 08:50:32.000000000 +0000
-+++ gammu-1.22.1/tests/locking.c 2009-01-17 11:58:09.000000000 +0000
-@@ -1,7 +1,14 @@
- #include <gammu.h>
- #include <stdlib.h>
- #include <stdio.h>
--#include <assert.h>
-+
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-
-
- extern GSM_Error lock_device (const char* port, char **lock_device);
-diff -Nru gammu-1.22.1.orig/tests/sms-nokia-05.c gammu-1.22.1/tests/sms-nokia-05.c
---- gammu-1.22.1.orig/tests/sms-nokia-05.c 2008-11-13 08:50:32.000000000 +0000
-+++ gammu-1.22.1/tests/sms-nokia-05.c 2009-01-17 11:57:51.000000000 +0000
-@@ -3,12 +3,19 @@
- #include <gammu.h>
- #include <stdlib.h>
- #include <stdio.h>
--#include <assert.h>
- #include "../common/protocol/protocol.h" /* Needed for GSM_Protocol_Message */
- #include "../common/gsmstate.h" /* Needed for state machine internals */
-
- #include "sms-printing.h"
-
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-+
- unsigned char data[] = {
- 0x00, 0x02, 0x00, 0x01, 0x00, 0x00, 0x00, 0x9F, 0x00, 0x00, 0x02, 0x51, 0x00, 0x00, 0x00, 0x00,
- 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
-diff -Nru gammu-1.22.1.orig/tests/statemachine-init.c gammu-1.22.1/tests/statemachine-init.c
---- gammu-1.22.1.orig/tests/statemachine-init.c 2008-11-13 08:50:32.000000000 +0000
-+++ gammu-1.22.1/tests/statemachine-init.c 2009-01-17 11:58:22.000000000 +0000
-@@ -1,7 +1,6 @@
- #include <gammu.h>
- #include <stdlib.h>
- #include <stdio.h>
--#include <assert.h>
-
- #ifdef WIN32
- # define NUL "NUL"
-@@ -9,6 +8,14 @@
- # define NUL "/dev/null"
- #endif
-
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-+
- GSM_StateMachine *s;
-
- void single_check(const char *device, const char *connection, const char *model, GSM_Error expected)
-diff -Nru gammu-1.22.1.orig/tests/vcard-read.c gammu-1.22.1/tests/vcard-read.c
---- gammu-1.22.1.orig/tests/vcard-read.c 2008-12-12 09:34:12.000000000 +0000
-+++ gammu-1.22.1/tests/vcard-read.c 2009-01-17 11:59:21.000000000 +0000
-@@ -11,7 +11,14 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
--#include <assert.h>
-+
-+#define assert(val) \
-+{ \
-+ if (!(val)) {\
-+ fprintf(stderr, "Test \"%s\" failed!\n", ""#val); \
-+ exit(2); \
-+ } \
-+}
-
- int main(int argc, char **argv)
- {
diff --git a/app-mobilephone/gammu/files/gammu-1.22.1-skip-locktest.patch b/app-mobilephone/gammu/files/gammu-1.22.1-skip-locktest.patch
deleted file mode 100644
index 157dd17c4d75..000000000000
--- a/app-mobilephone/gammu/files/gammu-1.22.1-skip-locktest.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nru gammu-1.22.1.orig/tests/CMakeLists.txt gammu-1.22.1/tests/CMakeLists.txt
---- gammu-1.22.1.orig/tests/CMakeLists.txt 2008-12-10 09:05:02.000000000 +0000
-+++ gammu-1.22.1/tests/CMakeLists.txt 2009-01-17 12:26:47.000000000 +0000
-@@ -424,7 +424,7 @@
-
- # Test for locking, only on !WIN32 and if we can write to lock dir
- if (NOT WIN32)
-- execute_process(COMMAND test -w /var/lock/ RESULT_VARIABLE VAR_LOCK_WRITABLE)
-+ set (VAR_LOCK_WRITABLE 1)
- if (VAR_LOCK_WRITABLE EQUAL 0)
- add_executable(locking locking.c)
- target_link_libraries(locking libGammu)