summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-12-28 04:13:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-12-28 04:13:26 +0000
commitfb6b9b4094fc54d3af260f684c9feba11e43f7dc (patch)
tree55c173075c7db871717990482fd9b53414650e15 /app-misc
parentReintroduce texinfo patch to unbreak older versions (bug #496224). (diff)
downloadgentoo-2-fb6b9b4094fc54d3af260f684c9feba11e43f7dc.tar.gz
gentoo-2-fb6b9b4094fc54d3af260f684c9feba11e43f7dc.tar.bz2
gentoo-2-fb6b9b4094fc54d3af260f684c9feba11e43f7dc.zip
Bug #401473: bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/dnetc/ChangeLog11
-rw-r--r--app-misc/dnetc/dnetc-2.9110.519.ebuild94
-rw-r--r--app-misc/dnetc/dnetc-2.9110.519b.ebuild96
3 files changed, 199 insertions, 2 deletions
diff --git a/app-misc/dnetc/ChangeLog b/app-misc/dnetc/ChangeLog
index 60f24686b191..7d75a9c094ec 100644
--- a/app-misc/dnetc/ChangeLog
+++ b/app-misc/dnetc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/dnetc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.66 2012/06/01 01:55:14 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.67 2013/12/28 04:13:26 robbat2 Exp $
+
+*dnetc-2.9110.519 (28 Dec 2013)
+*dnetc-2.9110.519b (28 Dec 2013)
+
+ 28 Dec 2013; Robin H. Johnson <robbat2@gentoo.org> +dnetc-2.9110.519.ebuild,
+ +dnetc-2.9110.519b.ebuild:
+ Bug #401473: bump.
01 Jun 2012; Zac Medico <zmedico@gentoo.org> dnetc-2.9011.496-r1.ebuild,
dnetc-2.9015.504.ebuild, dnetc-2.9103.509.ebuild, dnetc-2.9107.516.ebuild,
diff --git a/app-misc/dnetc/dnetc-2.9110.519.ebuild b/app-misc/dnetc/dnetc-2.9110.519.ebuild
new file mode 100644
index 000000000000..f9e9695b2d20
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9110.519.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9110.519.ebuild,v 1.1 2013/12/28 04:13:26 robbat2 Exp $
+
+EAPI=2
+inherit user
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
+#SRC_URI_amd64="amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64.tar.gz )"
+#SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
+#SRC_URI_sparc="sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc-v7.tar.gz )"
+SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc} ${SRC_URI_x86} ${SRC_URI_sparc}"
+
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~x86" # ppc,amd64 not available for this version
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="net-dns/bind-tools"
+
+QA_PRESTRIPPED="opt/distributed.net/dnetc"
+
+S=${WORKDIR}/dnetc
+
+src_prepare() {
+ binname=""
+ if use amd64; then
+ binname=dnetc${MIN_PV}-linux-amd64
+ elif use x86; then
+ binname=dnetc${MIN_PV}-linux-x86-elf-uclibc
+ elif use ppc; then
+ binname=dnetc${MIN_PV}-linux-ppc-elf-uclibc
+ fi
+ [[ -z "${binname}" ]] && die "Name of dnetc binary for this platform undefined"
+ mv "${binname}" dnetc || die "$binname binary is missing"
+}
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd "${FILESDIR}"/dnetc.initd dnetc
+ newconfd "${FILESDIR}"/dnetc.confd dnetc
+
+ keepdir /var/spool/dnetc
+}
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ source /etc/conf.d/dnetc
+
+ if [ -e /opt/distributed.net/dnetc.ini ]; then
+ # use ini file
+ /opt/distributed.net/dnetc -quiet -ini /opt/distributed.net/dnetc.ini -flush
+ elif [ ! -e /opt/distributed.net/dnetc.ini ] && [ ! -z ${EMAIL} ]; then
+ # email adress from config
+ /opt/distributed.net/dnetc -quiet -flush -e ${EMAIL}
+ fi
+
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+
+ enewgroup dnetc
+ enewuser dnetc -1 -1 /opt/distributed.net dnetc
+}
+
+pkg_postinst() {
+ chown -Rf dnetc:dnetc /opt/distributed.net
+ chmod 0555 /opt/distributed.net/dnetc
+
+ elog "To run distributed.net client in the background at boot:"
+ elog " rc-update add dnetc default"
+ elog ""
+ elog "Either configure your email address in /etc/conf.d/dnetc"
+ elog "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ elog "All files has not been removed from /opt/distributed.net"
+ fi
+}
diff --git a/app-misc/dnetc/dnetc-2.9110.519b.ebuild b/app-misc/dnetc/dnetc-2.9110.519b.ebuild
new file mode 100644
index 000000000000..3b6639b329ec
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9110.519b.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9110.519b.ebuild,v 1.1 2013/12/28 04:13:26 robbat2 Exp $
+
+EAPI=2
+inherit user
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+#SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
+SRC_URI_amd64="amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64.tar.gz )"
+#SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
+#SRC_URI_sparc="sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc-v7.tar.gz )"
+SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc} ${SRC_URI_x86} ${SRC_URI_sparc}"
+
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~amd64" # ppc,x86 not available for this version
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="net-dns/bind-tools"
+
+QA_PREBUILT="opt/distributed.net/dnetc"
+
+getS() {
+ case $ARCH in
+ amd64) suffix=amd64 ;;
+ x86) suffix=x86-elf-uclibc ;;
+ ppc) suffix=ppc-elf-uclibc ;;
+ esac
+ echo dnetc${MIN_PV:0:3}-linux-${suffix}
+}
+
+src_prepare() {
+ export S="${WORKDIR}/$(getS)"
+ cd "${S}"
+ [[ -x dnetc ]] || die "Name of dnetc directory/binary for this platform undefined"
+}
+
+src_install() {
+ export S="${WORKDIR}/$(getS)"
+ cd "${S}"
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd "${FILESDIR}"/dnetc.initd dnetc
+ newconfd "${FILESDIR}"/dnetc.confd dnetc
+
+ keepdir /var/spool/dnetc
+}
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ source /etc/conf.d/dnetc
+
+ if [ -e /opt/distributed.net/dnetc.ini ]; then
+ # use ini file
+ /opt/distributed.net/dnetc -quiet -ini /opt/distributed.net/dnetc.ini -flush
+ elif [ ! -e /opt/distributed.net/dnetc.ini ] && [ ! -z ${EMAIL} ]; then
+ # email adress from config
+ /opt/distributed.net/dnetc -quiet -flush -e ${EMAIL}
+ fi
+
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+
+ enewgroup dnetc
+ enewuser dnetc -1 -1 /opt/distributed.net dnetc
+}
+
+pkg_postinst() {
+ chown -Rf dnetc:dnetc /opt/distributed.net
+ chmod 0555 /opt/distributed.net/dnetc
+
+ elog "To run distributed.net client in the background at boot:"
+ elog " rc-update add dnetc default"
+ elog ""
+ elog "Either configure your email address in /etc/conf.d/dnetc"
+ elog "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ elog "All files has not been removed from /opt/distributed.net"
+ fi
+}