summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-20 15:26:37 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-20 15:26:37 +0000
commitf10a05b896105f12cd44092e1e9738b546f192b5 (patch)
treea06cf719e049e0203462c3077741556989dc6169 /app-misc
parentVersion bump (diff)
downloadgentoo-2-f10a05b896105f12cd44092e1e9738b546f192b5.tar.gz
gentoo-2-f10a05b896105f12cd44092e1e9738b546f192b5.tar.bz2
gentoo-2-f10a05b896105f12cd44092e1e9738b546f192b5.zip
Version bump (bug 416689, thanks Hans de Graaff for the notice)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/specto/ChangeLog10
-rw-r--r--app-misc/specto/files/specto-0.4.1-icon-theme.patch30
-rw-r--r--app-misc/specto/specto-0.4.1.ebuild43
3 files changed, 81 insertions, 2 deletions
diff --git a/app-misc/specto/ChangeLog b/app-misc/specto/ChangeLog
index 2de7ad3c08bb..8db50823ffea 100644
--- a/app-misc/specto/ChangeLog
+++ b/app-misc/specto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/specto
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/ChangeLog,v 1.6 2011/01/12 14:23:24 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/ChangeLog,v 1.7 2012/05/20 15:26:37 xmw Exp $
+
+*specto-0.4.1 (20 May 2012)
+
+ 20 May 2012; Michael Weber <xmw@gentoo.org> +specto-0.4.1.ebuild,
+ +files/specto-0.4.1-icon-theme.patch:
+ Version bump (bug 416689, thanks Hans de Graaff for the notice)
12 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
specto-0.3.1.ebuild:
diff --git a/app-misc/specto/files/specto-0.4.1-icon-theme.patch b/app-misc/specto/files/specto-0.4.1-icon-theme.patch
new file mode 100644
index 000000000000..60870deba203
--- /dev/null
+++ b/app-misc/specto/files/specto-0.4.1-icon-theme.patch
@@ -0,0 +1,30 @@
+Replace some GNOME icons with their FreeDesktop equivalents
+so that it works with oxygen as a theme.
+
+--- specto-0.4.1/spectlib/notifier.py
++++ specto-0.4.1/spectlib/notifier.py
+@@ -213,11 +213,11 @@
+ """ show the right icon for the status from the watch. """
+ watch = self.specto.watch_db[id]
+ statusbar = self.builder.get_object("statusbar1")
+- icon = self.get_icon("error", 50, False)
++ icon = self.get_icon("dialog-error", 50, False)
+
+ try:
+ if status == "checking":
+- icon = self.get_icon("reload", 0, False)
++ icon = self.get_icon("view-refresh", 0, False)
+ statusbar.push(0, (datetime.today().strftime("%H:%M") + " - " + _('The watch "%s" is checking.') % watch.name))
+
+ elif status == "idle":
+@@ -242,8 +242,8 @@
+
+ elif status == "error":
+ statusbar.push(0, (datetime.today().strftime("%H:%M") + " - " + _('The watch "%s" has a problem.') % watch.name))
+- balloon_icon = self.get_icon("error", 0, True)
+- icon = self.get_icon("error", 50, False)
++ balloon_icon = self.get_icon("dialog-error", 0, True)
++ icon = self.get_icon("dialog-error", 50, False)
+ if self.specto.specto_gconf.get_entry("pop_toast") == True:
+ body = watch.escape(watch.error_message)
+ self.balloon.show_toast(body, balloon_icon, urgency="critical", summary=(_("%s encountered a problem") % watch.name))
diff --git a/app-misc/specto/specto-0.4.1.ebuild b/app-misc/specto/specto-0.4.1.ebuild
new file mode 100644
index 000000000000..e3ab19b855b9
--- /dev/null
+++ b/app-misc/specto/specto-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/specto/specto-0.4.1.ebuild,v 1.1 2012/05/20 15:26:37 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_MODNAME="spectlib"
+
+inherit distutils eutils
+
+DESCRIPTION="watch configurable events and trigger notifications"
+HOMEPAGE="http://specto.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_it
+ linguas_pt_BR linguas_ro linguas_sv linguas_tr"
+
+RDEPEND="dev-python/gconf-python
+ dev-python/dbus-python
+ dev-python/libgnome-python
+ dev-python/notify-python
+ >=dev-python/pygtk-2.10"
+DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-icon-theme.patch
+
+ sed -e "s:share/doc/specto:share/doc/${PF}:" \
+ -i setup.py spectlib/util.py || die
+
+ if [ -n "${LINGUAS}" ] ; then
+ sed -e "/^i18n_languages = /s: = .*: = \"${LINGUAS}\":" \
+ -i setup.py || die
+ fi
+}