summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-09-07 02:28:03 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-09-07 02:28:03 +0000
commit6c37cf2579296864d520553e36a9ff114866761f (patch)
treed94e284a3aad92dbe9209063b39183fbcc30e325 /app-misc
parentWorks on amd64. (diff)
downloadgentoo-2-6c37cf2579296864d520553e36a9ff114866761f.tar.gz
gentoo-2-6c37cf2579296864d520553e36a9ff114866761f.tar.bz2
gentoo-2-6c37cf2579296864d520553e36a9ff114866761f.zip
version bump from upstream
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tracker/ChangeLog8
-rw-r--r--app-misc/tracker/files/digest-tracker-0.6.23
-rw-r--r--app-misc/tracker/tracker-0.6.2.ebuild127
3 files changed, 137 insertions, 1 deletions
diff --git a/app-misc/tracker/ChangeLog b/app-misc/tracker/ChangeLog
index 170794edf951..3a98552edd58 100644
--- a/app-misc/tracker/ChangeLog
+++ b/app-misc/tracker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tracker
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/ChangeLog,v 1.20 2007/08/11 20:30:05 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/ChangeLog,v 1.21 2007/09/07 02:28:02 compnerd Exp $
+
+*tracker-0.6.2 (07 Sep 2007)
+
+ 07 Sep 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +tracker-0.6.2.ebuild:
+ Version bump from upstream
*tracker-0.6.1 (11 Aug 2007)
diff --git a/app-misc/tracker/files/digest-tracker-0.6.2 b/app-misc/tracker/files/digest-tracker-0.6.2
new file mode 100644
index 000000000000..4c5323c2b8c5
--- /dev/null
+++ b/app-misc/tracker/files/digest-tracker-0.6.2
@@ -0,0 +1,3 @@
+MD5 288e355a20514e8b3de9fe83cb4d4f4c tracker-0.6.2.tar.gz 1044791
+RMD160 99d5f502b50942afa88240dd3f2aa9f60876732e tracker-0.6.2.tar.gz 1044791
+SHA256 a0523caa982b208a94727404adcb22238b1a291ca0cfdd33b58fcd4ec2ab8d02 tracker-0.6.2.tar.gz 1044791
diff --git a/app-misc/tracker/tracker-0.6.2.ebuild b/app-misc/tracker/tracker-0.6.2.ebuild
new file mode 100644
index 000000000000..ab1d94957e1e
--- /dev/null
+++ b/app-misc/tracker/tracker-0.6.2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.6.2.ebuild,v 1.1 2007/09/07 02:28:02 compnerd Exp $
+
+inherit autotools eutils flag-o-matic linux-info
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="http://www.tracker-project.org/"
+SRC_URI="http://www.gnome.org/~jamiemcc/tracker/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="applet debug gnome gsf gstreamer gtk jpeg pdf xine kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.12.0
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/gmime-2.1.0
+ >=media-gfx/imagemagick-5.2.1
+ >=dev-libs/dbus-glib-0.71
+ >=dev-db/sqlite-3.4
+ >=media-libs/libpng-1.2
+ >=dev-libs/libxml2-2.6
+ sys-libs/zlib
+ applet? ( gnome-extra/deskbar-applet )
+ gnome? (
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/gnome-vfs-2.10
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.14
+ )
+ gsf? ( >=gnome-extra/libgsf-1.13 )
+ gstreamer? ( >=media-libs/gstreamer-0.10 )
+ gtk? ( >=x11-libs/gtk+-2.8.20 )
+ jpeg? ( >=media-gfx/exif-0.6 )
+ xine? ( >=media-libs/xine-lib-1.0 )
+ !gstreamer? ( !xine? ( || ( media-video/totem media-video/mplayer ) ) )
+ !kernel_linux? ( >=app-admin/gamin-0.1.7 )
+ pdf? (
+ >=x11-libs/cairo-1.0
+ >=app-text/poppler-bindings-0.5.0
+ )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.14
+ >=dev-util/pkgconfig-0.20"
+
+function notify_inotify() {
+ ewarn
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify file change notification support' under the"
+ ewarn "'File systems' option. It is marked as CONFIG_INOTIFY in the config"
+ ewarn "Also enable 'Inotify support for userland' in under the previous"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config."
+ ewarn
+ die 'missing CONFIG_INOTIFY'
+}
+
+function inotify_enabled() {
+ linux_chkconfig_present INOTIFY && linux_chkconfig_present INOTIFY_USER
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if built_with_use 'dev-db/sqlite' 'nothreadsafe' ; then
+ eerror "You must build sqlite with threading support"
+ die "dev-db/sqlite built with nothreadsafe"
+ fi
+
+ if ! built_with_use 'app-text/poppler-bindings' 'gtk' ; then
+ ewarn "You must build poppler-bindings with gtk to get support for PDFs"
+ die "poppler-bindings needs gtk support"
+ fi
+
+ if ! built_with_use 'media-gfx/imagemagick' 'png' ; then
+ ewarn "You must build imagemagick with png"
+ die "imagemagick needs png support"
+ fi
+
+ if use jpeg && ! built_with_use 'media-gfx/imagemagick' 'jpeg' ; then
+ ewarn "You must build imagemagick with jpeg to get support for JPEG"
+ die "imagemagick needs jpeg support"
+ fi
+
+ if use kernel_linux ; then
+ inotify_enabled || notify_inotify
+ fi
+}
+
+src_compile() {
+ local myconf=
+
+ if use gstreamer ; then
+ myconf="${myconf} --enable-video-extractor=gstreamer"
+ elif use xine ; then
+ myconf="${myconf} --enable-video-extractor=xine"
+ else
+ myconf="${myconf} --enable-video-extractor=external"
+ fi
+
+ if use kernel_linux ; then
+ myconf="${myconf} --enable-file-monitoring=inotify"
+ else
+ myconf="${myconf} --enable-file-monitoring=fam"
+ fi
+
+ econf ${myconf} \
+ --enable-preferences --disable-xmp --disable-unac \
+ $(use_enable applet deskbar-applet) \
+ $(use_enable debug debug-code) \
+ $(use_enable gnome gui) \
+ $(use_enable gsf) \
+ $(use_enable gtk libtrackergtk) \
+ $(use_enable jpeg exif) \
+ $(use_enable pdf) \
+ || die "configure failed"
+
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}