summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-13 13:04:06 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-13 13:04:06 +0000
commit9624dd3423ef0b3fbfcfe4e94447bf9d39669ea2 (patch)
tree922e892ab6161cb32799edaa2a765197d9531817 /app-misc/wcd
parentStable for amd64, wrt bug #407557 (diff)
downloadgentoo-2-9624dd3423ef0b3fbfcfe4e94447bf9d39669ea2.tar.gz
gentoo-2-9624dd3423ef0b3fbfcfe4e94447bf9d39669ea2.tar.bz2
gentoo-2-9624dd3423ef0b3fbfcfe4e94447bf9d39669ea2.zip
Version Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/wcd')
-rw-r--r--app-misc/wcd/ChangeLog10
-rw-r--r--app-misc/wcd/files/wcd-5.2.1-gentoo.patch60
-rw-r--r--app-misc/wcd/wcd-5.1.4.ebuild10
-rw-r--r--app-misc/wcd/wcd-5.2.1.ebuild32
4 files changed, 104 insertions, 8 deletions
diff --git a/app-misc/wcd/ChangeLog b/app-misc/wcd/ChangeLog
index d67206063a7f..bd69e56ae348 100644
--- a/app-misc/wcd/ChangeLog
+++ b/app-misc/wcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/wcd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/ChangeLog,v 1.3 2011/11/02 10:06:59 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/ChangeLog,v 1.4 2012/03/13 13:04:06 jlec Exp $
+
+*wcd-5.2.1 (13 Mar 2012)
+
+ 13 Mar 2012; Justin Lecher <jlec@gentoo.org> wcd-5.1.4.ebuild,
+ +wcd-5.2.1.ebuild, +files/wcd-5.2.1-gentoo.patch:
+ Version Bump
02 Nov 2011; Justin Lecher <jlec@gentoo.org> wcd-5.1.4.ebuild, metadata.xml:
Added missing build dep, #389227
diff --git a/app-misc/wcd/files/wcd-5.2.1-gentoo.patch b/app-misc/wcd/files/wcd-5.2.1-gentoo.patch
new file mode 100644
index 000000000000..67794bc3d0c4
--- /dev/null
+++ b/app-misc/wcd/files/wcd-5.2.1-gentoo.patch
@@ -0,0 +1,60 @@
+ src/Makefile | 13 +++++++------
+ 1 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 9a37e3b..7aac6eb 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -46,14 +46,14 @@ endif
+
+ include version.mk
+
+-CC = gcc
++CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -310,7 +310,7 @@ endif
+ # dynamically) comment the LDFLAGS line and add the 'libncurses.a' file
+ # (often found as /usr/lib/libncurses.a) to the OBJS1 list.
+
+-CFLAGS = -O2 -Wall -Wextra -Wno-unused-parameter -Wconversion $(RPM_OPT_FLAGS)
++CFLAGS += -Wall
+
+ EXTRA_CFLAGS = -Ic3po \
+ $(CFLAGS_VERSION) \
+@@ -337,7 +337,7 @@ ifdef ASCII_TREE
+ EXTRA_CFLAGS += -DASCII_TREE
+ endif
+
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LIB_CURSES) \
+ $(LIB_UNISTRING) \
+ $(LDFLAGS_EXTRA) \
+@@ -387,6 +387,7 @@ status:
+ @echo "DEFS = $(DEFS)"
+ @echo "DEFS_CURSES = $(DEFS_CURSES)"
+ @echo "EXTRA_DEFS = $(EXTRA_DEFS)"
++ @echo "LIBS = $(LIBS)"
+ @echo "LDFLAGS = $(LDFLAGS)"
+ @echo "LDFLAGS_EXTRA = $(LDFLAGS_EXTRA)"
+ @echo "CFLAGS = $(CFLAGS)"
+@@ -396,7 +397,7 @@ status:
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) -o $@
++ $(CC) $(OBJS1) $(LDFLAGS) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@
diff --git a/app-misc/wcd/wcd-5.1.4.ebuild b/app-misc/wcd/wcd-5.1.4.ebuild
index 308ce1964dce..84d440528a39 100644
--- a/app-misc/wcd/wcd-5.1.4.ebuild
+++ b/app-misc/wcd/wcd-5.1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/wcd-5.1.4.ebuild,v 1.2 2011/11/02 10:06:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/wcd-5.1.4.ebuild,v 1.3 2012/03/13 13:04:06 jlec Exp $
-EAPI="4"
+EAPI=4
inherit eutils toolchain-funcs
@@ -16,7 +16,6 @@ LICENSE="GPL-2"
IUSE="ncurses nls unicode"
DEPEND="app-text/ghostscript-gpl"
-RDEPEND=""
src_prepare() {
epatch "${FILESDIR}"/${PV}-gentoo.patch
@@ -29,6 +28,5 @@ src_compile() {
use ncurses || mycompile="${mycompile} CURSES="
use unicode && mycompile="${mycompile} UCS=1"
emake \
- ${mycompile} \
- || die
+ ${mycompile}
}
diff --git a/app-misc/wcd/wcd-5.2.1.ebuild b/app-misc/wcd/wcd-5.2.1.ebuild
new file mode 100644
index 000000000000..1b91d2548cc1
--- /dev/null
+++ b/app-misc/wcd/wcd-5.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wcd/wcd-5.2.1.ebuild,v 1.1 2012/03/13 13:04:06 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/#WCD_ANCHOR"
+SRC_URI="http://www.xs4all.nl/~waterlan/${P}-src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="ncurses nls unicode"
+
+DEPEND="app-text/ghostscript-gpl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ local mycompile
+ use nls || mycompile="${mycompile} ENABLE_NLS="
+ use ncurses || mycompile="${mycompile} CURSES="
+ use unicode && mycompile="${mycompile} UCS=1"
+ emake \
+ ${mycompile}
+}