summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-02-21 13:02:53 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-02-21 13:02:53 +0000
commitfa276cb956f6d2c68e3f2f9736cb74050cf9daec (patch)
treebf9b4ebbceda1de4a06c0bbf853751eab68f031f /app-misc/tasque
parentVersion bump (diff)
downloadgentoo-2-fa276cb956f6d2c68e3f2f9736cb74050cf9daec.tar.gz
gentoo-2-fa276cb956f6d2c68e3f2f9736cb74050cf9daec.tar.bz2
gentoo-2-fa276cb956f6d2c68e3f2f9736cb74050cf9daec.zip
Version bump to Tasque 0.1.9
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'app-misc/tasque')
-rw-r--r--app-misc/tasque/ChangeLog9
-rw-r--r--app-misc/tasque/tasque-0.1.9.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/app-misc/tasque/ChangeLog b/app-misc/tasque/ChangeLog
index f02ca65cf165..50ec178331a9 100644
--- a/app-misc/tasque/ChangeLog
+++ b/app-misc/tasque/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tasque
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.2 2009/02/11 20:43:36 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/ChangeLog,v 1.3 2010/02/21 13:02:53 suka Exp $
+
+*tasque-0.1.9 (21 Feb 2010)
+
+ 21 Feb 2010; Andreas Proschofsky <suka@gentoo.org> +tasque-0.1.9.ebuild:
+ Version bump to Tasque 0.1.9
11 Feb 2009; Peter Alfredsen <loki_val@gentoo.org> tasque-0.1.8.ebuild:
Use portable cp -pPR instead of cp -a
diff --git a/app-misc/tasque/tasque-0.1.9.ebuild b/app-misc/tasque/tasque-0.1.9.ebuild
new file mode 100644
index 000000000000..aa48ad72f7bd
--- /dev/null
+++ b/app-misc/tasque/tasque-0.1.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tasque/tasque-0.1.9.ebuild,v 1.1 2010/02/21 13:02:53 suka Exp $
+
+EAPI=2
+
+inherit gnome.org mono
+
+DESCRIPTION="Tasky is a simple task management app (TODO list) for the Linux Desktop"
+HOMEPAGE="http://live.gnome.org/Tasque"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+rememberthemilk eds +sqlite hiveminder debug"
+
+RDEPEND=">=dev-dotnet/gtk-sharp-2.12.7-r5
+ >=dev-dotnet/gnome-sharp-2.24.0
+ >=dev-dotnet/notify-sharp-0.4.0_pre20080912
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-glib-sharp-0.4
+ eds? ( >=dev-dotnet/evolution-sharp-0.18.1 )
+ sqlite? ( dev-db/sqlite:3 )
+ "
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ BACKEND=false
+ for usef in eds sqlite hiveminder rememberthemilk
+ do
+ use $usef && BACKEND=true
+ done
+ if [[ "${BACKEND}" != "true" ]]
+ then
+ eerror "You must select one of the following backends by enabling their useflag:"
+ eerror "eds ( integrates with the evolution schedule )"
+ eerror "sqlite ( uses a local, file-backed database to keep track of your TODO list )"
+ eerror "rememberthemilk ( integrates with www.rememberthemilk.com )"
+ eerror "hiveminder ( integrates with www.hiveminder.com )"
+ die "Please select a backend"
+ fi
+}
+
+src_configure() {
+ #http://bugzilla.gnome.org/show_bug.cgi?id=568910
+ export GTK_DOTNET_20_LIBS=" " \
+ GTK_DOTNET_20_CFLAGS=" "
+ econf --disable-backend-icecore \
+ --enable-backend-rtm \
+ $(use_enable sqlite backend-sqlite) \
+ $(use_enable eds backend-eds) \
+ $(use_enable hiveminder backend-hiveminder) \
+ $(use_enable debug)
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake failed"
+ dodoc NEWS TODO README AUTHORS || die "docs installation failed"
+ mv_command="cp -pPR" mono_multilib_comply
+}