summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-19 10:03:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-19 10:03:37 +0000
commit077999b66b92805d61e002a379924f952b09b6c4 (patch)
tree1f614130b295b901481bd144664cad271f303806 /app-misc/srm/srm-1.2.7.ebuild
parentinitial commit (bug 38348) (diff)
downloadgentoo-2-077999b66b92805d61e002a379924f952b09b6c4.tar.gz
gentoo-2-077999b66b92805d61e002a379924f952b09b6c4.tar.bz2
gentoo-2-077999b66b92805d61e002a379924f952b09b6c4.zip
initial commit (bug 38348)
Diffstat (limited to 'app-misc/srm/srm-1.2.7.ebuild')
-rw-r--r--app-misc/srm/srm-1.2.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/srm/srm-1.2.7.ebuild b/app-misc/srm/srm-1.2.7.ebuild
new file mode 100644
index 000000000000..10c1cb45a7b7
--- /dev/null
+++ b/app-misc/srm/srm-1.2.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/srm/srm-1.2.7.ebuild,v 1.1 2004/01/19 10:03:31 mr_bones_ Exp $
+
+DESCRIPTION="A command-line compatible rm which destroys file contents before unlinking."
+HOMEPAGE="http://sourceforge.net/projects/srm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="X11"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README Changes || die "dodoc failed"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Please notice that srm will not work as expected with any"
+ ewarn "journaled file system (e.g. reiserfs, ext3)."
+ ewarn "Please read /usr/share/doc/${P}/README.gz"
+ echo
+}