summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 11:33:11 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 11:33:11 +0000
commitc159c250b75512ebdc60d0010b29b8814d8f5f47 (patch)
treecf8eeb9643894aca2850e51a54259dcb4ab3dfe4 /app-misc/ondir/ondir-0.2.2-r1.ebuild
parentimported prefix changes (diff)
downloadgentoo-2-c159c250b75512ebdc60d0010b29b8814d8f5f47.tar.gz
gentoo-2-c159c250b75512ebdc60d0010b29b8814d8f5f47.tar.bz2
gentoo-2-c159c250b75512ebdc60d0010b29b8814d8f5f47.zip
QA, imported prefix changes
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/ondir/ondir-0.2.2-r1.ebuild')
-rw-r--r--app-misc/ondir/ondir-0.2.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/ondir/ondir-0.2.2-r1.ebuild b/app-misc/ondir/ondir-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..da1c0be0d363
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ondir/ondir-0.2.2-r1.ebuild,v 1.1 2010/06/15 11:33:11 jlec Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="program that automatically executes scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+
+src_prepare() {
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" CONF="${EPREFIX}/etc/ondirrc" install || die
+ dodoc AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh || die
+ newdoc ondirrc.eg ondirrc.example || die
+ dohtml changelog.html ondir.1.html || die
+}