summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-01-22 20:14:08 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-01-22 20:14:08 +0000
commitcd0c69234b0c441ee221b07411c0dcc5b44b3dcc (patch)
tree95779468df5b48bec82f32ace9893f1fad35fd02 /app-misc/mc
parentfixed emerge-webrsync (diff)
downloadgentoo-2-cd0c69234b0c441ee221b07411c0dcc5b44b3dcc.tar.gz
gentoo-2-cd0c69234b0c441ee221b07411c0dcc5b44b3dcc.tar.bz2
gentoo-2-cd0c69234b0c441ee221b07411c0dcc5b44b3dcc.zip
version bump with man2help fix from upstream
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog9
-rw-r--r--app-misc/mc/files/digest-mc-4.6.0_pre31
-rw-r--r--app-misc/mc/mc-4.6.0_pre3.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 32af470e2812..e38d69c1477a 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/mc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.4 2002/12/27 03:12:47 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.5 2003/01/22 20:14:08 bcowan Exp $
+
+*mc-4.6.0_pre3 (22 Jan 2003)
+
+ 22 Jan 2003; Brad Cowan <bcowan@gentoo.org> mc-4.6.0_pre3.ebuild,
+ files/digest-mc-4.6.0_pre3:
+ Version bump with many bugfixes, hopefully upstream fixed the man2hlp bug for
+ good.
*mc-4.6.0_pre2 (26 Dec 2002)
diff --git a/app-misc/mc/files/digest-mc-4.6.0_pre3 b/app-misc/mc/files/digest-mc-4.6.0_pre3
new file mode 100644
index 000000000000..c17704215617
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.0_pre3
@@ -0,0 +1 @@
+MD5 dc3eb823f286b3aca7fbcf5614babfe7 mc-4.6.0-pre3.tar.gz 3710736
diff --git a/app-misc/mc/mc-4.6.0_pre3.ebuild b/app-misc/mc/mc-4.6.0_pre3.ebuild
new file mode 100644
index 000000000000..0af06fc2e6d7
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0_pre3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0_pre3.ebuild,v 1.1 2003/01/22 20:14:08 bcowan Exp $
+
+IUSE="gpm nls samba ncurses X slang"
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${MY_P}.tar.gz"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf=""
+
+ if ! use slang && ! use ncurses
+ then
+ myconf="${myconf} --with-screen=mcslang"
+ elif
+ use ncurses && ! use slang
+ then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse" \
+ || myconf="${myconf} --without-gpm-mouse"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ dodoc ABOUT-NLS COPYING* ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+}
+