summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-05-08 10:34:53 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-05-08 10:34:53 +0000
commit74812912c5597ed64bb2336b3ef0aecfde310c74 (patch)
tree9ad70426d9a48232a09b6b8305c42e62e6ebd210 /app-misc/mc/mc-4.6.0-r7.ebuild
parentFixed BUG #49583 (Manifest recommit) (diff)
downloadgentoo-2-74812912c5597ed64bb2336b3ef0aecfde310c74.tar.gz
gentoo-2-74812912c5597ed64bb2336b3ef0aecfde310c74.tar.bz2
gentoo-2-74812912c5597ed64bb2336b3ef0aecfde310c74.zip
security update, bug #49990
Diffstat (limited to 'app-misc/mc/mc-4.6.0-r7.ebuild')
-rw-r--r--app-misc/mc/mc-4.6.0-r7.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/app-misc/mc/mc-4.6.0-r7.ebuild b/app-misc/mc/mc-4.6.0-r7.ebuild
new file mode 100644
index 000000000000..c405d1452317
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0-r7.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r7.ebuild,v 1.1 2004/05/08 10:34:53 lanius Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz
+ http://www.spock.mga.com.pl/public/gentoo/${P}-sambalib-3.0.0.patch.bz2
+ http://www.spock.mga.com.pl/public/gentoo/${P}-sambalib.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+IUSE="gpm nls samba ncurses X slang"
+
+DEPEND=">=sys-fs/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( net-fs/samba )
+ X? ( virtual/x11 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ has_version '>=net-fs/samba-3.0.0' \
+ && epatch ${DISTDIR}/${P}-sambalib-3.0.0.patch.bz2
+ has_version '<net-fs/samba-3.0.0' \
+ && epatch ${DISTDIR}/${P}-sambalib.patch.bz2
+
+ epatch ${FILESDIR}/${P}-find.patch
+ epatch ${FILESDIR}/${P}-cpan-2003-1023.patch
+ epatch ${FILESDIR}/${P}-can-2004-0226-0231-0232.patch.bz2
+ epatch ${FILESDIR}/${P}-vfs.patch
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=""
+
+ if ! use slang && ! use ncurses ; then
+ myconf="${myconf} --with-screen=mcslang"
+ elif use ncurses && ! use slang ; then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ myconf="${myconf} `use_with gpm gpm-mouse`"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_with X x`"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages --with-privatedir=/etc/samba/private" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ --enable-charset \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
+ ${S}/lib/mc-wrapper.sh
+
+ einstall || die
+
+ dodoc ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+
+ insinto /usr/share/mc
+ doins ${FILESDIR}/mc.gentoo
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "allow mc to chdir to its latest working dir at exit"
+ einfo ""
+ einfo "# Midnight Commander chdir enhancement"
+ einfo "if [ -f /usr/share/mc/mc.gentoo ]; then"
+ einfo " . /usr/share/mc/mc.gentoo"
+ einfo "fi"
+}