summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-12-12 01:22:17 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-12-12 01:22:17 +0000
commit13672bdc27f15ca28d74baacc9a522d2700628d1 (patch)
tree0b960890d2c3b1cc694fe49f1116da26f5738bb2 /app-misc/livetools
parentEdit to ChangeLog (diff)
downloadgentoo-2-13672bdc27f15ca28d74baacc9a522d2700628d1.tar.gz
gentoo-2-13672bdc27f15ca28d74baacc9a522d2700628d1.tar.bz2
gentoo-2-13672bdc27f15ca28d74baacc9a522d2700628d1.zip
Initial import, ~x86 for testing
Diffstat (limited to 'app-misc/livetools')
-rw-r--r--app-misc/livetools/ChangeLog12
-rw-r--r--app-misc/livetools/files/digest-livetools-1.11
-rw-r--r--app-misc/livetools/livetools-1.1.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/livetools/ChangeLog b/app-misc/livetools/ChangeLog
new file mode 100644
index 000000000000..23cb7aa07822
--- /dev/null
+++ b/app-misc/livetools/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-misc/livetools
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header
+
+*livetools-1.1 (11 Dec 2002)
+
+ 11 Dec 2002; Matt Keadle <mkeadle@gentoo.org> livetools-1.1.ebuild
+ files/digest-livetools-1.1 :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. Thanks to Caleb Shay for submitting this ebuild
+ in bug #11744.
diff --git a/app-misc/livetools/files/digest-livetools-1.1 b/app-misc/livetools/files/digest-livetools-1.1
new file mode 100644
index 000000000000..123d69251d69
--- /dev/null
+++ b/app-misc/livetools/files/digest-livetools-1.1
@@ -0,0 +1 @@
+MD5 3cbac65587468395f39043d7e8733ac3 livetools-1.1.tar.bz2 142489
diff --git a/app-misc/livetools/livetools-1.1.ebuild b/app-misc/livetools/livetools-1.1.ebuild
new file mode 100644
index 000000000000..51b4ef3c0c15
--- /dev/null
+++ b/app-misc/livetools/livetools-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/livetools/livetools-1.1.ebuild,v 1.1 2002/12/12 01:22:17 mkeadle Exp $
+
+DESCRIPTION="A small set of utilities to allow easy access to Creative's SoundBlaster Live!Drive IR's remote control."
+HOMEPAGE="http://www.clarkson.edu/~evanchsa/software/livetools/"
+SRC_URI="http://www.clarkson.edu/~evanchsa/software/livetools/1.1/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Currently, this is only functional as a XMMS plugin
+# so it makes no sense to run it without XMMS. When it
+# becomes more generalized we can remove the XMMS dep.
+DEPEND="media-sound/xmms"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}