summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-10-26 20:59:08 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-10-26 20:59:08 +0000
commit75332fc69e7b72a367a8a85d601eb9a31d9f3569 (patch)
tree28ffc5bed2a45c20fe9e69ae993d302820a63524 /app-misc/hilite
parentFixed ebuild to use tc-getCC from toolchain-funcs.eclass, Closes #69016. (Man... (diff)
downloadgentoo-2-75332fc69e7b72a367a8a85d601eb9a31d9f3569.tar.gz
gentoo-2-75332fc69e7b72a367a8a85d601eb9a31d9f3569.tar.bz2
gentoo-2-75332fc69e7b72a367a8a85d601eb9a31d9f3569.zip
Don't use CC, bug #68981
Diffstat (limited to 'app-misc/hilite')
-rw-r--r--app-misc/hilite/ChangeLog5
-rw-r--r--app-misc/hilite/Manifest12
-rw-r--r--app-misc/hilite/hilite-1.5.ebuild6
3 files changed, 9 insertions, 14 deletions
diff --git a/app-misc/hilite/ChangeLog b/app-misc/hilite/ChangeLog
index fbaf106b23b4..a2750997a7b1 100644
--- a/app-misc/hilite/ChangeLog
+++ b/app-misc/hilite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/hilite
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hilite/ChangeLog,v 1.8 2004/10/15 23:47:06 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hilite/ChangeLog,v 1.9 2004/10/26 20:59:08 ciaranm Exp $
+
+ 26 Oct 2004; Ciaran McCreesh <ciaranm@gentoo.org> hilite-1.5.ebuild:
+ Don't use CC, bug #68981
16 Oct 2004; Tom Martin <slarti@gentoo.org> metadata.xml:
Added to the shell-tools herd for ciaranm.
diff --git a/app-misc/hilite/Manifest b/app-misc/hilite/Manifest
index 2adbd14dc532..a1f4fc98d90e 100644
--- a/app-misc/hilite/Manifest
+++ b/app-misc/hilite/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 0844f88375e873a1d97197894f724102 ChangeLog 921
+MD5 e013e22176bb69294266617d41055b17 hilite-1.5.ebuild 684
MD5 cc91d79e8dc6f0d1b9727eb83de5f98a metadata.xml 258
-MD5 9dd620c7f5beaa7c8433ba872331d1a2 hilite-1.5.ebuild 657
MD5 cc917381e52b9b4031849b400b4235ca files/digest-hilite-1.5 55
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBcGGNCHk4+ZoBpvsRAuvBAJwNc6jtlyGGV4F+zapACgoTt8zdTACgjlHu
-vRdMWkKQgUsdfPFhWg1WRV0=
-=Ipcx
------END PGP SIGNATURE-----
diff --git a/app-misc/hilite/hilite-1.5.ebuild b/app-misc/hilite/hilite-1.5.ebuild
index c0b58e2bd779..746b480ab0c4 100644
--- a/app-misc/hilite/hilite-1.5.ebuild
+++ b/app-misc/hilite/hilite-1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hilite/hilite-1.5.ebuild,v 1.7 2004/10/05 13:34:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hilite/hilite-1.5.ebuild,v 1.8 2004/10/26 20:59:08 ciaranm Exp $
+
+inherit toolchain-funcs
HOMEPAGE="http://sourceforge.net/projects/hilite"
SRC_URI="mirror://gentoo/${PN}-${PV}.c"
@@ -20,7 +22,7 @@ src_unpack() {
}
src_compile() {
- ${CC:-gcc} ${CFLAGS} -o ${PN} ${PN}-${PV}.c \
+ $(tc-getCC ) ${CFLAGS} -o ${PN} ${PN}-${PV}.c \
|| die "compile failed"
}