summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-09-27 03:46:56 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-09-27 03:46:56 +0000
commitc499da7d09281859e67fd76f6d2d59c350586fb0 (patch)
tree83d6a6b5e406c7a7e7a73ad8e70a62097b519454 /app-misc/gpsdrive
parentAnother go at linguas fix (diff)
downloadgentoo-2-c499da7d09281859e67fd76f6d2d59c350586fb0.tar.gz
gentoo-2-c499da7d09281859e67fd76f6d2d59c350586fb0.tar.bz2
gentoo-2-c499da7d09281859e67fd76f6d2d59c350586fb0.zip
Updated ebuild for more recent version (closes bug #97208)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'app-misc/gpsdrive')
-rw-r--r--app-misc/gpsdrive/ChangeLog9
-rw-r--r--app-misc/gpsdrive/files/gpsdrive-drawmarkers-remove.patch26
-rw-r--r--app-misc/gpsdrive/gpsdrive-2.10_pre5.ebuild101
-rw-r--r--app-misc/gpsdrive/metadata.xml6
4 files changed, 140 insertions, 2 deletions
diff --git a/app-misc/gpsdrive/ChangeLog b/app-misc/gpsdrive/ChangeLog
index 83579da4b65d..eb75aa8d9fc3 100644
--- a/app-misc/gpsdrive/ChangeLog
+++ b/app-misc/gpsdrive/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/gpsdrive
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/ChangeLog,v 1.27 2008/07/31 16:16:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/ChangeLog,v 1.28 2008/09/27 03:46:55 nerdboy Exp $
+
+*gpsdrive-2.10_pre5 (26 Sep 2008)
+
+ 26 Sep 2008; Steve Arnold <nerdboy@gentoo.org>
+ +files/gpsdrive-drawmarkers-remove.patch, +gpsdrive-2.10_pre5.ebuild:
+ Updated ebuild for more recent version (closes bug #97208) with new mapnik
+ support (also closes bug #94334).
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-misc/gpsdrive/files/gpsdrive-drawmarkers-remove.patch b/app-misc/gpsdrive/files/gpsdrive-drawmarkers-remove.patch
new file mode 100644
index 000000000000..c831a36b4bc0
--- /dev/null
+++ b/app-misc/gpsdrive/files/gpsdrive-drawmarkers-remove.patch
@@ -0,0 +1,26 @@
+--- src/util/CMakeLists.txt.orig 2008-09-21 20:15:48.379309613 -0700
++++ src/util/CMakeLists.txt 2008-09-21 20:17:36.012310364 -0700
+@@ -25,13 +25,14 @@
+ install(TARGETS worldgen DESTINATION ${BIN_INSTALL_DIR})
+ endif (GDAL_FOUND)
+
+-if (GDAL_FOUND AND GTK2_FOUND)
+- add_executable(gmapview ${gmapview_SRCS})
+- target_link_libraries(gmapview
+- ${MAP_LIBRARY}
+- ${GDAL_LIBRARIES}
+- ${GTK2_LIBRARIES}
+- )
+- install(TARGETS gmapview DESTINATION ${BIN_INSTALL_DIR})
+-endif (GDAL_FOUND AND GTK2_FOUND)
++## this bombs because there's no implementation of drawmarkers
++#if (GDAL_FOUND AND GTK2_FOUND)
++# add_executable(gmapview ${gmapview_SRCS})
++# target_link_libraries(gmapview
++# ${MAP_LIBRARY}
++# ${GDAL_LIBRARIES}
++# ${GTK2_LIBRARIES}
++# )
++# install(TARGETS gmapview DESTINATION ${BIN_INSTALL_DIR})
++#endif (GDAL_FOUND AND GTK2_FOUND)
+
diff --git a/app-misc/gpsdrive/gpsdrive-2.10_pre5.ebuild b/app-misc/gpsdrive/gpsdrive-2.10_pre5.ebuild
new file mode 100644
index 000000000000..293ce489781f
--- /dev/null
+++ b/app-misc/gpsdrive/gpsdrive-2.10_pre5.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gpsdrive/gpsdrive-2.10_pre5.ebuild,v 1.1 2008/09/27 03:46:55 nerdboy Exp $
+
+inherit cmake-utils eutils fdo-mime
+
+DESCRIPTION="GPS navigation system with NMEA and Garmin support, zoomable map display, waypoints, etc."
+HOMEPAGE="http://www.gpsdrive.de/"
+SRC_URI="${HOMEPAGE}/packages/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+S=${WORKDIR}/${P/_/}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+# submit bug for ppc64
+
+IUSE="dbus debug doc gdal mapnik scripts"
+
+COMMON_DEP=">=x11-libs/gtk+-2.8.12
+ >=media-libs/libart_lgpl-2.3.17
+ >=media-libs/fontconfig-2.2.3
+ >=x11-libs/libXcursor-1.1.2
+ >=dev-libs/atk-1.10.3
+ >=dev-libs/libpcre-4.2
+ >=dev-libs/boost-1.33.1
+ >=gnome-extra/libgda-3.0.1
+ >=x11-libs/pango-1.10.1
+ >=dev-libs/glib-2.8.5
+ >=x11-libs/cairo-1.0.2
+ dbus? ( sys-apps/dbus )
+ mapnik? ( >=sci-geosciences/mapnik-0.5 )
+ gdal? ( sci-libs/gdal )"
+
+DEPEND="${COMMON_DEP}
+ >=dev-util/cmake-2.4.4
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEP}
+ dev-perl/libwww-perl
+ dev-perl/DBI
+ sci-geosciences/gpsd
+ media-fonts/dejavu"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # The utils won't build without some extra functions that
+ # aren't implemented yet AFAICT; temporarily disabled.
+ epatch "${FILESDIR}"/${PN}-drawmarkers-remove.patch
+ # Update mapnik font path...
+ use mapnik && sed -i -e "s:truetype/ttf-dejavu:dejavu:g" \
+ tests/{gpsdriverc,gpsdriverc-in,gpsdriverc-pre} \
+ src/gpsdrive_config.c || die "sed failed"
+ # Fix desktop file...
+ sed -i -e "s:gpsicon:/usr/share/gpsdrive/pixmaps/gpsicon.png:g" \
+ -e "s:Graphics;Network;Geography:Application;Geography;GPS:g" \
+ data/gpsdrive.desktop || die "sed failed"
+}
+
+src_compile() {
+ local mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with scripts SCRIPTS)
+ $(cmake-utils_use_with mapnik MAPNIK)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with gdal GDAL)"
+ MAKEOPTS="-j1" cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS Changelog NEWS README
+ newdoc data/mysql/my.cnf my.cnf.example
+ use mapnik && dodoc Documentation/install-mapnik-osm.txt
+ use doc && dodoc \
+ Documentation/{FAQ.gpsdrive,CREDITS,GPS-receivers,LEEME,NMEA.txt,TODO,README*}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ elog
+ elog "Be sure to see the README files in /usr/share/doc/${PF}"
+ elog "for information on using Kismet with gpsdrive. The MySQL"
+ elog "config is installed as an example, but using it with"
+ elog "gpsdrive is up to you. Additional scripts are still"
+ elog "shipped in the source package."
+ elog
+ elog "This version also now depends on the gpsd package, and"
+ elog "specific devices are supported there. Start gpsd first,"
+ elog "otherwise gpsdrive will only run in simulation mode (which"
+ elog "is sometimes handy for downloading maps for another"
+ elog "location)."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
+
diff --git a/app-misc/gpsdrive/metadata.xml b/app-misc/gpsdrive/metadata.xml
index dd8cfa3701fc..a603871aa73c 100644
--- a/app-misc/gpsdrive/metadata.xml
+++ b/app-misc/gpsdrive/metadata.xml
@@ -7,6 +7,10 @@
<name>Steve Arnold</name>
</maintainer>
<use>
- <flag name='garmin'>Adds specific support for Garmin GPS receivers</flag>
+ <flag name='garmin'>Adds specific support for Garmin GPS receivers (pre-2.10
+ only)</flag>
+ <flag name='gdal'>Include gdal and ogr support for format conversions.</flag>
+ <flag name='mapnik'>Include mapnik support for custom map creation.</flag>
+ <flag name='scripts'>Include some of the additional helper scripts.</flag>
</use>
</pkgmetadata>