summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-04 10:54:34 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-04 10:54:34 +0000
commit0c0537b8d5feaa911099dfe43c5f97c075f840e0 (patch)
treea18c77cc2239e5cee62eb8f1691761eb71148ce1 /app-misc/empty
parentStable for amd64, wrt bug #427774 (diff)
downloadgentoo-2-0c0537b8d5feaa911099dfe43c5f97c075f840e0.tar.gz
gentoo-2-0c0537b8d5feaa911099dfe43c5f97c075f840e0.tar.bz2
gentoo-2-0c0537b8d5feaa911099dfe43c5f97c075f840e0.zip
Respect LDFLAGS (bug 429664, thanks flameeyes for the report and pinkbyte for the suggested fix).
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/empty')
-rw-r--r--app-misc/empty/ChangeLog8
-rw-r--r--app-misc/empty/empty-0.6.18b.ebuild3
-rw-r--r--app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch11
3 files changed, 19 insertions, 3 deletions
diff --git a/app-misc/empty/ChangeLog b/app-misc/empty/ChangeLog
index 65f17b7db563..66b12fcb29d2 100644
--- a/app-misc/empty/ChangeLog
+++ b/app-misc/empty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/empty
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/ChangeLog,v 1.1 2012/06/18 16:40:50 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/ChangeLog,v 1.2 2012/08/04 10:54:34 xmw Exp $
+
+ 04 Aug 2012; Michael Weber <xmw@gentoo.org>
+ +files/empty-0.6.18b-respect-LDFLAGS.patch, empty-0.6.18b.ebuild:
+ Respect LDFLAGS (bug 429664, thanks flameeyes for the report and pinkbyte for
+ the suggested fix).
*empty-0.6.18b (18 Jun 2012)
@@ -8,4 +13,3 @@
+files/overflow-fixes.patch, +metadata.xml:
Add app-misc/empty, ebuild by James Le Cuirot <chewi@aura-online.co.uk>. Bug
#97387
-
diff --git a/app-misc/empty/empty-0.6.18b.ebuild b/app-misc/empty/empty-0.6.18b.ebuild
index 4aaa21c35254..544738568442 100644
--- a/app-misc/empty/empty-0.6.18b.ebuild
+++ b/app-misc/empty/empty-0.6.18b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/empty-0.6.18b.ebuild,v 1.1 2012/06/18 16:40:50 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/empty/empty-0.6.18b.ebuild,v 1.2 2012/08/04 10:54:34 xmw Exp $
EAPI="4"
inherit eutils
@@ -18,6 +18,7 @@ RDEPEND="virtual/logger"
src_prepare() {
epatch "${FILESDIR}/overflow-fixes.patch"
+ epatch "${FILESDIR}/${P}-respect-LDFLAGS.patch"
}
src_install() {
diff --git a/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch b/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..f839afcf28c9
--- /dev/null
+++ b/app-misc/empty/files/empty-0.6.18b-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- empty-0.6.18b/Makefile
++++ empty-0.6.18b/Makefile
+@@ -16,7 +16,7 @@
+ PREFIX = /usr/local
+
+ all:
+- ${CC} ${CFLAGS} -Wall ${LIBS} -o empty empty.c
++ ${CC} ${CFLAGS} ${LDFLAGS} empty.c ${LIBS} -o empty
+
+ FreeBSD: all
+ NetBSD: all