summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-12-15 21:26:33 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-12-15 21:26:33 +0000
commitae9647cc51d85ee99a28c0be27b55cab9cc01b7e (patch)
tree006db2bf45e3e793686c67583013dd72b7393355 /app-misc/discomatic
parentRemove old. (diff)
downloadgentoo-2-ae9647cc51d85ee99a28c0be27b55cab9cc01b7e.tar.gz
gentoo-2-ae9647cc51d85ee99a28c0be27b55cab9cc01b7e.tar.bz2
gentoo-2-ae9647cc51d85ee99a28c0be27b55cab9cc01b7e.zip
Fix building w/ gcc-4.3, #250684
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 i686)
Diffstat (limited to 'app-misc/discomatic')
-rw-r--r--app-misc/discomatic/ChangeLog8
-rw-r--r--app-misc/discomatic/discomatic-0.3.ebuild10
-rw-r--r--app-misc/discomatic/files/discomatic-0.3-gcc43.patch22
3 files changed, 34 insertions, 6 deletions
diff --git a/app-misc/discomatic/ChangeLog b/app-misc/discomatic/ChangeLog
index 9d33e025e590..df1941f21425 100644
--- a/app-misc/discomatic/ChangeLog
+++ b/app-misc/discomatic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/discomatic
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/ChangeLog,v 1.10 2007/05/05 08:56:38 dertobi123 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/ChangeLog,v 1.11 2008/12/15 21:26:32 dertobi123 Exp $
+
+ 15 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/discomatic-0.3-gcc43.patch, discomatic-0.3.ebuild:
+ Fix building w/ gcc-4.3, #250684
05 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+files/discomatic-0.3-glib.patch, discomatic-0.3.ebuild:
diff --git a/app-misc/discomatic/discomatic-0.3.ebuild b/app-misc/discomatic/discomatic-0.3.ebuild
index 4b0700c53821..e8252cd85ead 100644
--- a/app-misc/discomatic/discomatic-0.3.ebuild
+++ b/app-misc/discomatic/discomatic-0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.10 2007/05/05 08:56:38 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/discomatic/discomatic-0.3.ebuild,v 1.11 2008/12/15 21:26:32 dertobi123 Exp $
inherit gnome2 eutils
@@ -21,8 +21,10 @@ DEPEND=">=dev-libs/glib-2.2
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-glib.patch
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-glib.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
DOCS="AUTHORS ChangeLog INSTALL NEWS README* TODO"
diff --git a/app-misc/discomatic/files/discomatic-0.3-gcc43.patch b/app-misc/discomatic/files/discomatic-0.3-gcc43.patch
new file mode 100644
index 000000000000..e78d65f0b6dd
--- /dev/null
+++ b/app-misc/discomatic/files/discomatic-0.3-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naur discomatic-0.3.orig/src/folderutils.cpp discomatic-0.3/src/folderutils.cpp
+--- discomatic-0.3.orig/src/folderutils.cpp 2003-10-17 22:54:37.000000000 +0200
++++ discomatic-0.3/src/folderutils.cpp 2008-12-15 19:15:55.000000000 +0100
+@@ -6,6 +6,7 @@
+ #include "project.h"
+ #include "math.h"
+ #include <sstream>
++#include <cstring>
+
+ using namespace std;
+
+diff -Naur discomatic-0.3.orig/src/process.cpp discomatic-0.3/src/process.cpp
+--- discomatic-0.3.orig/src/process.cpp 2003-10-17 22:54:37.000000000 +0200
++++ discomatic-0.3/src/process.cpp 2008-12-15 19:18:33.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include "process.h"
+ #include <fstream>
++#include <cstring>
+
+ gboolean read_input(GIOChannel *source, GIOCondition condition, gpointer data){
+ ((Process*)data)->processInput(source);
+