summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 16:55:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 16:55:21 +0000
commit6d1a53ac4b063cdfe80c12710686795a8395f6df (patch)
treefe1f0c5e58c063e11b598c29e5acc6931df0c3e6 /app-misc/devtodo/devtodo-0.1.14.ebuild
parentadded kermit license (diff)
downloadgentoo-2-6d1a53ac4b063cdfe80c12710686795a8395f6df.tar.gz
gentoo-2-6d1a53ac4b063cdfe80c12710686795a8395f6df.tar.bz2
gentoo-2-6d1a53ac4b063cdfe80c12710686795a8395f6df.zip
repoman'd
Diffstat (limited to 'app-misc/devtodo/devtodo-0.1.14.ebuild')
-rw-r--r--app-misc/devtodo/devtodo-0.1.14.ebuild54
1 files changed, 12 insertions, 42 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.14.ebuild b/app-misc/devtodo/devtodo-0.1.14.ebuild
index 40c3a7dfef78..9e33fc94a37e 100644
--- a/app-misc/devtodo/devtodo-0.1.14.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.14.ebuild
@@ -1,59 +1,29 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.14.ebuild,v 1.1 2002/07/24 10:03:58 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.14.ebuild,v 1.2 2002/07/25 16:55:21 seemant Exp $
-SLOT="0"
-KEYWORDS="x86"
-LICENSE="GPL-2"
-
-#Source directory; the dir where the sources can be found (automatically unpacked)
S=${WORKDIR}/${P}
-
-#Short one-line description
DESCRIPTION="A nice command line todo list for developers"
-
-#Point to any required sources; these will be automatically downloaded by Portage
SRC_URI="http://devtodo.sourceforge.net/${PV}/${P}.tar.gz"
-
-#Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://devtodo.sourceforge.net/"
-#build-time dependencies
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1
- >=sys-devel/gcc-2.95.3"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
-#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
src_compile() {
- #the "try" command will stop the build process if the specified command fails. Prefix critical
- #commands with "try"
- try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --sysconfdir=/etc/devtodo --host=${CHOST}
- #Note the use of --infodir and --mandir, above. This is to make this package FHS 2.2-compliant
- #(/usr/share is used for info and man now).
+ econf --sysconfdir=/etc/devtodo || die
- try make
- #emake (previously known as pmake) is a script that calls the standard GNU make with parallel
- #building options for speedier builds on SMP systems. Use emake first; it might not work. If
- #not, then replace the line above with:
-
- #try make
+ make || die
}
src_install () {
- #you must *personally verify* that this trick doesn't install
- #anything outside of DESTDIR; do this by reading and understanding
- #the install part of the Makefiles. Also note that this will often
- #also work for autoconf stuff (usually much more often than DESTDIR,
- #which is actually quite rare.
-
- # try make prefix=${D}/usr install
-
- try make DESTDIR=${D} install
- #again, verify the Makefiles! We don't want anything falling outside
- #of ${D}.
+ make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog QuickStart README TODO doc/scripts.sh doc/scripts.tcsh doc/todorc.example contrib/tdrec
+ dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
+ dodoc doc/scripts.sh doc/scripts.tcsh doc/todorc.example contrib/tdrec
}